my ini

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

my ini

Postby billa » 06. July 2004 13:55

Hallo,
kann mir jemand die Konsequenzen sagen, wenn man in Windows2000 in WINNT die my.ini nicht anlegt?

Wenn ich diese nämlich nicht anlege, dann funktioniert bei mir xampp einwandfrei. Sobald ich die my.ini aber anlegen lasse duch Mysql/bin/mysqladmin, die beiden Eingaben (Passwort + Name) dann kommt immer eine Fehlermeldung und der Datenbankzugriff geht nur noch eingeschränkt.

Danke
billa
 
Posts: 48
Joined: 05. May 2004 16:56

Postby Wiedmann » 06. July 2004 14:06

kann mir jemand die Konsequenzen sagen, wenn man in Windows2000 in WINNT die my.ini nicht anlegt?
...
Wenn ich diese nämlich nicht anlege, dann funktioniert bei mir xampp einwandfrei.

Ist immer eine Frage wie du MySQL überhaupt startest. Beim Start über die Batchdatei wird beim XAMPP glaub sowieso die in "\xampp\mysql\bin" benutzt.

Sobald ich die my.ini aber anlegen lasse duch Mysql/bin/mysqladmin

Wie willst du das machen? mysqladmin hat nichts mit der my.ini zu tun. Die mußt du selbst mit einem Texteditor anlegen.

die beiden Eingaben (Passwort + Name)

Was für Eingaben? In welchem Programm und wann führst du die Eingaben aus?

dann kommt immer eine Fehlermeldung

Wann kommt eine Fehlermeldung, in welchem Programm und welche?

und der Datenbankzugriff geht nur noch eingeschränkt.

Mit welchem Client greifst du da auf MySQL zu und wie?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

my ini

Postby billa » 06. July 2004 17:43

Hallo,
vielen Dank für Deine schnelle Antwort!
Diese Problem beschäftigt mich schon von Anfang an, seit ich mich mit xampp beschäftige. Habe schon alles mögliche im Forum dazu gelesen, aber nirgends eine eindeutige Erklärung gefunden. Gleich am Anfang meiner Gehversuche las ich, daß man nach erfolgreicher Installation nach z.B. d:\xampp\mysql\bin\winmysqladmin.exe sich begeben und diese winmysqladmin.exe ausführen soll. Das tat ich dann auch viele male und jedes mal kommt dann nach einem Neustart des Rechners diese Meldung:

###Apache + Mysql is starting Now###
[Sat jul 03 19:07:58 2004] [notice] Disabled use of AcceptEx<> Winsock2 API
Beende ich dann xampp und starte es erneu, kommt diese etwas abgewandelte Nachricht:
Please wait [Bitte warten] [Sat Jul 03 19:25:09 2004] [notice] Disabled use of AcceptEx<> Winsock2 API
Can´t start Server: Bind on TCP/IP port: No error
040703 19:25:09 Do you already have another mysqld server running on port 3306 ?
040703 19:25:09 Aborting
040703 19:25:09 mysql\bin\mysql.exe: Shutdown complette...

### APACHE + MYSQL IS STARTING NOW ###

Ich habe die neueste Installer-Version heute unter Windows2000 installiert und die xampp_start.exe in autostart eingebunden. Wenn ich jetzt den Rechner starte läuft alles super ohne Probleme.
Folge ich den Anweisungen, die ich im Forum gefunden habe und führe das obig geschilderte aus, so öffnet sich ein Fenster in welches ich ein Kennwort und Namen eingeben soll.
Laut Anweisung soll das wichtig sein, weil dadurch die DB sicherer wird?

Nachdem das gemacht ist, wird die my.ini in WINNT automatisch angelegt.
Beim nächsten Start kommt dann die obige Fehlermeldung und rechts unten In der Taskleiste ein Ampelsymbol.
Dieses Ampel-Symbol hätte ich schon ganz gerne als Anzeige.
Aber dann ist es mir nicht mehr möglich eine neue Datenbank anzulegen. Das Abrufen von Daten aus einer vorhandenen DB funktioniert dann allerdings immer noch. Mit phpmyadmin greife ich momentan auf die DB zu.

Ursprünglich wollte ich folgendes haben:
Mysql und Apache starten automatisch und durch das Ampel-Symbol bekomme ich angezeigt, ob die DB funktioniert.
Beides scheint so nicht zu gehen.

Wie macht Ihr denn das?

Liebe Grüße
billa
 
Posts: 48
Joined: 05. May 2004 16:56


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 9 guests