Absturz von Apache bei starker Mysql belastung!

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Absturz von Apache bei starker Mysql belastung!

Postby Saro » 06. July 2004 09:53

Servus,

also ich habe jetzt versucht verschiedene Foren zu installieren:

phpBB
phpBB Plus 1.3
Minevra
Invisionboard

usw.

Aber immer das gleiche sobald ich einen Thread lesen möchte bzw. öffne und der einen größeren Datensatz aus der Datenbank ausliest kommt auf einmal das Windows Fenster: Apache HTTP Server hat ein Problem festegtellt und muss beendet werden.

Bei den Details steht:
AppName: apache.exe
AppVer: 2.0.50.0
ModName: zendoptimizer.dll
ModVer:0.0.0.0
Offset: 0002b867

Betriebssystem: WinXP Home
Prozessor: AMD Athlon XP 1800+
XAMPP Version: 1.4.4
Festplatte mit NTFS Formatiert und die andere mit FAT32 aber egal kommt bei beiden.
Saro
 
Posts: 2
Joined: 06. July 2004 09:44

Postby Wiedmann » 06. July 2004 09:58

ModName: zendoptimizer.dll

Und wenn du den Optimizer in der php.ini nicht laden lässt?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Saro » 06. July 2004 10:05

Wie tu ich den denn nicht laden? Wenn ich Ahnung davon hätte würde ich ja kein komplett Paket benutzen :-)

Habe jetzt einfach aus:

Code: Select all
[Zend]
;zend_optimizer.enable_loader = 0
zend_optimizer.optimization_level=1023
;zend_extension="\xampp\php\zendOptimizer\lib\Optimizer-2.5.2\php-4.3.x\ZendOptimizer.dll"
zend_extension_ts="\xampp\php\zendOptimizer\lib\ZendExtensionManager.dll"
zend_extension_manager.optimizer_ts="\xampp\php\zendOptimizer\lib\Optimizer-2.5.2"
;zend_optimizer.license_path="\xampp\licenses\zendOptimizer\license.txt"


Code: Select all
[Zend]
;zend_optimizer.enable_loader = 0
;zend_optimizer.optimization_level=1023
;zend_extension="\xampp\php\zendOptimizer\lib\Optimizer-2.5.2\php-4.3.x\ZendOptimizer.dll"
;zend_extension_ts="\xampp\php\zendOptimizer\lib\ZendExtensionManager.dll"
;zend_extension_manager.optimizer_ts="\xampp\php\zendOptimizer\lib\Optimizer-2.5.2"
;zend_optimizer.license_path="\xampp\licenses\zendOptimizer\license.txt"


gemacht und es funktioniert (Wieso nicht mit???) aber richtig so oder habe ich zuviel deaktiviert?
Saro
 
Posts: 2
Joined: 06. July 2004 09:44

Postby Wiedmann » 06. July 2004 11:12

Wenn ich Ahnung davon hätte würde ich ja kein komplett Paket benutzen

Da siehst du mal. Ich wusste gar nicht das der mittlerweile beim XAMPP standardmässig dabei ist... danke.

aber richtig so oder habe ich zuviel deaktiviert?

Pass schon. Wenn auch die Zeile mit "zend_extension_ts" gelangt hätte. Die anderen Anweisungen werden ja nur benutzt wenn diese Erweiterung geladen wird.

gemacht und es funktioniert (Wieso nicht mit???)

Keine Ahnung *g* . Die Fehlermeldung hat halt gesagt das dieses der Auslöser war. Da müsstest du mal bei Zend oder phpBB im Forum vorbeischauen und forschen.

Hab das mal mit meiner php.ini verglichen. Ich hab zend_optimizer.optimization_level nur auf 15 stehen. Und "zend_optimizer.enable_loader = 0" ist aktiviert (ohne ";"). Kannst ja mal probieren ob das schon langt (hab aber auch nur den Optimizer 2.5.1 laufen).
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby WebY » 10. July 2004 21:08

Hab jetzt bei mri so gemacht:


Code: Select all
[Zend]
;zend_optimizer.enable_loader = 0
;zend_optimizer.optimization_level=1023
;zend_extension="\xampp\php\zendOptimizer\lib\Optimizer-2.5.2\php-4.3.x\ZendOptimizer.dll"
;zend_extension_ts="\xampp\php\zendOptimizer\lib\ZendExtensionManager.dll"
;zend_extension_manager.optimizer_ts="\xampp\php\zendOptimizer\lib\Optimizer-2.5.2"
;zend_optimizer.license_path="\xampp\licenses\zendOptimizer\license.txt"



immernoch den Fehler ;(
WebY
 
Posts: 14
Joined: 08. July 2004 14:55

Postby Wiedmann » 10. July 2004 21:51

Wenn du das in der richtigen php.ini gemacht hast, und den Apachen neu gestartet hast, ist das kaum zu glauben...
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 14 guests