Problem mit Eingabe in openssl.exe

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Postby Wiedmann » 28. January 2005 23:47

Der ServerName ist : "ssl.mdg-webmaster.cjb.net"
Der CN im Zertifikat ist: "https://ssl.mdg-webmaster.cjb.net"

--> Da ist ein "https://" zuviel.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby mdg-webmaster » 28. January 2005 23:53

axo, man darf also im Zertifikat kein https:// davor setzen. Ok, ich werde das jetzt nochmal machen. Danke.

mdg-webmaster
mdg-webmaster
 
Posts: 21
Joined: 24. January 2005 00:31

Postby Wiedmann » 29. January 2005 00:04

Zitat aus diesem Thread:
Wiedmann wrote:Bei "Common Name" muß der ServerName (DNS-Name) von deinem Server hin.

Und "https://" (das benutze Protokoll für den Zugriff) gehört nicht zu einem DNS-Eintrag. Oder hast z.B: sowas, mit dem davor, schonmal anpingen können?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby mdg-webmaster » 29. January 2005 00:49

Jo, manchmal bedenkt man solche Dinge nicht ;) Danke, jetzt klappt es. Dine Batch find ich klasse.

mdg-webmaster
mdg-webmaster
 
Posts: 21
Joined: 24. January 2005 00:31

bekomme beim Aufruf der makecert.bat nur Fehlermeldungen

Postby Creed » 29. May 2005 23:21

Hallo Leute.

Habe folgendes Problem.
Ich habe mir den Code von Wiedmann wie beschrieben kopiert und nur den Pfad in Zeile 2 angepasst.

Also so.

Code: Select all
set OPENSSL_CONF=E:/xampp/apache/bin/openssl.cnf


Das ganze dann als makecert.bat im E:/xampp/apache/bin abgespeichert.
In der Eingabeaufforderung habe ich dann folgendes eingegeben.

E:\>\xampp\apache\bin\makecert.bat

Beim Bestätigen mit der enter Taste, bekomme ich folgende Fehler angezeigt.

E:\>\xampp\apache\bin\makecert.bat
Der Befehl "openssl" ist entweder falsch geschrieben oder
konnte nicht gefunden werden.
Der Befehl "openssl" ist entweder falsch geschrieben oder
konnte nicht gefunden werden.
Der Befehl "openssl" ist entweder falsch geschrieben oder
konnte nicht gefunden werden.
E:\.rnd konnte nicht gefunden werden
E:\privkey.pem konnte nicht gefunden werden
E:\server.csr konnte nicht gefunden werden
Das System kann die angegebene Datei nicht finden.
Das System kann die angegebene Datei nicht finden.

E:\>


Die Dateien .rnd und privkey.pem, werden zwar in dem Verzeichnis wo die makecert.bat drinne liegt erstellt, aber die server.csr fehlt.

Ich habe keine Ahnung woran das liegt.

Wenn ich die makecert.bat im E:/xampp/apache/bin Verzeichnis direkt anklicke, bekomme ich folgendes in der Eingabeaufforderung angezeigt.


Loading 'screen' into random state - done
Generating a 1024 bit RSA private key
............++++++
......++++++
writing new private key to 'privkey.pem'
Enter PEM pass phrase:



Die Dateien .rnd und privkey.pem, werden auch wieder in dem Verzeichnis wo die makecert.bat drinne liegt erstellt, aber die server.csr fehlt immer noch.
Und ich kann im Fenster der Eingabeaufforderung nichts eintragen, wenn ich die makecert.bat direkt aufrufe. :?

Denke aber mal, dass die server.csr sowiso erst erstellt wird, wenn ich die Passwörter eingegeben habe und die noch fehlenden anderen Angaben zum Server gemacht habe.

Habe das Packet xampp-win32-1.4.13 ohne irgendwelche Addons installiert.


Kann mir dazu bitte jemand weiterhelfen, oder mir sagen, was ich falsch mache?

Danke im Vorraus.

Gruß
Creed
Creed
 
Posts: 20
Joined: 01. August 2003 18:32

Postby Wiedmann » 30. May 2005 12:57

E:\>\xampp\apache\bin\makecert.bat
Beim Bestätigen mit der enter Taste, bekomme ich folgende Fehler angezeigt.
...

Wenn man diese Bachdatei in der Konsole ausführt, muss man zuvor in das Verzeichnis wechseln:
Code: Select all
E:
CD \xampp\apache\bin
makecert.bat


Wenn ich die makecert.bat im E:/xampp/apache/bin Verzeichnis direkt anklicke, bekomme ich folgendes in der Eingabeaufforderung angezeigt.
...

Sieht doch gut aus...

Die Dateien .rnd und privkey.pem, werden auch wieder in dem Verzeichnis wo die makecert.bat drinne liegt erstellt, aber die server.csr fehlt immer noch.

Eigentlich sollte er die drei Dateien am Schluss wiede löschen. Wäre also normal wenn danach keine "server.csr" da ist.

Und ich kann im Fenster der Eingabeaufforderung nichts eintragen, wenn ich die makecert.bat direkt aufrufe.

? Sollte kein Problem sein da was einzugeben.

Hast du irgendwelche Tuningtools benutzt, welche das Verhalten der Eingabeaufforderung verändern?

Schau doch ob "server.crt" und "server.key" in den entsprechenden Unterverzeichnissen von "..\conf" nicht doch aktualisiert wurden.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Creed » 30. May 2005 15:05

Hallo Wiedmann.

Danke Dir erstmal für deine Antwort.

Habe die makecert.bat jetzt mal so wie du es beschrieben hast, in der
Eingabeaufforderung aufgerufen.

Das Ergebnis ist folgendes.

Anzeige in der Eingabeaufforderung.

C:\Dokumente und Einstellungen\Administrator>E:

E:\>CD \xampp\apache\bin

E:\xampp\apache\bin>makecert.bat
Loading 'screen' into random state - done
Generating a 1024 bit RSA private key
......................++++++
.............++++++
writing new private key to 'privkey.pem'
Enter PEM pass phrase:
Verifying - Enter PEM pass phrase:
Verify failure
Enter PEM pass phrase:


Die Dateien .rnd und privkey.pem, werden auch wieder erstellt. Die server.csr, fehlt wieder.

Leider habe ich jetzt wieder das gleiche Problem wie mit dem direkten Aufruf der makecert.bat.
Ich kann in der Eingabeaufforderung nichts eingeben, weder Buchstaben noch Zahlen.
Dadurch ist auch der Verify failure entstanden, weil ich 2x kein Passwort eingegeben und nur mit Enter weitergeklickt habe!


Hast du irgendwelche Tuningtools benutzt, welche das Verhalten der Eingabeaufforderung verändern?


Nein, habe ich nicht.
Win2k Prof. frisch installiert und dann direkt den xampp hinterher.
Natürlich noch einen Virus-Scanner mit Firewall und Spyware Remover.
Aber kein XP Antispy. Ansonsten noch alle Gängigen Browser.


Schau doch ob "server.crt" und "server.key" in den entsprechenden Unterverzeichnissen von "..\conf" nicht doch aktualisiert wurden.


Nein, das Erstellungsdatum der jeweiligen Dateien haben alle ein Erstellungsdatum zwischen 2001 und 2002.

Weiss echt nicht woran das liegen kann.
Bei der Vergabe eines Passwortes für Mysql, kann ich aber in der Eingabeaufforderung meine Angaben machen.
( Dies nur als Anmerkung, falls dir der Gedanke kommt. Ob ich überhaupt etwas in der Eingabeaufforderung eingeben kann. )


Gruß
Creed
Creed
 
Posts: 20
Joined: 01. August 2003 18:32

Postby Wiedmann » 30. May 2005 15:33

Leider habe ich jetzt wieder das gleiche Problem wie mit dem direkten Aufruf der makecert.bat. Ich kann in der Eingabeaufforderung nichts eingeben, weder Buchstaben noch Zahlen.

Hm, während der Eingabe der "PEM pass phrase" wird am Bildschirm auch nichts angezeigt.

Dadurch ist auch der Verify failure entstanden, weil ich 2x kein Passwort eingegeben und nur mit Enter weitergeklickt habe!

Wenn man da einfach Enter drückt, macht er nicht weiter. Der frägt solange nach einer gültigen "PEM pass phrase" bis 2x das Gleiche eingegeben wurde.

BTW: du meintest doch gedrückt und nicht "weitergeklickt"? --> mit der Maus ist da ja nichts zu bedienen...
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Creed » 31. May 2005 13:48

Hallo,

Hm, während der Eingabe der "PEM pass phrase" wird am Bildschirm auch nichts angezeigt.


Ja, es kommt keine Fehlermeldung und auch keine Hinweise, die auf die nicht Funktionalität hinweisen könnten. Der Curser bleibt hinter Enter PEM pass phrase:_, beim Versuch der Eingabe am blinken und zeigt weder eingegebene Buchstaben, noch Zahlen an.


Dies ist genau der Text, der mir beim Aufruf der makecert.bat über die Eingabeaufforderung angezeigt wird.


C:\Dokumente und Einstellungen\Administrator>E:

E:\>CD \xampp\apache\bin

E:\xampp\apache\bin>makecert.bat
Loading 'screen' into random state - done
Generating a 1024 bit RSA private key
......................++++++
.............++++++
writing new private key to 'privkey.pem'
Enter PEM pass phrase:_


Leider ohne Chance etwas einzugeben.


BTW: du meintest doch gedrückt und nicht "weitergeklickt"? --> mit der Maus ist da ja nichts zu bedienen...


Ja, ich meinte das weiter drücken über die Enter Taste, nach dem ich nichts in der Eingabeaufforderung eingegeben bekommen hatte.


An einem defekten Betriebssystem könnte es eigentlich nicht liegen.
Sonst könnte ich ja die makecert.bat noch nicht mal über die Eingabeaufforderung aufrufen, denke ich.

Wird denn die server.csr auch direkt beim Aufruf der makecert.bat erzeugt?
Frage dies nur, weil ja die Dateien .rnd und privkey.pem direkt beim Aufruf erzeugt werden und nur die server.csr fehlt.


Gruß
Creed
Last edited by Creed on 31. May 2005 18:53, edited 4 times in total.
Creed
 
Posts: 20
Joined: 01. August 2003 18:32

Postby Creed » 31. May 2005 18:43

Ein kurzer Nachtrag zu meinem obigen Post.

Ich habe die makecert.bat nochmal auf 2 anderen PC´s getestet, auf denen der XAMPP mit Apache/2.0.48, mod_ssl/2.0.48 und OpenSSL/0.9.7c installiert ist.
Ein PC davon mit WinXP Prof. & SP2, und der andere auch mit Win2k Prof. & SP4.
Bei beiden PC´s habe ich genau das gleiche Problem mit der makecert.bat.
Ich kann auf beiden PC´s nach dem Aufruf der makecert.bat, nichts in der Eingabeaufforderung eingeben.

Langsam bin ich echt am verzweifeln.


Creed
Creed
 
Posts: 20
Joined: 01. August 2003 18:32

Postby Wiedmann » 31. May 2005 18:46

Ich kann auf beiden PC´s nach dem Aufruf der makecert.bat, nichts in der Eingabeaufforderung eingeben.

Kannst du dieses "nichts in der Eingabeaufforderung eingeben" mal genauer beschreiben/erklären?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Creed » 31. May 2005 19:03

Hi.

Ja, ist ganz einfach.
Der Curser blinkt hinter Enter PEM pass phrase:_ und erwartet dort ja die Eingabe des Passwortes. Wenn ich jetzt 123456 eingeben würde, müsste die Eingabe ja folgendermaßen aussehen.

C:\Dokumente und Einstellungen\Administrator>E:

E:\>CD \xampp\apache\bin

E:\xampp\apache\bin>makecert.bat
Loading 'screen' into random state - done
Generating a 1024 bit RSA private key
......................++++++
.............++++++
writing new private key to 'privkey.pem'
Enter PEM pass phrase:123456


Nach dem drücken der Enter Taste, müsste dann die Aufforderung zum verifizieren des Passwortes kommen.
Oder irre ich mich da jetzt?

Diese 123456 werden aber hinter Enter PEM pass phrase:_ nicht angezeigt in der Eingabeaufforderung. Der Curser bleibt an der gleichen Stelle stehen und blinkt nur.

Gruß
Creed
Creed
 
Posts: 20
Joined: 01. August 2003 18:32

Postby Wiedmann » 31. May 2005 19:06

Diese 123456 werden aber hinter Enter PEM pass phrase:_ nicht angezeigt in der Eingabeaufforderung. Der Curser bleibt an der gleichen Stelle stehen und blinkt nur.

Ich zitiere mich mal:
Wiedmann wrote:Hm, während der Eingabe der "PEM pass phrase" wird am Bildschirm auch nichts angezeigt.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Creed » 31. May 2005 19:09

Dies habe ich mir schon gedacht, dass dies etwas undeutlich geschrieben war.
Deshalb habe ich meinen vorletzten Beitrag auch nochmal editiert. :wink:
Creed
 
Posts: 20
Joined: 01. August 2003 18:32

Postby Wiedmann » 31. May 2005 19:42

:?:
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Previous

Return to XAMPP für Windows

Who is online

Users browsing this forum: wodim and 7 guests