MySQL Error 1045

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

MySQL Error 1045

Postby Sandy » 01. July 2004 02:35

Hallo,
ich bin absoluter Anfänger und habe ein Problem: Nach der Installation lief Mysql zuerst. Nachdem ich den Rechner neu hochgefahren habe, funktioniert es nicht mehr.
Der Apache Server läuft, bei Status wird aber MySql Datenbank "deaktiviert" angezeigt. Wenn ich versuche, die mysql.exe per hand zu starten, kommt in einem Dos-Fenster ganz kurz die Meldung: Error 1045, dann schließt sich das Fenster wieder. Meine Error-log Datei sieht folgendermaßen aus:

mysql\bin\mysqld.exe: ready for connections.
Version: '4.0.20a-debug-log' socket: '' port: 3306
040630 17:26:03 Aborted connection 4 to db: 'webauth' user: 'ODBC' host: `localhost' (Got an error reading communication packets)
040630 17:54:38 Aborted connection 5 to db: 'testdatabase' user: 'ODBC' host: `localhost' (Got an error reading communication packets)
040630 18:05:56 Aborted connection 6 to db: 'testdatabase' user: 'ODBC' host: `localhost' (Got an error reading communication packets)
mysql\bin\mysqld.exe: ready for connections.
Version: '4.0.20a-debug-log' socket: '' port: 3306
mysql\bin\mysqld.exe: ready for connections.
Version: '4.0.20a-debug-log' socket: '' port: 3306

Ich wäre wirklich dankbar, wenn mir hier jemand weiterhelfen könnte.
Vielen Dank im voraus!
Sandy
Sandy
 
Posts: 3
Joined: 01. July 2004 02:28

Postby Rolidor » 01. July 2004 12:56

Servus.
Hast du's mal mit der 'mysql_start.bat' im XAMPP-Verzeichnis versucht?

Rolo
Rolidor
 
Posts: 406
Joined: 20. April 2004 10:17
Location: Dreieich - Hessen

Postby Sandy » 01. July 2004 15:32

Danke für Deine Antwort.

Ja, ich habe es mit der Mysql_start.bat probiert. Da öffnet sich ein Dos-Fenster, das sagt, daß Mysql gestartet wird. Es schließt sich aber gleich wieder und alles ist wie vorher, d.h. es funktioniert nicht.

Irgendwelche anderen Vorschläge?
Danke
Sandy
Sandy
 
Posts: 3
Joined: 01. July 2004 02:28

Postby Rolidor » 01. July 2004 19:18

Hallo.
Kann es sein, dass du User gelöscht oder Passwörter für mysql-user vergeben hast? Der Fehler 1045 tritt nähmlich in genau diesen Fällen auf, wenn etwa ein User (für mysql) nicht existiert oder das Passwort falsch ist. Wenn du noch nichts wichtiges in der DB abgelegt hast, hilft im Zweifelsfall eine Neuinstallation (keine große Sache).

Gruß
Rolo
Rolidor
 
Posts: 406
Joined: 20. April 2004 10:17
Location: Dreieich - Hessen

Postby Sandy » 02. July 2004 01:45

Nein, ich habe keine User oder Passwörter verändert (soweit bin ich noch gar nicht, daß ich wüßte wie das geht).
Aber ich habe alles nochmal runtergeschmissen und neu installiert. Jetzt scheint es soweit zu klappen.
Vielen Dank nochmal für die Hilfe!
Sandy
Sandy
 
Posts: 3
Joined: 01. July 2004 02:28


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 14 guests

cron