Xampp 1.8.2.-1 und Win8 64bit; Problem mit php-scripts

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Xampp 1.8.2.-1 und Win8 64bit; Problem mit php-scripts

Postby haboma » 08. August 2013 20:41

Habe neuen Rechner mit Win8. Xampp 1.8.2-1 erfolgreich installiert (Installer-Vers). Apache und MySQL laufen. Kann mit phpmyadmin die DB problemlos aufsuchen.
Aber: einzelne php-Seiten werden nicht richtig angezeigt. Eine Navigation, die per php included ist, erscheint gar nicht. Ein anderes script: statt einer DB-Verbindung wird "Invalid query:26 No database selected" angezeigt. Eine weitere php-Seite wird angezeigt, statt interpretiert.
Die DB wird aber mit richtigen Parametern aufgerufen. Das identische script (und auch die inkludierte Navigation) läuft auf einem anderen Rechner (Win7 Prof; Xampp 1.8.1) einwandfrei, wie die ganze übrige Site.
Ich habe auf meiner lokalen Entwicklungsumgebung 3 versch. Websites getestet (mit z.T. identischem DB-connect). Eines läuft tadellos, die zwei anderen nicht (s. Fehlerbeschreibung oben). Auch auf dem Remote-Server (die Sites sind online) laufen alle drei einwandfrei.
Ich weiss beim besten Willen nicht, wo ich mit der Fehlersuche beginnen soll. Bin laienhafter Webdesigner, kein Crack. Bisher probiert: Neuinstallation, Deinstallation von Skype (wegen Port). httpd.conf geändert 'Listen Port 8080' statt 80 (dann wieder zurückversetzt in orig-Zustand, da ohne Erfolg). Älterne Xampp-Version installiert (eben 1.8.1, das auf dem anderen Rechner mit Win7 problemlos läuft). Jedesmal dazwischen restore (da es sich um ein Neugerät handelt).
Ich weiss nicht einmal, ob dieses Posting hier am richtigen Ort ist.
Kann mir jemand helfen, oder mich an den richtigen Ort weiterweisen? Für Hilfe bin ich sehr dankbar.
haboma
 
Posts: 5
Joined: 08. August 2013 20:05
XAMPP Version: 5.6.3
Operating System: Windows 8

Re: Xampp 1.8.2.-1 und Win8 64bit; Problem mit php-scripts

Postby WilliL » 08. August 2013 21:14

ich habe mir meine Änderungen in den Konfigurationsdateien mit Remarks kommentiert, um sie wieder finden zu können.

Was hast du an Konfigs in der anderen Installation geändert?
"Invalid query:26 No database selected" angezeigt
wir wohl recht haben - ggf Änderung in der Strukture oder eine vergessen .htacces od eine vhosts Direktive...

Hier kannst du nur einen Punkt nach dem anderen angehen.
Willi
WilliL
 
Posts: 621
Joined: 08. January 2010 10:54
XAMPP Version: 5.5.19
Operating System: Win7Home Prem 64 SP1

Re: Xampp 1.8.2.-1 und Win8 64bit; Problem mit php-scripts

Postby Nobbie » 08. August 2013 21:38

Das hat mit Neuinstallation, Skype und Co. nichts im geringsten zu tun.

Das sind Konfigurationsprobleme innerhalb von PHP (wahrscheinlich) und/oder Releasequerstände. Hier weiß ja keiner, in welcher Umgebung die Scripts fehlerfrei liefen.
Nobbie
 
Posts: 6630
Joined: 09. March 2008 13:04

Re: Xampp 1.8.2.-1 und Win8 64bit; Problem mit php-scripts

Postby haboma » 08. August 2013 22:51

-Ich habe in der httpd.conf nur den Port von 80 auf 8080 geändert, da es aber nichts brachte, wieder zurück auf den Originalzustand (Port 80) gesetzt.
-Skype habe ich deinstalliert, weil gelesen habe, dass Skype den gleichen Port wie Apache benutzt. Auch das war nur ein Versuch, das Problem einzugrenzen.
-Neuinstallation habe ich gemacht, um sicher zu gehen, dass nicht irgendwo in den Win8-Eingeweiden etwas zurück bleibt.
-Was die nicht bekannt sein sollende Umgebung anbelangt, weiss ich nicht, was gemeint ist. Die funktionierende lokale Umgebung ist wie gesagt Win7Prof und Xampp 1.8.1 (mit PHP 5.4.7). Die remote-Umgebung kenne ich nicht; es ist der Webserver des Hosters. Auch mit früheren Xampp-Installationen haben die scripts einwandfrei funktioniert.
-Sind Code-Beispiele und Pfadstruktur erwünscht?
haboma
 
Posts: 5
Joined: 08. August 2013 20:05
XAMPP Version: 5.6.3
Operating System: Windows 8

Re: Xampp 1.8.2.-1 und Win8 64bit; Problem mit php-scripts

Postby haboma » 08. August 2013 23:07

Nachtrag:
- ich habe soeben Xampp 1.8.3 installiert. Nichts ändert.
- Sowohl Xampp 1.8.1 (mit PHP 5.4.7) auf Win7, als auch Xampp 1.8.2-1 auf Win8 sind direkt in C:/ installiert.
- Die scripts funktionieren mit Xampp 1.8.1 (mit PHP 5.4.7) auf Win7 und haben auch mit älteren Xampp-Versionen (auch unter WinXP) funktioniert. Gleiche scripts, gleiche DB etc.
haboma
 
Posts: 5
Joined: 08. August 2013 20:05
XAMPP Version: 5.6.3
Operating System: Windows 8

Re: Xampp 1.8.2.-1 und Win8 64bit; Problem mit php-scripts

Postby Altrea » 09. August 2013 06:13

haboma wrote:-Sind Code-Beispiele und Pfadstruktur erwünscht?

Definitiv! Ansonsten ist das hier reines Rätselraten.
Es könnte auch ein DNS Problem, bzw. Nebeneffekt vom Auflösen von localhost (oder einer anderen Domain) zu IPv4 und IPv6. Ist IPv6 aktiviert?
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6584
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: Xampp 1.8.2.-1 und Win8 64bit; Problem mit php-scripts

Postby haboma » 09. August 2013 07:37

-ich werde die Codes nachliefern.
-ich habe nichts geändert bzgl. IPv4 oder IPv6. Wo sehe ich, was wo eingestellt ist? Was sollte aktiviert sein?
haboma
 
Posts: 5
Joined: 08. August 2013 20:05
XAMPP Version: 5.6.3
Operating System: Windows 8

Re: Xampp 1.8.2.-1 und Win8 64bit; Problem mit php-scripts

Postby Altrea » 09. August 2013 07:57

Die einfachste Art zu sehen, zu was ein bestimmter Host aufgelöst wird ist ihn in der Eingabeaufforderung anzupingen.
Also ping doch mal den Host an, den du aus Parameter in deinem MySQL connection string verwendest.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6584
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: Xampp 1.8.2.-1 und Win8 64bit; Problem mit php-scripts

Postby haboma » 09. August 2013 18:06

Ich melde mich zurück in dieser mysteriösen Angelegenheit. Mysteriös erschien sie mir, weil einmal eine fehlenden Datenbankverbindung gemeldet wurde (wo ich doch sicher, war, dass die Verbindungsparameter korrekt waren), ein anderes mal wurde ein php-Naviagationsmenü nicht angezeit, und wieder ein anderers Mal wurde eine php-Seite angezeigt, statt interpretiert etc. etc.

Und dies alles zu genau dem Zeitpunkt, als ich einen neuen Rechner mit neuem OS und neuem Xampp installierte. Wer käme da nicht auf die Idee, bei dieser Installation sei etwar nicht wunschgemäss abgelaufen. Ich kam jedenfalls auf die Idee. Dies umso mehr, als alle in Frage kommenden scripts auf verschiedensten anderen/früheren Umgebungen funktionieren.

Nun, die Lösung liegt näher. Die Navigation wurde nicht angezeit, weil sie mit <? include("../Seiten/navig.php"); ?> statt mit <?php include("../Seiten/navig.php"); ?> inkludiert hatte. Die SQL-Fehlermeldung entstand, weil der Code der db_connect.php mit "<?" statt mit "<?php" beginnt. So einfach liegen die Dinge manchmal (aber anderswo, als man sie sucht).

Soweit ich sehe, funktioniert jetzt alles wunschgemäss. Trotzdem vielen Dank an alle, die sich die Zeit genommen haben, sich das Problem anzuschauen.

Nachtrag: Ich habe immer gemeint "<?php" sei "nice-to-have", nicht "must". Wer ist da so streng geworden? Win8 oder Xampp? Weshalb wird das nicht deutlicher kommuniziert?
haboma
 
Posts: 5
Joined: 08. August 2013 20:05
XAMPP Version: 5.6.3
Operating System: Windows 8

Re: Xampp 1.8.2.-1 und Win8 64bit; Problem mit php-scripts

Postby Altrea » 10. August 2013 01:23

haboma wrote:Nachtrag: Ich habe immer gemeint "<?php" sei "nice-to-have", nicht "must". Wer ist da so streng geworden? Win8 oder Xampp?

PHP selbst. Seit PHP 5.1.0 (Veröffentlicht 24.11.2005) steht für short_open_tag in der php.ini die Empfehlung diese Einstellung auf off zu stellen. Hintergrund ist die Kompatibilität zum XML open tag <?xml in PHP scripten. Diese Empfehlung führte zu dem Gerücht dass mit PHP6 diese Einstellungsmöglichkeit ganz wegfallen könnte.

Mit PHP 5.3.0 (30.06.2009) wurde seitens PHP auch die Empfehlung für Entwicklungsumgebungen auf den Wert Off gewechselt. Zu der Zeit haben mehrere Webserver Stacks (unter Anderem auch XAMPP) der Empfehlung folgen wollen, was aber aus zwei Gründen einen Aufschrei der PHP Entwicklergemeinde auslöste.
1. waren selbst einige große bekannte PHP Scripte zu der Zeit noch nicht in der Lage mit der empfohlenen Einstellung umzugehen
2. wurde mit der empfohlenen Einstellung auch die short code echo Syntax <?= deaktiviert, die aber zum einen keine Kompatibilitätsprobleme mit XML aufwies und zum Anderen äußerst beliebt in Template Systemen ob ihrer Übersichtlichkeit war.
Daher ruderte man auch bei XAMPP wieder zurück und aktivierte die short_open_tag wieder.

Seit PHP 5.4 hat sich die Lage nun geändert. Kaum ein großes bekanntes Script benötigt Sie heute noch und zudem fällt die short code echo Syntax nicht mehr unter diese Einstellung. Es besteht also heute kein wirklich guter Grund mehr für einen PHP Entwickler seine Scripte von dieser Einstellung unnötigerweise abhängig zu machen.

Auch wir hier im Forum haben deutlich weniger Supportanfragen zu short_open_tag als befürchtet und noch zu Zeiten der ersten Tests.

haboma wrote:Weshalb wird das nicht deutlicher kommuniziert?

Wie du hoffentlich sehen konntest ist dieser eine Einstellungswechsel ein Prozess über Jahre gewesen. Ein Entwickler kann nicht von der Verantwortung entbunden werden seine Scripte regelmäßig gegen verschiedene Einstellungskonstellationen zu testen und sollte sein Script zumindest lauffähig zur derzeitigen Empfehlung halten.

Mit PHP 5.6 oder PHP 6 fallen die ganzen alten mysql_ Funktionen weg und man wird zu mysqli_ oder PDO wechseln müssen. Aber auch da werden dies einige Entwickler erst zuspät mitbekommen obwohl PHP seit PHP 5.3 darauf hinweist und seit PHP 5.5 Deprecated Hinweismeldungen bei jeder Verwendung einer dieser Funktionen ausgibt (vorausgesetzt die Entwickler entsprechen der Empfehlung die Einstellung error_reporting ihrer Entwicklungsumgebungen auf dem empfohlenen Wert zu belassen).

Meine Gegenfrage also: Wie und vor Allem wo hätte/sollte man es kommunizieren können damit es auch jeder mitbekommt?
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6584
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 11 guests