Probleme mit posix_getpwuid() in der php.ini

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Probleme mit posix_getpwuid() in der php.ini

Postby music2u » 23. June 2004 12:47

Hallo!

Obwohl ich die Funktion posix_getpwuid() in der php.ini unter der Option "disable_functions" eingetragen habe, bekomme ich folgende Fehlermeldung.

Fatal error: Call to undefined function: posix_getpwuid()

PS: Server habe ich natürlich neugestartet und die Funktion wird in der PHP INFO angezeigt.

Was mache ich falsche?

Ach ja der XAMPP läuft auf WIN2000.

Oder geht diese Funktion nicht unter Windows?

Gruß
Stefan
music2u
 
Posts: 3
Joined: 23. June 2004 12:37

Postby music2u » 23. June 2004 12:57

Frage hat sich erübrigt. Habe auf einer Seite folgende Anmerkung dazu gefunden.

Sensible Daten können mit den POSIX-Funktionen, z.B. posix_getpwnam() und Freunde, abgefragt werden. Die POSIX-Funktionen führen keinerlei Zugriffsüberprüfungen durch, wenn safe mode aktiviert ist. Es wird daher stark empfohlen, die POSIX-Erweiterung komplett zu deaktivieren (verwenden Sie dazu bei der Konfiguration --disable-posix), wenn Sie in einer solchen Umgebung arbeiten.


Anmerkung: This extension is not available on Windows platforms.
music2u
 
Posts: 3
Joined: 23. June 2004 12:37

Re: Probleme mit posix_getpwuid() in der php.ini

Postby Wiedmann » 23. June 2004 13:03

Obwohl ich die Funktion posix_getpwuid() in der php.ini unter der Option "disable_functions" eingetragen habe,

Wie das Wort "disable" vermuten lässt, schaltet man mit dieser Anweisung die angegebenen Funktionen aus ;-)
(Ist aber in der "php.ini" auch so erklärt!)


Oder geht diese Funktion nicht unter Windows?

Ein Blick ins PHP-Manual hätte dir verraten:
POSIX Funktionen - This extension is not available on Windows platforms
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 8 guests