Festplatte hört nicht auf zu lesen / schreiben

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Festplatte hört nicht auf zu lesen / schreiben

Postby ajimaru » 22. June 2004 22:05

Hallo,

bevor ich anfange, hab das Forum nach ähnlichen Probleme durchsucht und nur diesen Beitrag gefunden alter Beitrag , leider wurde dort das Problem nicht gelöst.
Nun zum eigendlichen Thema:

Ich habe auf Windows2000 xampp-win32-1.4.3 ( Apache 2.0.49) installiert, bin mit Admin rechten angemeldet, mysql, Filezilla und MercuryMail laufen, aber sobald ich Apache starte fänge meine Festplatte an unaufhörlich tu lesen / schreiben, solange bis ich Apache wieder beende, localhost ist in dieser Zeit nicht erreichbar da Apache nicht wirklich startet.
Bei AppServ 2.4.0 funktioniert, dieses Paket basiert im Gegensatz zu xampp auf Apache v1.3.29 , Apache2Triad das auf Apache v2.0.49 basiert zeigt die selben Symptome! :?:

Nun ja :-) ich hoffe das mir jemand weiter helfen kann, bin für alle Vorschläge offen, und auch über ICQ zu erreichen.

mfg aji


Nachtrag:

ob mySQL läuft kann ich nicht bestätigen, ist mir ein Rätsel was da falsch läuft :(
User avatar
ajimaru
 
Posts: 7
Joined: 22. June 2004 21:17
Location: BY

Weiter Informationen

Postby ajimaru » 23. June 2004 14:58

Hier noch ein paar Zusatzinformationen die vieleicht nützlich seien können:

Ich habe neben einer Netzwerkkarte auch noch eine TV Karte (Haupauge WinTV DVB) die einen zusätzlichen Neztwerkadapter installiert, welcher unter Windows2000 eine "autonome" Netzwerkverbingung inklusive IP Adresse darstellt. Meine Neztwerkkarte hat die IP Adresse 192.168.168.2 und die TV Karte 192.168.168.250, beide sind im selben Subnetz 255.255.0.0 . Apache ist an 192.168.168.2 gebunden.

Außerdem habe ich noch einen Screenshot der Laufenden Prozesse eingefügt:

(Bild ist ca 120kb groß, es ging nicht kleiner ohne unleserlich zu werden :? )

Image
Image
User avatar
ajimaru
 
Posts: 7
Joined: 22. June 2004 21:17
Location: BY

Postby nemesis » 23. June 2004 22:45

Hallo,

von Symanctec weiß ich jetzt nix, aber welche Version der McAffee Firewall hast du? Die alte 4er und der Virenscanner 7.0 von Mc, hatte Apache 2 (ab 2.0.39) dazu gebracht, dass er niemals einen Child für ankommende anfragen anlegen konnte. Wenn Apache im Debug Modus gestartet wird, dürfte das rattern auf die ganzen Logeinträge (bis zu paar Tausend, je nach Sekundenanzahl und System ;)) was Apache dann anlegt.
Das Norton Speedd zeugs kenn ich niet, aber man muss ja niet alles kennen ;)

Falls das RocketLuncher für nen Raidcontroller ist, würde ich den mal überprüfen...
Ansonsten, als PNG wäre das Bild kleiner geworden ;p

[OT] Welchen Palm hast du? [/OT]
Ubuntu 8.04 | SMP P3 1.4 GHz | 6 GByte RegECC | 74 GByte Seagate 15k5 system | 3Ware 9550SXU-4LP with 4x 500 GByte Seagate ES2 Raid 10 data | StoreCase DE400 | PX-230A | Intel Pro/1000MT Dual PCI-X
User avatar
nemesis
AF Moderator
 
Posts: 999
Joined: 29. December 2002 13:14
Location: Ingolstadt

Postby ajimaru » 26. June 2004 17:51

hi,

also McAfee Firewall hat Product Version 4.02.6000.0 ,
das "SPEEDD~1" ist Norton Speed Disk, ein Programm zum Festplatte defragmentieren.... aber das kanns ja nicht sein. Rocked Divison Software ist ein Virtual DVD, SCSI und RamDisk Emulator.

Wenn dieser "Bug" mit dem Child erstellen bekannt ist, muß es doch ne lösung geben oder? :?
Was soll ich nun tun? :cry:




PS. hab n PalmIIIx wenn die Frage an mich gerichtet war. :arrow:
Image
User avatar
ajimaru
 
Posts: 7
Joined: 22. June 2004 21:17
Location: BY

Gleiches Prob

Postby gerdi » 26. June 2004 21:26

hallo,

ich benutze xp-pro sp1 und alle Sicherheitsubdates.
McAfee VirusScan 7.00.5000.0 und firewall 4.00.5000.0

mysql wird ohne prob gestartet

apache wird nicht fehlerfrei gestartet. Die Datei xampp\apache\logs\error.log hat folgenden Inhalt, nur die ersten Zeilen!!

[Sat Jun 26 21:48:11 2004] [notice] Parent: Created child process 2948
[Sat Jun 26 21:48:12 2004] [notice] Child 2948: Child process is running
[Sat Jun 26 21:48:12 2004] [notice] Child 2948: Acquired the start mutex.
[Sat Jun 26 21:48:12 2004] [notice] Child 2948: Starting 250 worker threads.
[Sat Jun 26 21:48:12 2004] [error] (OS 10038)Ein Vorgang bezog sich auf ein Objekt, das kein Socket ist. : Child 2948: Encountered too many errors accepting client connections. Possible causes: dynamic address renewal, or incompatible VPN or firewall software. Try using the Win32DisableAcceptEx directive.
[Sat Jun 26 21:48:12 2004] [error] (OS 10038)Ein Vorgang bezog sich auf ein Objekt, das kein Socket ist. : Child 2948: Encountered too many errors accepting client connections. Possible causes: dynamic address renewal, or incompatible VPN or firewall software. Try using the Win32DisableAcceptEx directive.
......
usw.............

Die Fehler kommen auch, wenn Mcafee nicht aktiviert ist.


Habe in der Datei xampp\apache\conf\httpd.conf die Variable Win32DisableAcceptEx gesucht und gefunden. Mit Wordpad geöffnet. die Zeile sieht so aus:

# Win32DisableAcceptEx ON

Durch löschen des # Zeichen habe ich diese Variable aktivert. Mit Wordpad speichern.

start von apache_start.bat und kein rattern der Platte mehr.
die Datei error.log sihet jetzt so aus:
[Sat Jun 26 22:20:38 2004] [notice] Parent: Created child process 3928
[Sat Jun 26 22:20:38 2004] [notice] Disabled use of AcceptEx() WinSock2 API
[Sat Jun 26 22:20:38 2004] [notice] Child 3928: Child process is running
[Sat Jun 26 22:20:39 2004] [notice] Child 3928: Acquired the start mutex.
[Sat Jun 26 22:20:39 2004] [notice] Child 3928: Starting 250 worker threads.
[Sat Jun 26 22:20:39 2004] [notice] Child 3928: Listening on port 443.
[Sat Jun 26 22:20:39 2004] [notice] Child 3928: Listening on port 80.


nach startet der iexplorer http://localhost und der Auswahl deutsch kommt die XAMPP seite.

Und alle wird gut.......... :lol: :lol: :lol:
gerdi
 
Posts: 1
Joined: 26. June 2004 20:51
Location: detmold

danke gerdi

Postby ajimaru » 27. June 2004 11:59

hallo,

ich hab die Einstellung

Code: Select all
# Win32DisableAcceptEx ON


aktiviert und siehe da, es geht :D
war aber auch am hinterletzen Eck versteckt :?
Image
User avatar
ajimaru
 
Posts: 7
Joined: 22. June 2004 21:17
Location: BY


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 16 guests