Absturz von mod_auth_mysql

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Absturz von mod_auth_mysql

Postby tbnobody » 22. June 2004 21:05

Hallo,

wenn ich mit dem mod_auth_mysql die authentizierung mit z.B.
require group admin
festlege bekomme ich in der error.log des Apache folgende Fehlermeldungen:

[Tue Jun 22 21:44:30 2004] [error] [client 192.168.1.8] MySQL error Lost connection to MySQL server during query: /members/phpMyAdmin/images/spacer.gif, referer: http://localhost/members/phpMyAdmin/db_ ... 1&db=mysql
[Tue Jun 22 21:44:30 2004] [error] [client 192.168.1.8] mysql user nobody not in group table authentication: /members/phpMyAdmin/images/spacer.gif, referer: http://localhost/members/phpMyAdmin/db_ ... 1&db=mysql
[Tue Jun 22 21:44:33 2004] [notice] Parent: child process exited with status 3221225477 -- Restarting.
[Tue Jun 22 21:44:33 2004] [notice] Parent: Created child process 4424
[Tue Jun 22 21:44:33 2004] [notice] Child 4424: Child process is running
[Tue Jun 22 21:44:33 2004] [notice] Child 4424: Acquired the start mutex.
[Tue Jun 22 21:44:34 2004] [notice] Child 4424: Starting 250 worker threads.

und eine erneute Passwortabfrage im Browser.
Wenn ich allerdings die authentizierung mit
require valid-user
durchführe funktioniert es besser, der Fehler tritt nichtmehr so oft auf.

Hatte schon jemand so ein Problem, oder weis jmd an was es liegen kann?
Falls bedarf besteht, kann ich auch noch die .htaccess pasten, aber die ist an die aus dem ZIP Archiv gehalten (nur die beiden Zeilen mit den Gruppen aktiviert).

Als Version verwende ich: xampp-win32-1.4.3.zip

Danke für euer Hilfe

Thomas[/i]
tbnobody
 
Posts: 2
Joined: 22. June 2004 20:58

Postby Heini_net » 22. June 2004 21:14

hi..

also das Problem haben noch mehrere.. und wir vermuten das es an Apache oder am modul für mysql auth liegt..

lässt sich nix dran ändern... du kannst höhstens die htaccess dateien methode verwenden..

Vielleicht ist es in der nächsten Apache Version behoben.

mfg. Heini
User avatar
Heini_net
 
Posts: 520
Joined: 25. July 2003 15:43
Location: hier

Postby tbnobody » 22. June 2004 21:31

Achso, das Problem besteht erst seit der akutellen Apache Version.

Ich habe noch absolut keine Erfahrungen gesammelt, ich habe nur dieses mod_auth_mysql als binary für den Apache gesucht ( konnte es nicht kompilieren ) und bin hier fündig geworden.

Ciao

Thomas
tbnobody
 
Posts: 2
Joined: 22. June 2004 20:58


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 16 guests