noch ein Versuch: Verträglichkeit IIS und Apache/XAMPP ???

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

noch ein Versuch: Verträglichkeit IIS und Apache/XAMPP ???

Postby mf » 15. June 2004 20:04

Ich habe auf meinem MS Win XP Prof zuerst XAMPP installiert und da lief es wunderbar!!

nun habe ich den IIS installiert und da kommt das System nicht mehr mit "xampp_start.exe" hoch. Es kann sein, dass der IIS den Port 80 nutzt, aber auch wenn ich den 8080 konfiguriere kommt er noch immer nicht hoch ...

Folgende Fehlermeldung habe ich festgehalten:
*********************************************
C:\>cd xampp

C:\XAMPP>xampp_start.exe
Diese Eingabeforderung nicht waehrend des Runnings beenden ...
Zum stoppen bitte die xampp_stop benutzen!
Please do not close this window while running ...
Use the xampp_stop for shutdown!

Please wait [Bitte warten] (OS 10048)Normalerweise darf jede Socketadresse (Prot
okoll, Netzwerkadresse oder Anschluss) nur jeweils einmal verwendet werden. : m
ake_sock: could not bind to address 0.0.0.0:443
no listening sockets available, shutting down
Unable to open logs
Can't start server: Bind on TCP/IP port: No error
040615 20:52:35 Do you already have another mysqld server running on port: 3306
?
040615 20:52:35 Aborting

040615 20:52:35 mysql\bin\mysqld.exe: Shutdown Complete

...

### APACHE + MYSQL IS STARTING NOW ###

C:\XAMPP>

*********************************************

WAS muss ich noch alles (in der Konfiguration ?) ändern, dass beide Systeme potentiell sich zusammen "vertragen" ?
mfg
michael filzinger
mf
 
Posts: 13
Joined: 08. June 2004 15:01
Location: 65817 Eppstein

Postby Wiedmann » 15. June 2004 20:29

Steht doch da:

Es kann sein, dass der IIS den Port 80 nutzt, aber auch wenn ich den 8080 konfiguriere kommt er noch immer nicht hoch.

could not bind to address 0.0.0.0:443


Was sagt uns das? Es kollidiert halt nicht nur der Port 80...

(Port 443 ist für SSL)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

aber WIE geht es ??

Postby mf » 15. June 2004 20:36

danke für die Erläuterung - aber WAS kann ich ändern, damit es läuft ???
mfg
michael filzinger
mf
 
Posts: 13
Joined: 08. June 2004 15:01
Location: 65817 Eppstein

Postby Wiedmann » 15. June 2004 20:41

aber WAS kann ich ändern, damit es läuft

Schalte bei einem der beiden Server SSL ab.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

SSL abschalten - aber WIE ??

Postby mf » 15. June 2004 20:56

danke für den tipp!

ich brauche kein SSL - aber wie schalte ich es beim Apache ab??
(oder auch beim IIS ...)
mfg
michael filzinger
mf
 
Posts: 13
Joined: 08. June 2004 15:01
Location: 65817 Eppstein

Re: SSL abschalten - aber WIE ??

Postby Wiedmann » 15. June 2004 21:13

ich brauche kein SSL - aber wie schalte ich es beim Apache ab??

In der httpd.conf folgende Zeile auskommentieren (#):
#Include conf/ssl.conf
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

suche generelle Lösung ...

Postby mf » 15. June 2004 21:56

das habe ich auch schon gemacht, aber die fehler hören damit nicht auf ....

gibt es denn niemanden, der IIS und Apache "nebeneinander" betreibt und mir echt eine lösunge beschreiben kann??
mfg
michael filzinger
mf
 
Posts: 13
Joined: 08. June 2004 15:01
Location: 65817 Eppstein

iis

Postby Kistler280 » 30. June 2004 16:29

also bei mir lauf der apache und der iis neben einader
Habe den abache auf stantart ports laufen port 80/443
den iss lauft uaf port 8080 ohne ssl.
ssl ist ja one server Zetifikate bekanlich nicht möglich.
um den iis dan aufzurfen gebe einfach deine ip:8080 oder deine doman:8080 ein solde klaben
Kistler280
 
Posts: 2
Joined: 30. October 2003 20:45
Location: Zwickau


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 15 guests