Virtualhost in httpd.conf - Newbie braucht Hilfe...

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Virtualhost in httpd.conf - Newbie braucht Hilfe...

Postby erich_xxx » 27. May 2004 11:43

Ich hab' meinen Rechner neu gemacht und
meinen Apache-Webserver neu installiert....
und wenn ich wie "früher" in der httpd.conf angebe:
-----
<VirtualHost 127.0.0.1:80>
ServerName pipe
Serveralias pipe
ServerAdmin test@localhost
DocumentRoot "D:/Homepage/pipe"
<Directory "D:/Homepage/pipe">
DirectoryIndex index.htm index.html index.php
</Directory>
ErrorLog logs/play-error_log
TransferLog logs/play-access_log
</VirtualHost>

<VirtualHost 127.0.0.1:80>
ServerName hexe
Serveralias hexe
ServerAdmin test@localhost
DocumentRoot "D:/Homepage/hexe"
<Directory "D:/Homepage/hexe">
DirectoryIndex index.htm index.html index.php
</Directory>
ErrorLog logs/play-error_log
TransferLog logs/play-access_log
</VirtualHost>
-----
und in der hosts:
----
127.0.0.1 localhost
127.0.0.1 pipe
127.0.0.1 hexe
----

dann kann ich mich nur leider immer im "ersten" virualhost einloggen... (http://pipe)
hexe findet er nicht... ???
Was mache ich nur falsch???

Habe schon folgendes ausprobiert, aber da gibt's dann Probleme mit dem Datenbankzugriff,

---
Alias /pipe "D:/Homepage/pipe/"

<Directory "D:/Homepage/pipe/">
DirectoryIndex index.htm index.html index.php index.php3 index.phtml index.shtml index.cgi index.pl
</Directory>

Alias /hexe "D:/Homepage/hexe/"

<Directory "D:/Homepage/hexe/">
DirectoryIndex index.htm index.html index.php index.php3 index.phtml index.shtml index.cgi index.pl
</Directory>
---

weil ich dann so posten muss: http://localhost/hexe
Mensch :twisted: Hilfe!

Dann hab'schs auch gleich noch so probiert:
----
Alias pipe "D:/Homepage/pipe/"

<Directory "D:/Homepage/pipe/">
DirectoryIndex index.htm index.html index.php index.php3 index.phtml index.shtml index.cgi index.pl
</Directory>
----
ohne erfolg, weil dann oben folgendes steht:
http://pipe/xampp/splash.php
und er flitzt ins quasi root xampp


Kann mir bitte jemand helfen???
erich_xxx
 
Posts: 3
Joined: 27. May 2004 11:35

Postby Wiedmann » 27. May 2004 12:09

Da fehlt wohl ein:
NameVirtualHost 127.0.0.1:80
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby erich_xxx » 27. May 2004 12:49

ja Klasse ! - das war's

vielen Dank...
erich_xxx
 
Posts: 3
Joined: 27. May 2004 11:35

mod_Perl ???

Postby erich_xxx » 28. May 2004 09:11

und schon meine nächste Frage - sorry.....

Ich möchte gern meine perlscripte nicht immer "per hand"
nach C:\Programme\xampp\cgi-bin verschieben
sonder komfortabel jeweils unter z.B.
---
<VirtualHost 127.0.0.1:80>
DocumentRoot "D:/Homepage/pipe"
ServerName pipe
</VirtualHost>
---
also http://pipe/ wiederfinden.

Ist dies' möglich? und wenn ja wie???
Meine httpd.conf ist immernoch "orginal" d.h.
es sind nur die Ergänzungen zum
VirtualHost und NameVirtualHost drin...

Vielen Dank schon mal!
erich_xxx
 
Posts: 3
Joined: 27. May 2004 11:35

Postby Rolidor » 28. May 2004 12:49

Hallo.
Günstiger ist ein eigenes Verzeichnis für die Skripte. In diesem Fall nenne ich es mal 'cgi-bin'.
Code: Select all
<VirtualHost 127.0.0.1:80>
DocumentRoot "D:/Homepage/pipe"
ServerName pipe

    <Directory ""D:/Homepage/pipe/cgi-bin/">
        Options ExecCGI
        AddHandler cgi-script .cgi .exe
        Order allow,deny
        Allow from all
    </Directory>

</VirtualHost>

Skripte im Ordner 'http://pipe/cgi-bin/' sollten jetzt ausführbar sein. Nicht vergessen den Apachen nach der Änderung in der http.conf neu zu starten.
Die weitestgehend deutsche Doku zum Apachen gibt's außerdem online und als Windows-chm auf http://httpd.apache.org/docs-project/.

Gruß
Rolo
Rolidor
 
Posts: 406
Joined: 20. April 2004 10:17
Location: Dreieich - Hessen

Postby Rolidor » 28. May 2004 12:50

Hallo.
Günstiger ist ein eigenes Verzeichnis für die Skripte. In diesem Fall nenne ich es mal 'cgi-bin'.
Code: Select all
<VirtualHost 127.0.0.1:80>
DocumentRoot "D:/Homepage/pipe"
ServerName pipe

    <Directory ""D:/Homepage/pipe/cgi-bin/">
        Options ExecCGI
        AddHandler cgi-script .cgi .exe
        Order allow,deny
        Allow from all
    </Directory>

</VirtualHost>

Skripte im Ordner 'http://pipe/cgi-bin/' sollten jetzt ausführbar sein. Nicht vergessen den Apachen nach der Änderung in der http.conf neu zu starten.
Die weitestgehend deutsche Doku zum Apachen gibt's außerdem online und als Windows-chm auf http://httpd.apache.org/docs-project/.

Gruß
Rolo
Rolidor
 
Posts: 406
Joined: 20. April 2004 10:17
Location: Dreieich - Hessen


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 10 guests