apache als service unter W2000 starten

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

apache als service unter W2000 starten

Postby paul » 27. May 2004 09:55

Hallo,

ich möchte den apache-server als Service unter Windows 2000 einrichten. In der Hilfe (online) steht, dass man die Datei apache_installservice.bat starten soll. Leider bekomme ich dann folgende Fehlermeldung: Service is already installed. Now we start apache2. Systemfehler 3 ist aufgetreten. Das System kann den angegebenen Pfad nicht finden. Was läuft hier falsch. Danke im voraus für die Hilfe.

Paul
paul
 
Posts: 8
Joined: 20. March 2004 11:47

Re: apache als service unter W2000 starten

Postby DJ DHG » 27. May 2004 10:03

Moin Moin

paul wrote:Service is already installed.


du hast schon einen apache installiert, steht da doch.
apache_installservice.bat 2 mal ausgeführt oder olter/anderen noch installiert?

mfg DJ DHG
User avatar
DJ DHG
AF Moderator
 
Posts: 2455
Joined: 27. December 2002 13:50
Location: Kiel

apache als service unter W2000 starten

Postby paul » 27. May 2004 10:49

Hallo,

der Apache-Server läuft aber nur wenn ich ihn von Hand starte. Ich hätte gerne, dass er als Dienst läuft und beim Start von Windows gestartet wird.

Gruß

Paul
paul
 
Posts: 8
Joined: 20. March 2004 11:47

Postby DJ DHG » 27. May 2004 12:53

schon mal daran gedacht den alten dienst zu deinstallieren?

mfg DJ DHG
Last edited by DJ DHG on 27. May 2004 13:43, edited 1 time in total.
User avatar
DJ DHG
AF Moderator
 
Posts: 2455
Joined: 27. December 2002 13:50
Location: Kiel

Postby borschtel1 » 27. May 2004 13:27

oder einfach unter [start] --> [Programme] --> [Verwaltung] --> [Dienste] den Apache2-Dienst so einstellen, dass er automatisch gestartet wird. und wenn er nicht läuft, kannst du ihn dort auch starten.
borschtel1
 
Posts: 29
Joined: 27. May 2004 11:29

apache als service unter W2000 starten

Postby paul » 27. May 2004 15:02

Hallo,

kann den alten Dienst nicht deinstallieren, finde keine Möglichkeit. Außerdem ist der Pfad zur .exe-Datei falsch, da kann ich leider unter "Dienste" auch nichts ändern.

Paul
paul
 
Posts: 8
Joined: 20. March 2004 11:47

Postby DJ DHG » 27. May 2004 15:35

versuches mit der "apache_uninstallservice.bat" im xampp\apache verzeichnis?

mfg DJ DHG
User avatar
DJ DHG
AF Moderator
 
Posts: 2455
Joined: 27. December 2002 13:50
Location: Kiel

apache als service unter W2000 starten

Postby paul » 27. May 2004 16:46

Hallo,

habe ich schon versucht, aber leider verschwindet der Eintrag im Windows-Verzeichnis "Dienste" nicht. Möglicherweise liegt es daran, dass der uninstall_service versucht den apache 2 zu entfernen, bei mir steht in dem o.g. Verzeichnis Apache und unter den Eigenschaften steht als Pfad zur exe-Datei: "D:\Programme\Apache.exe". Diese Datei habe ich gar nicht. Irgend eine Idee?

Paul
paul
 
Posts: 8
Joined: 20. March 2004 11:47

Postby Wiedmann » 27. May 2004 17:01

Irgend eine Idee?

Ja. Du hättest deinen ersten Apachen korrekt deinstallieren sollen, anstatt ihn nur zu löschen.

Lösche den vorhandenen Dienst in der Registry, starte den Rechner neu, und installiere dann erst den Apachedienst vom XAMPP. Alternativ kannst du dir zum Löschen des Dienstes auch das Tool sc.exe aus dem NT4 Resource Kit besorgen.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

apache als service unter W2000 starten

Postby paul » 28. May 2004 12:23

Hallo,

jetzt funktioniert es, Vielen Dank. Zum Abschluß noch eine Frage: Wie kann ich dafür sorgen, dass ich in der Taskleiste sehe, dass mein apache-server läuft? Das war bei meiner früheren Version immer so. Danke

Gruß

Paul
paul
 
Posts: 8
Joined: 20. March 2004 11:47

Postby 1ApRiL » 07. June 2004 20:27

Ich habe eigentlich das gleiceh prob. Nur bei mir hatte ich zuvor so nen kack ausversehen, von nem NAMO packet installiert.
Das ist ganz anders. Es gibt keinen eintrag bei den Diensten. Wenn ich versuche es zu deinstallieren, hängt sich nur das Softwaretool auf.
Wenn ich so in den Ordner gucken da gibt es keine bats nur eine apache.exe und noch so nen paar. Ich hoffe es gibt eine möglichkeit das zu deinstallieren. Will endlich xampp benutzen können. Weil Mysql läuft super.
1ApRiL
 
Posts: 2
Joined: 07. June 2004 19:36
Location: Waiblingen

Postby ERAZER » 20. August 2004 11:05

Hi, wenn ich unter Win2k (SP4) den Apache als Service installieren will, erhalte ich diese Fehlermeldung:

Ein dienstspezifischer Fehler ist aufgetreten: 1.
Sie erhalten weitere Hilfe, wenn Sie NET HELPMSG 3547 eingeben.

Könnt ihr mir helfen ¿
ERAZER
 
Posts: 3
Joined: 20. August 2004 10:42


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 14 guests