.htaccess und so

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

.htaccess und so

Postby DAU » 21. March 2003 09:12

Hallo Leute,

was muss ich machen (einstellen) damit meine .htaccess Datei bei einem ErrorDocument einen relativen Pfad zuläßt?? :?: :?: :?:
Bei mir funzt nur der absolute Pfad.

Danke.
DAU
 

Postby DAU » 21. March 2003 09:17

ErrorDocument 404 "Sorry, this page doesn't exist.

funzt übrigens auch nicht :!: :!:
DAU
 

Postby Pc-dummy » 21. March 2003 11:34

Hi

ähm das hier hab ich aus meinem apache-buch...

Code: Select all
ErrorDocument 500 http://www.beispiel.de/cgi-bin/server_fehler
ErrorDocument 404 /cgi-bin/nicht_gefunden.pl
ErrorDocument 401 /nicht_authorisiert.html
ErrorDocument 403 "Sie haben die erforderliche Berechtigung, auf diesen Bereich der Internetseite zuzugreifen."


diese versionen auser den CGI hab ich mir alle drei in ne .htaccess gepackt und es funzt

So nun aber das was du hören willst *g*

das da im <Directory> Container des jeweilgen Verzeichnises abändern
Code: Select all
AllowOverride Authconfig


auf das da
Code: Select all
AllowOverride FileInfo Auhconfig


MFG
Pc-Dummy
--
a 13 year old Newbie ;)
Pc-dummy
AF Moderator
 
Posts: 784
Joined: 29. December 2002 01:46
Location: AT-Vorarlberg-Feldkirch

Postby DAU » 21. March 2003 11:54

ich habe es auch so nach gelesen. "Benützen sie einen relativen oder absoluten Pfad, ganz wie sie wollen ..."
Bei mir funzt der relative Pfad aber nicht und ich weiß nicht warum.

Was meinst Du mit dem
Code: Select all
AllowOverride FileInfo Authconfig
??
Wo soll ich es wie einfügen?
DAU
 

Postby Pc-dummy » 21. March 2003 13:16

in die httpd.conf

dann sollte eigentlich alles wieder funzen *g*
Pc-dummy
AF Moderator
 
Posts: 784
Joined: 29. December 2002 01:46
Location: AT-Vorarlberg-Feldkirch

Postby DAU » 21. March 2003 13:29

habe jetzt meine httpd.conf
von
Code: Select all
<Directory />
    Options FollowSymLinks
    AllowOverride All
</Directory>

in
Code: Select all
<Directory />
    Options FollowSymLinks
    AllowOverride FileInfo Authconfig
</Directory>

geändert.
funzt leider immer noch nicht mit dem relativen pfad! :-/
DAU
 

Postby Pc-dummy » 22. March 2003 01:14

Hy DAU *lol*

Ich glaub du hast dir den falsche Directory-Container ausgesucht

Nimm mal den der etwa so lautet

Code: Select all
<Directory c:/wampp2/htdocs>


also der mit dem htdocs drin

MFG
Pc-Dummy
--
a 13 year old Newbie
Pc-dummy
AF Moderator
 
Posts: 784
Joined: 29. December 2002 01:46
Location: AT-Vorarlberg-Feldkirch


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 13 guests