MercuryMail: Gesendet von... postmaster ändern

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

MercuryMail: Gesendet von... postmaster ändern

Postby << dp >> » 23. May 2004 18:42

Hi,
ich habe mir jetzt ca. 1 Stunde lang MercuryMail angetan, um lokal einen kleinen Mailserver zu basteln. So weit funktioniert auch alles. Ich habe mir ein eigenes Profil, das die EMails empfängt, angelegt und die Profile "postmaster" und "admin" gelöscht, da mein Profil deren Aufgaben eigentlich übernehmen soll. Tut es aber nicht. Ich lese die EMails mit Hilfe von Outlook aus - funktioniert auch problemlos. Das einzige was mich stört - und nicht funktioniert - ist, dass bei den eingegangene EMails immer noch "postmaster@localhost" steht, obwohl dieses Profil ja gar nicht mehr existiert. Ich möchte, dass da der Name von meinem Profil steht. Kann man das irgentwie realisieren oder steht das fest?

Vielen Dank für jede Hilfe !!!

Gruß

Daniel
<< dp >>
 
Posts: 33
Joined: 26. April 2004 14:23

Postby Rolidor » 23. May 2004 22:27

Hallo.
Dann tu dir mal das an:
http://www.pmail.com/faqs/faqs_mwp.htm
'Problem: Mail goes out with the wrong "From" address ...'

Grüßli
Rolo

PS: Warum nimsu nich FileZilla oder WarFTP? Beide sind kinderleicht zu administrieren.
Rolidor
 
Posts: 406
Joined: 20. April 2004 10:17
Location: Dreieich - Hessen

Postby Wiedmann » 23. May 2004 23:29

Rolidor wrote:PS: Warum nimsu nich FileZilla oder WarFTP? Beide sind kinderleicht zu administrieren.

Wahrscheinlich weil keines von beiden ein Mailserver ist...

<< dp >> wrote:Das einzige was mich stört - und nicht funktioniert - ist, dass bei den eingegangene EMails immer noch "postmaster@localhost" steht

Ich denke du meinst:
Wenn du dir mit PHP eine Mail schickst, ist der Absender "postmaster@localhost".

Dazu mußt du in der php.ini (im Verzeichnis "/xampp/apache/bin") folgende Zeile anpassen:
sendmail_from = postmaster@localhost

Da du trotz dieser Einstellung und gelöschtem postmaster-Account im Mercury Mails versenden kannst, solltest du evtl. deine Relay-Einstellungen überprüfen. Stichwort: offenes Mailrelay

Desweiteren kannst du bei der mail-Funktion von PHP auch noch den passenden From-Header setzten:
mail($Empfaenger, $Betreff, $Nachricht, "From: webmaster@localhost\n");
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Rolidor » 24. May 2004 19:52

Jo, wieder mal voll erwischt. Ist mir jetzt schon dass zweite Mal passiert. Ich sollte möglicherweise mal aufs DVD glotzen und Quasseln beim Posten verzichten.
Muss heißen '...ArGo oder Hamster...'
Der Mailserver von ArGoSoft ist wirklich kinderleicht zu handhaben, bietet in der freien Version allerdings nur fundamentales. Ist für simples sendmail aber völlig ausreichend.

gruß
Rolo
Rolidor
 
Posts: 406
Joined: 20. April 2004 10:17
Location: Dreieich - Hessen

Postby << dp >> » 24. May 2004 20:04

Hui,
in der php.inin steht das. Verdammt, dann habe ich die ganze Zeit über in der falschen INI-Datei gesucht - nähmlich in der von Mercury selbst. Egal, Problem gelöst. Vielen Dank !!!

Gruß

P.S.: Den Befehl "From..." von PHP kenne ich, wäre aber nur eine Notlösung gewesen.
<< dp >>
 
Posts: 33
Joined: 26. April 2004 14:23


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 5 guests