Passwortschutz

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Passwortschutz

Postby billa » 20. May 2004 22:47

Hallo, schlage mich schon Stunden mit einem Problem herum, das ich nicht ergründen kann. Es fing ganz einfach an, wollte htdocs mit einem Passwortschutz versehen. Es klappte auch auf Anhieb, das EingabeFenster popt auf, aber gibt man den Namen und das Kennwort ein, passiert nichts. Nach langem lesen im Vorum und im Netz, bin ich auf diese Seite gestoßen: http://www.krizleebear.de/phpaccess/dyn ... p?pageID=8 - http://www.krizleebear.de/phpaccess/tes ... 3_test.php

Durch die Eingabe von test / test sollte man dort testen können, wie der Schutz funktioniert. Aber sobald ich das tat, genau der gleiche Effekt wie bei meinen .htaccess-versuchen. Das Popup erscheint, aber mehr geht nicht. Woran kann das liegen? Hat schon jemand was ähnliches beobachtet? Ich habe IE6/SP1 und Win2000. Am xampp scheint es wohl nicht zu liegen, da es bei mir ja mit oben angegebener Seite auch nicht funktioniert.
billa
 
Posts: 48
Joined: 05. May 2004 16:56

Postby Wiedmann » 20. May 2004 23:33

Poste mal deine .htaccess und in welchem Pfad diese auf der HD liegt.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby DJ DHG » 21. May 2004 00:04

Moin Moin

@Wiedmann
er schreibt das er das problem nicht nur mit seiner eigenen htaccess hat sondern auch mit
welchen die auf anderen seiten liegen.

kann mit vorstellen das es am browser liegt.
schon mit einem anderen versucht?

mfg DJ DHG
User avatar
DJ DHG
AF Moderator
 
Posts: 2455
Joined: 27. December 2002 13:50
Location: Kiel

Postby Wiedmann » 21. May 2004 01:04

Morgen ;-)

eigentlich vermute ich ja, dass seine Passwörter mit crypt anstatt mit md5 (oder plain) verschlüsselt sind. Entweder er hat sich das Script von der oben angegebenen Seite installiert, oder er hat sie sich sonst wo in einem Webformular erstellen lassen.

Da es ja auch sein könnte, dass der Pfad zur .htpasswd nicht stimmt, fand ich es eine gute Idee die paar Zeilen von der .htaccess posten zu lassen.

(Und dass das Online-Demo unter dem angegebenen Link nicht funktioniert, liegt in der Verantwortung des dortigen Autors.)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Hallo

Postby billa » 21. May 2004 15:02

Danke füe eure Resonanz.
Gerne würde ich die htaccess senden, aber ich denke das das Problem nicht da zu suchen ist. Das erwähnte Script von der Seite "Kriszleebear.de habe ich noch nicht ausprobiert, das werde ich aber heute in der Nacht mal tun. Als Browser benutze ich den Explorer. Habe auf verschiedenen Rechnern die besagte Seite und meine .htacesse geschützen Verzeichnisse aufgerufen. Nirgendwo ging es, weder bei win98 noch bei win2000. Die Rechner haben auch verschiedene Eplorer-Versionen drauf, so die 5.0, 5.5, 6.0 und 6.1 und die win2000-Rechner haben die von microsoft empfohlenen Sicherheitsupdates drauf. Allerdings waren alle Rechner hinter einer Hardware-Firewall. Ein Bekannter, der Linux auf dem Rechner hat, bei dem funktionierte alles auf Anhieb.
Jetzt bin ich gerade daran alles nochmals frisch zu machen. Habe mir eine alte 2GB Festplatte besorgt und spiele win98-2 drauf mit IE 5.0 und gehe dann direkt ins Internet, mit DSL ohne Firewall und ohne Patches. Bin gespannt ob es damit funktioniert.
Lieber Wiedmann >>>(Und dass das Online-Demo unter dem angegebenen Link nicht funktioniert, liegt in der Verantwortung des dortigen Autors.)<<<
Ist mir auch klar, aber bei meinem Bekannten läuft es, darum hatte ich ja gehofft, das mir das hier jemand bestätigt oder auch nicht. Der dortige Autor hat alles richtig gemacht, sonst würde es bei meinem Bekannten ja nicht gehen.
Fakten sind allemal besser als Vermutungen.
Trotzdem vielen Dank für den Hilfeversuch, werde jetzt erst mal das besagte in die Tat umsetzen und melde mich dann wieder.
billa
 
Posts: 48
Joined: 05. May 2004 16:56

Passwortschutz

Postby billa » 21. May 2004 21:30

Hallo, nachdem ich mir eine leere Festplatte besorgt, mit Win2000 beglückt und xampp installiert habe, mein leidiges Problem.
Ich habe das Installerpaket installiert unter
C:/programme/xampp
In htdocs habe ich ein Verzeichniss mit der Bezeichnung 0101 und dieses wollte ich mit .htacess schützen. Das Fenster pop auf, aber mehr geht nicht.
-------------------------------------------------------------------------------------
Der Name soll sein: 0101 und das Kennwort: test
...........................................................................................................
Im Verzeichniss 0101 befindet sich:
.htaccess
0101.htm
group
passwd
..........................................................................................................
in der .htaccess steht drin:
AuthType Basic
AuthUserFile C:/programme/xampp/0101/passwd
AuthGroupFile C:/programme/xampp/0101/group
AuthName "Zugangsdaten bitte hier eingeben"
require valid-user
order deny,allow
..........................................................................................................
in der group steht drin:
user:0101
..........................................................................................................
in passwd steht drin:
user:0101
..........................................................................................................
Mit den Pfadangaben habe ich herumprobiert und auch folgendes ausprobiert, aber auch ohne Erfolg.
AuthType Basic
AuthUserFile /home/programme/htdocs/0101/passwd
AuthGroupFile /home/programme/htdocs/0101/group
AuthName "Zugangsdaten bitte hier eingeben"
require valid-user
order deny,allow
billa
 
Posts: 48
Joined: 05. May 2004 16:56

Passwortschutz

Postby billa » 21. May 2004 21:51

Habe jetzt einen Teilerfolg zu verbuchen.

AuthType Basic
AuthUserFile C:/programme/xampp/htdocs/0101/passwd
AuthGroupFile C:/programme/xampp/htdocs/0101/group
AuthName "Zugangsdaten bitte hier eingeben"
require valid-user
order deny,allow

Damit kann ich jetzt das Verzeichniss 0101 schützen, das klappt jetzt. Durch diesen Erfolg beschwingt wollte ich auch das komplette htdocs-Verzeichniss schützen, aber da bekomme ich einfach nicht hin. Habe es so abgeändert:
AuthType Basic
AuthUserFile C:/programme/xampp/htdocs/passwd
AuthGroupFile C:/programme/xampp/htdocs/group
AuthName "Zugangsdaten bitte hier eingeben"
require valid-user
order deny,allow

Was mache ich da noch falsch?
billa
 
Posts: 48
Joined: 05. May 2004 16:56

Postby Wiedmann » 21. May 2004 21:53

Hi billa,

nachdem du eh auf "valid-user" prüfst, lassen wir mal das "AuthGroupFile" weg. Das "AuthUserFile" nennen wir zwecks der Sicherheit ".htpasswd".

(ist das Verzeichnis jetzt:
"C:/Programme/xampp/0101/" oder "C:/Programme/xampp/htdocs/0101/"
Ich geh jetzt mal vom Zweiten aus. Alle Dateien sind also in:
"C:/Programme/xampp/htdocs/0101/"

.htaccess
Code: Select all
AuthType Basic
AuthName "Zugangsdaten bitte hier eingeben"
AuthUserFile "C:/Programme/xampp/htdocs/0101/.htpasswd"
Require valid-user


.htpasswd
Code: Select all
0101:test


Wobei so das Passwort unverschlüsselt in der Datei steht (hier "test"). Zur Pflege dieser Datei, User und Passwort md5 verschlüsselt eintragen, benutzt du dann besser das Programm "htpasswd.exe" im Verzeichnis "C:/Programme/xampp/apache/bin/"

Edit:
Wenn du das ganze in das Verzeichnis "C:/Programme/xampp/htdocs/" tust, und bei den Pfadangabe das "0101/" rausmachst, also:
AuthUserFile "C:/Programme/xampp/htdocs/.htpasswd"
, ist es für das ganze /htdocs/ gültig.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

passwort

Postby billa » 22. May 2004 18:03

Hallo Wiedmann!
Das war es, danke Dir dafür. Manchmal sind es die einfachsten Sachen die einem verzweifeln lassen und nur weil man vor lauter Bäumen den Wald nicht mehr sieht. Hab ees Deinem Vorschlag entsprechend gemacht und es funktionierte auf Anhieb.
billa
 
Posts: 48
Joined: 05. May 2004 16:56

Postby quizzmaster » 22. May 2004 20:46

Unter Linux funktionieren deine Beispiele von oben überhauptnicht.
Also werden Da wohl die Webmaster was falsch gemacht haben
greetz
quizzmaster

"Ich weiss, dass ich nichts weiss, aber ich weiss mehr als die, die nicht wissen, dass sie nichts wissen." Sokrates
quizzmaster
 
Posts: 28
Joined: 06. February 2004 15:06

Postby Wiedmann » 22. May 2004 21:09

quizzmaster wrote:Unter Linux funktionieren deine Beispiele von oben überhauptnicht.
Also werden Da wohl die Webmaster was falsch gemacht haben


Das liegt wohl da dran, dass der Apache unter Linux keine Klartextpasswörter zuläßt.
Oder du hast keine Berechtigung deinerseits Berechtigungen zu setzten.

Da kammt es jetzt halt darauf an was genau passiert.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby quizzmaster » 23. May 2004 08:49

Ich meinte jetzt, wenn ich die Website aufrufe und mich mit test/test einlogge geht das nicht.
greetz
quizzmaster

"Ich weiss, dass ich nichts weiss, aber ich weiss mehr als die, die nicht wissen, dass sie nichts wissen." Sokrates
quizzmaster
 
Posts: 28
Joined: 06. February 2004 15:06

Postby Wiedmann » 23. May 2004 09:30

quizzmaster wrote:Ich meinte jetzt, wenn ich die Website aufrufe und mich mit test/test einlogge geht das nicht.

Ach so, du meinst das Online-Demo bei "http://www.krizleebear.de/". Dann hatte ich dich falsch verstanden und mein letzter Post für dich ist nicht zutreffend.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 9 guests