Mysql Fehlermeldung 1067

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Mysql Fehlermeldung 1067

Postby waldi007 » 12. May 2004 20:49

hallo,

hab xampp installiert und sowohl apache als auch mysql als dienst installiert. der apache läuft, wenn ich ihn in der diensteverwaltung "manuell" starte.

mach ich das mit mysql, bekomme ich die fehlermeldung "Fehler 1067"

kennt jemand das problem?
waldi007
 
Posts: 1
Joined: 12. May 2004 20:44

Postby Wiedmann » 12. May 2004 21:16

Stimmen die Angaben in "C:\my.cnf" oder "C:\WINDOWS\my.ini"?
Ist eine der beiden Dateien überhaupt vorhanden?
Was steht in "C:\xampp\mysql\data\mysql.err"?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby airis » 24. May 2004 09:45

Hallo Wiedmann,

ich bin es mal wieder.

Habe das gleiche Problem seit gestern mit Fehler 1067.
Ich habe die my.ini in windows gelöscht und xampp neu installiert.
Immer noch das gleiche.
Folgendes steht in der my.ini jetzt:

# The MySQL client
[client]
#password = your_password
port = 3306
socket =D:/#server/xampp/mysql/mysql.sock

# Here follows entries for some specific programs

# The MySQL server
[mysqld]
port = 3306
socket = D:/#server/xampp/mysql/mysql.sock
skip-locking
set-variable = key_buffer=16M
set-variable = max_allowed_packet=1M
set-variable = table_cache=64
set-variable = sort_buffer=512K
set-variable = net_buffer_length=8K
set-variable = myisam_sort_buffer_size=8M
log-bin
server-id = 1

basedir=D:/#server/xampp/mysql
tmpdir=D:/#server/xampp/tmp
datadir=D:/#server/xampp/mysql/data

#bind-address=192.168.1.1
#log-update = /path-to-dedicated-directory/hostname

# Uncomment the following if you are using BDB tables
#set-variable = bdb_cache_size=4M
#set-variable = bdb_max_lock=10000

skip-innodb
# Uncomment the following if you are using InnoDB tables
#innodb_data_home_dir = D:/#server/xampp/mysql/
#innodb_data_file_path = ibdata1:10M:autoextend
#innodb_log_group_home_dir = D:/#server/xampp/mysql/
#innodb_log_arch_dir = D:/#server/xampp/mysql/
# You can set .._buffer_pool_size up to 50 - 80 %
# of RAM but beware of setting memory usage too high
#set-variable = innodb_buffer_pool_size=16M
#set-variable = innodb_additional_mem_pool_size=2M
# Set .._log_file_size to 25 % of buffer pool size
#set-variable = innodb_log_file_size=5M
#set-variable = innodb_log_buffer_size=8M
#innodb_flush_log_at_trx_commit=1
#set-variable = innodb_lock_wait_timeout=50

[mysqldump]
quick
set-variable = max_allowed_packet=16M

[mysql]
no-auto-rehash
# Remove the next comment character if you are not familiar with SQL
#safe-updates

[isamchk]
set-variable = key_buffer=20M
set-variable = sort_buffer=20M
set-variable = read_buffer=2M
set-variable = write_buffer=2M

[myisamchk]
set-variable = key_buffer=20M
set-variable = sort_buffer=20M
set-variable = read_buffer=2M
set-variable = write_buffer=2M

[mysqlhotcopy]
interactive-timeout

[WinMySQLadmin]
Server=D:/#server/xampp/mysql/bin/mysqld-nt.exe


Vieleicht kannst Du mir hier auch einen Rat geben.

Gruss

Airis
airis
 
Posts: 134
Joined: 18. May 2004 12:33

Postby Wiedmann » 24. May 2004 10:17

Hi airis,

Laut der ini ist der xampp in:
"D:/#server/xampp/" installliert. Ist das wirklich so? Beachte das "#" in der Pfadangeabe.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby airis » 24. May 2004 10:47

Hi Wiedmann,

ja der Pfad vom Server ist D:\#server, ist das nicht ok?
Habe es nur gemacht damit es als erstes steht.

Gruss
Airis
airis
 
Posts: 134
Joined: 18. May 2004 12:33

Postby Kristian Marcroft » 24. May 2004 11:57

Hi,

ein # ist ein Kommentar wie man am rest der config erkennen kann.
Evtl. würde ich mal das/die (Doppelkreuz/Raute) # weglassen...

So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Postby Wiedmann » 24. May 2004 11:58

Da in der ini-Datei, ein "#" das Kommentarzeichen ist, wird alles ab diesem Zeichen ignoriert.

MySQL sucht dann z.B. die Datenbanken direkt in "D:\".

@KriS
Der Ordner heißt bei ihm halt so... Da hilft auch das Weglassen in der ini-Datei nicht.

@airis
Mußt also den XAMPP in einen anderen Ordner installieren. Mit Zahlen am Anfang würd es ja wieder gehen,
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby airis » 24. May 2004 12:24

Hi Wiedmann,

eine neue Installation unter "D:/1server/xammpp" brachte den gewünschten Erfolg.

Danke nochmals

Airis
airis
 
Posts: 134
Joined: 18. May 2004 12:33


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 14 guests