Wechsel von 1.7 mit Win7 auf 1.8 mit Win8

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Wechsel von 1.7 mit Win7 auf 1.8 mit Win8

Postby klausiko » 17. June 2013 11:13

Hallo ihr hifsbereiten Experten,
seit Jahren laufen in userer Firma von mir verbrochene Verwaltungs- und Kalkulatiosprogramme auf HTML-Seiten mit PHP und JavaScript fehlerlos.Nachdem ich mir ein Table zugelegt habe um nicht ständig den schweren Laptop mitschleppen zu müssen, habe ich (Betiebssystem WIN8) den xampp 1.8 heruntergeladen
und problemlos installiert.Und läuft! Nur meine Programme laufen nicht mehr. Es kommen Errors --- unerwartetes Dateiende,unerwartete Else, nicht akzeptierbares "=" usw. Short_open_tags sind auf ON geschaltet.

Code: Select all
   while($row = mysql_fetch_object($query))
                  {
                  ?><option value="<?php =$row->Sart?>"<? if ($_POST['besteu'] == $row->Sart) { ?>selected="selected" <?php }  ?>>
                  <?php echo($row->Sart); ?>
                  </option>      
                  <?php
                                                 }
                                                 ?> 


Das "=" im value vor $row->$art wird nicht mehr akzeptiert, und gerade das hat den selektierten Wert bei einem notwendigen zwischen Submit im Feld gehalten und dadurch auch die abhängigen Werte in normalen Textfeldern.
Hat jemand einen brauchbaren Vorschlag für mich oder muß ich den 1.8 wieder runterschmeißen.
Ich grüsse herzlichst und hoffe auf eine Antwort klausiko
klausiko
 
Posts: 2
Joined: 17. June 2013 10:19
XAMPP Version: 5.5.19
Operating System: Windows 8

Re: Wechsel von 1.7 mit Win7 auf 1.8 mit Win8

Postby Altrea » 17. June 2013 12:41

Hallo klausiko,

klausiko wrote:Es kommen Errors --- unerwartetes Dateiende,unerwartete Else, nicht akzeptierbares "=" usw. Short_open_tags sind auf ON geschaltet.

Short_open_tags würde ich heutzutage nichtmehr aktivieren.
Zum einen gibt es seit PHP 5.4 die Möglichkeit die Kurzschreibweise <?= für <?php echo auch mit abgeschalteten short_open_tag zu nutzen und zum anderen sollten Scripte nicht unnötig von einzelnen Einstellungen abhängig sein.


klausiko wrote:
Code: Select all
   while($row = mysql_fetch_object($query))
                  {
                  ?><option value="<?php =$row->Sart?>"<? if ($_POST['besteu'] == $row->Sart) { ?>selected="selected" <?php }  ?>>
                  <?php echo($row->Sart); ?>
                  </option>      
                  <?php
                                                 }
                                                 ?> 


Das "=" im value vor $row->$art wird nicht mehr akzeptiert

Das ist auch vollkommen korrekt so. Statt "<?php =" solltest du "<?=" schreiben. Das ist sogar kürzer und lässt sich durch eine simple Suchen Ersetzen Prozedur lösen.

Nebenbei noch der Hinweis, dass die mysql_* Funktionen mit PHP 5.5 als deprecated gekennzeichnet sind und mit PHP 5.6 oder sehr PHP 6 wahrscheinlich ganz aus dem Core geschmissen werden.
Solltest du also auch weiterhin deine Umgebung aktuell halten wollen, ist ein Wechsel zu mysqli oder am besten gleich PDO anzuraten.

zu guter letzt noch der Tipp, sich an das EVA (Eingabe-Verarbeitung-Ausgabe) Prinzip zu orientieren.
Also zuerst alles was für die Ausgabe verarbeitet werden muss zusammenbauen, um die Ausgabelogik möglichst übersichtlich und funktional zu halten.
Dein oben gezeigter Code könnte nach EVA ungefähr so aussehen:
Code: Select all
//Verarbeitung
$options = array();
while($row = mysql_fetch_object($query)) {
    $value = $row->Sart;
    $selected = ($_POST['besteu'] == $value) ? ' selected="selected"' : '';
    $options[] = '<option value="'.$value.'"'.$selected.'>'.$value.'</option>';
}

// hier noch irgendwelcher anderer Verarbeitungscode

?>

<!-- Ausgabe - hier vorher DOCTYPE, html starttag, head und title, etc -->
<select name="select-xy">
<?=implode('', $options)?>
</select>



mit freundlichen Grüßen,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6752
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: Wechsel von 1.7 mit Win7 auf 1.8 mit Win8

Postby klausiko » 19. June 2013 19:51

Hallo Altrea, erst einmal besten Dank für deine schnelle Antwort.Leider haben alle meine Bemühungen auch mit deinen Hinweisen nicht zum Erfolg geführt.Ich habe also 1.8 wieder entfernt und durch 1.7 ersetzt.Lief auf Anhieb wieder wie gehabt.Wenn ich etwas mehr Zeit habe ,werde ich die Sache erneut in Angriff nehmen. Aber wann hat ein 73-jähriger Rentner schon Zeit.
Mit den besten Grüssen herzlichst klausiko
klausiko
 
Posts: 2
Joined: 17. June 2013 10:19
XAMPP Version: 5.5.19
Operating System: Windows 8


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 7 guests