Probleme mit XAMPP 1.4.2 Installer

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Probleme mit XAMPP 1.4.2 Installer

Postby JohKa » 07. May 2004 22:16

Hallo,

ich habe zwei Probleme mit der neusten Version.
1) ICh bekomme das Programm nicht geladen. Windows bricht den Download nach 1.1 MB ab. Gibt es eine andere möglichkeit das Programm zu laden?
2) Ich habe das an einem anderen PC geladen und dort installiert. Mein Problem ist, dass MySQL zwar startet Apache aber net. Kann mir da jemand mal helfen?


MFG

JohKa
JohKa
 
Posts: 7
Joined: 07. May 2004 22:11

Postby Wiedmann » 07. May 2004 22:18

zu eins:
einen Virenscanner installiert?

zu zwei:
Ohne genaue Fehlermeldung.... Glaskugel hat Ausgang ;-)
Schätzungsweise blockiert aber ein anderes Programm den Port 80 und/oder 443.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby JohKa » 07. May 2004 22:23

zu eins:

Ja habe ich installiert. Daran kann es aber net liegen, da andere Downloads problemlos installieren.

zu zwei:
Es kommte keine Fehlermeldung. Wenn ich auf "xampp basic start" klicke, öffnet sich ein Dos-Fenster, das sich nach ca. 2 Sekunden wieder schließt.

P.S: Wie finde ich heraus, welches Programm den Port 80 bzw. 443 belegt?
JohKa
 
Posts: 7
Joined: 07. May 2004 22:11

Postby Wiedmann » 07. May 2004 22:36

zu eins:
in dem Packet befindet sich eine Datei die von machen Virenscannern als unerwünscht angesehen wird. Daher wird in diesem Fall der Download und/oder das Ausführen abgebrochen.

zu zwei:
welches Betriebssystem?
Ein anderere Webserver, skype.... gibts viele Möglichkeiten.

In der Eingabeaufforderung kannst du mal eingeben:
netstat -a -n | more

dann siehst du schonmal ob ein :80 oder :443 auftaucht.
Das Prog TCPView wär auch eine Möglichkeit.

Wenn du schon mal in der Eingabeaufforderung bist:
wechsel mit "cd \xampp" oder "cd \progamme\xampp" ins XAMPP-Verzeichnis und ruf die Datei "apache_start.bat" auf. Dann siehst du die Fehlermeldung.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby JohKa » 08. May 2004 07:59

zu eins:
Danke für den Hinweis, habe den Virusscanner deaktiviert und es ging super schnell.

zu zwei:
Ich habe Windoof XP
ich habe das mal mit netstat gemacht und bei dem Port 80 und 443 steht unter Status "abhören".

[EDIT]Ich habe das jetzt mal über apache_start.bat versucht. Es kommt nichts, nach einer Sekunde schließt sich das Fenster wieder und ich kann trotzdem nicht auf http://localhost/ zugreifen.

[EDIT 2] Ich habe zwei Fehlermeldungen gefunden.
1) make_sock: could not bind to address 0.0.0.0:443
2) Der Name für den Dienst ist ungültig
JohKa
 
Posts: 7
Joined: 07. May 2004 22:11

Postby Wiedmann » 08. May 2004 09:36

ich habe das mal mit netstat gemacht und bei dem Port 80 und 443 steht unter Status "abhören".

Also läuft schon ein Webserver. So kann der XAMPP nie starten. Hast du zufällig den Webserver von XP installiert (IIS)?

Geh nochmal in die Eingabeaufforderung und gib ein:
netstat -a -n -o | findstr "PID :80 :443"

danach führst du das Folgende für jede gefundene PID aus (xxxx = PID)
tasklist /svc /fi "PID eq xxxx"

Jetzt hast du das Programm/Dienst welches dafür verantwortlich ist.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby JohKa » 08. May 2004 16:00

So habe das Programm gefunden, das den Port belegt und es beendet. Jetzt funzt es. Danke.
JohKa
 
Posts: 7
Joined: 07. May 2004 22:11

Postby Kristian Marcroft » 08. May 2004 22:23

JohKa wrote:So habe das Programm gefunden, das den Port belegt und es beendet. Jetzt funzt es. Danke.


Hi,

verrätst du uns auch welches Prog das war?
Denn so können andere User welche die Foren Suche verwenden die das gleiche Prob haben, möglichst schnell ihr Prob lösen...

So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Postby JohKa » 08. May 2004 23:28

Aso natürlich.

Das Prog heißt Skype.
JohKa
 
Posts: 7
Joined: 07. May 2004 22:11

Postby Kristian Marcroft » 09. May 2004 00:46

JohKa wrote:Aso natürlich.

Das Prog heißt Skype.


Hi,

und hättest du die Foren Suche verwendet.. und/oder in die FAQ geschaut, hättest das auch gewusst. :)

So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Postby JohKa » 09. May 2004 08:07

Oh, ich habe gesucht, aber bin zu keinem Ergebnis gekommen und an die FAQ habe ich net gedacht. Mache ich das nächstemal.
JohKa
 
Posts: 7
Joined: 07. May 2004 22:11


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 15 guests