Aufruf des Verzeichnis htdocs gibt 404 aus ?

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Aufruf des Verzeichnis htdocs gibt 404 aus ?

Postby ralleprivat » 02. June 2013 08:49

Guten Morgen,

nun versuche ich schon seit Stunden, die Version 1.8.1 unter Windows zum laufen zu bekommen.
Die Installation läuft völlig normal und ohne Fehler ab.
Das Controlpanel funktioniert und
Code: Select all
http://localhost/xampp/
wird im Browser auch ausgegeben.
Auch keine Probleme in der dortigen Statusanzeige.

Versuche ich aber nun
Code: Select all
http://localhost/xampp/htdocs/
wird mir 404 augegeben. Das passiert bei jeder angesprochen Datei.

Ich habe mehrfach neu installiert und es auch mit Version 1.8.0 versucht - ohne Ergebnis.

Wie kann ich dieses Problem lösen ?
Ich bin für jede Hilfe dankbar und wünsche noch einen schönen Sonntag.
Viele Grüße
Ralf

Apache Error-Log:
Code: Select all
[Sun Jun 02 09:31:50.118885 2013] [ssl:warn] [pid 3664:tid 440] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Sun Jun 02 09:31:50.165763 2013] [mpm_winnt:notice] [pid 3664:tid 440] AH00455: Apache/2.4.3 (Win32) OpenSSL/1.0.1c PHP/5.4.7 configured -- resuming normal operations
[Sun Jun 02 09:31:50.165763 2013] [mpm_winnt:notice] [pid 3664:tid 440] AH00456: Server built: Aug 18 2012 12:41:37
[Sun Jun 02 09:31:50.165763 2013] [core:notice] [pid 3664:tid 440] AH00094: Command line: 'C:\\program files (x86)\\xampp\\apache\\bin\\httpd.exe -d C:/Program Files (x86)/xampp/apache'
[Sun Jun 02 09:31:50.165763 2013] [mpm_winnt:notice] [pid 3664:tid 440] AH00418: Parent: Created child process 1884
[Sun Jun 02 09:31:50.634538 2013] [ssl:warn] [pid 1884:tid 412] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Sun Jun 02 09:31:50.665787 2013] [mpm_winnt:notice] [pid 1884:tid 412] AH00354: Child: Starting 150 worker threads.


PHP Error-Log:
Code: Select all
[02-Jun-2013 07:32:57 UTC] PHP Warning:  file_get_contents(lang.tmp): failed to open stream: No such file or directory in C:\Program Files (x86)\xampp\htdocs\xampp\index.php on line 2
ralleprivat
 
Posts: 2
Joined: 02. June 2013 08:38
XAMPP Version: 5.6.3
Operating System: Windows 8

Re: Aufruf des Verzeichnis htdocs gibt 404 aus ?

Postby Nobbie » 02. June 2013 10:17

ralleprivat wrote:Versuche ich aber nun
Code: Select all
http://localhost/xampp/htdocs/
wird mir 404 augegeben. Das passiert bei jeder angesprochen Datei.



Das ist ja auch Käse - einfach nur http://localhost

Offensichtlich kennst Du gar nichts von Apache und Webservern. Am besten fängst beim Lesen der Doku beim Kapitel "DocumentRoot" an. Damit Du verstehst, warum das so ist und nicht anders.
Nobbie
 
Posts: 6921
Joined: 09. March 2008 13:04

Re: Aufruf des Verzeichnis htdocs gibt 404 aus ?

Postby ralleprivat » 02. June 2013 10:48

Stimmt, denn ich fange erst an.
Trotzdem vielen Dank für den Tip.

Viele Grüße
Ralf
ralleprivat
 
Posts: 2
Joined: 02. June 2013 08:38
XAMPP Version: 5.6.3
Operating System: Windows 8


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 14 guests