htaccess - Rewrite Problem!?

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

htaccess - Rewrite Problem!?

Postby Cobretty » 01. June 2013 16:27

Hallo zusammen,

ich bin am verzweifeln. :(

Ich habe die neue Version von Xampp rutnergeladen und installiert (1.8.1).

Früher habe ich meine ganzen Ordner(Webseiten) im htdocs Ordner immer über die Ports aufgerufen.

z. B.:

Code: Select all
Listen 9999

<VirtualHost *:9999>
   DocumentRoot "C:/xampp/htdocs/xyz"
   Options FollowSymLinks
   <Directory "C:/xampp/htdocs/xyz">
      AllowOverride All
      Options FollowSymLinks
      Order allow,deny
      Allow from all
   </Directory>
</VirtualHost>


Dann hab ich halt in den Browser -> localhost:9999 eingegeben und die Website xyz wurde aufgerufen.


Wenn ich jetzt aber so vorgehe wie gehabt, startet Apache nicht mehr. Also wenn ich in der httpd-vhosts mehrere "Webseiten anlege" . Im Controlpannel sehe ich, dass er dann 9999, 9998, 9997 etc. aufruft. Und wenn es dann ich glaub mehr als 3 sind, startet Apache nicht mehr.


Dann habe ich das ganze OHNE z.b. "Listen 9999" versucht und die Webseiten lokal dann mit localhost/xpz aufgerufen. Das geht auch wenn sich eine index.html in dem Ordner befindet.

Aber sobald ich Rewrite Rechte über die htaccess bestimme, findet er die Seite nicht. Und wenn ich die RewriteEngine auf Off stelle, wird mir nur die Struktur / Liste der Seite angezeigt. Aber halt kein css funktioniert etc.

Hier meine htaccess:

Code: Select all
RewriteEngine on
Options +FollowSymLinks
RewriteBase /



########### DEUTSCH ###########

# Seiten
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule ^(home|agentur|projekte|sorglos-lounge|news|kontakt|impressum).html$      mainfile.php?bereich=$1&seite=index&lang=de [QSA,L]

# ROOT
RewriteRule ^$                                                   mainfile.php?bereich=home&seite=index&lang=de

########### Error 404 ###########
#ErrorDocument 404                                                mainfile.php?bereich=error&seite=404&lang=de

########### ALLES ZU ROOT WAS NICHT WWW IST ###########
#    RewriteCond %{HTTP_HOST}                                  !^www\.xyz.de$ [NC]
#   RewriteRule ^(.*)$                                             http://www.xyz.de/? [R=301,L]



Ich dache, wenn ich das mit dem rewrite hinbekomme, dass immer meine "mainfile.php" aufgerufen wird, könnte ich mir das mit den Ports aufrufen sparen bzw. mit dem "Listen" jedesmal in der httpd-vhosts und alle webseiten über die Namen direkt aufrufen (localhost/NameDesOrdners).


Ich wäre super dankbar für ein Feedback oder einen Tipp. Ich weiß nicht mehr weiter.

Beste Grüße

Cob
Cobretty
 
Posts: 11
Joined: 27. February 2011 13:36
XAMPP Version: 5.6.3
Operating System: Windows Vista 32 bit

Re: htaccess - Rewrite Problem!?

Postby Nobbie » 01. June 2013 22:23

Cobretty wrote:Wenn ich jetzt aber so vorgehe wie gehabt, startet Apache nicht mehr. Also wenn ich in der httpd-vhosts mehrere "Webseiten anlege" .


"Prosa" ist hier ungeeignet, zeige doch einfach die originale Konfiguration. Und schaue vor allem im error.log, was da steht, warum Apache nicht startet.

Im Controlpannel sehe ich, dass er dann 9999, 9998, 9997 etc. aufruft. Und wenn es dann ich glaub mehr als 3 sind, startet Apache nicht mehr.


Cobretty wrote:Dann habe ich das ganze OHNE z.b. "Listen 9999" versucht und die Webseiten lokal dann mit localhost/xpz aufgerufen. Das geht auch wenn sich eine index.html in dem Ordner befindet.

Aber sobald ich Rewrite Rechte über die htaccess bestimme, findet er die Seite nicht. Und wenn ich die RewriteEngine auf Off stelle, wird mir nur die Struktur / Liste der Seite angezeigt. Aber halt kein css funktioniert etc.


Das ist definitiv unverständlich. Was hast Du vor? Könntest Du das mit besseren Beispielen erläutern?

Cobretty wrote:Ich dache, wenn ich das mit dem rewrite hinbekomme, dass immer meine "mainfile.php" aufgerufen wird, könnte ich mir das mit den Ports aufrufen sparen bzw. mit dem "Listen" jedesmal in der httpd-vhosts und alle webseiten über die Namen direkt aufrufen (localhost/NameDesOrdners).


S.o. - es ist nicht verständlich, was Du erreichen willst.
Nobbie
 
Posts: 6585
Joined: 09. March 2008 13:04

Re: htaccess - Rewrite Problem!?

Postby Cobretty » 02. June 2013 11:58

Im error.log stand ja nie was drin.

Also wie in dem Beispielcode beschrieben, habe ich immer meine lokalen Websiten mit den Ports aufgerufen: "localhost:9999" etc. Das ging aber auf einmal nicht mehr nach der neuen xampp version.

Dann habe ich das "Listen 9999" weggelassen und die Website so aufgerufen: "localhost/xyz". Das ging, aber nur wenn direkt im Ordner eine index.html datei drin war und nicht wenn ich mit einer htaccess die rewrite rechte vergeben habe bzw. auf mainfile.php verwiesen habe.

Seit heut morgen ist es so, dass Apache läuft, aber er über "localhost:9999" die xampp startseite aufruft. Wie bei "localhost:80". Obwohl ein ganz anderer Ordner auf 9999 hinterlegt ist. Aber die anderen laufen. Immerhin. Warum auch immer.
Ich lass das jetzt erstmal so.

Jetzt hat sich aber ein neues Problem ergeben, dass mein xt:comerce 4.0.16 nicht richtig dargestellt wird. Als ob die css nicht gefunden wird. Aber hierzu mach ich einen neuen Thread auf, da es sonst nicht mehr mit diesem Betreff passt. :)
Cobretty
 
Posts: 11
Joined: 27. February 2011 13:36
XAMPP Version: 5.6.3
Operating System: Windows Vista 32 bit

Re: htaccess - Rewrite Problem!?

Postby Nobbie » 02. June 2013 20:49

Cobretty wrote:Im error.log stand ja nie was drin.


Dann schaust Du an der falschen Stelle.
Nobbie
 
Posts: 6585
Joined: 09. March 2008 13:04


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 9 guests