Webalizer funzt nicht (XAMPP 1.4.2.Windows)

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Webalizer funzt nicht (XAMPP 1.4.2.Windows)

Postby zero » 03. May 2004 14:13

Hallo,

ich habe XAMPP 1.4.2 für Windows installiert. Soweit läuft
auch alles - nur erstellt der Webalizer keine neuen Statistiken.

Wenn ich über die XAMPP-Startseite auf Webalizer zugreife, zeigt
er nur die Daten vom 2. Juni 2003 (Eure Daten) an.

Die Access.log wird aber gefüllt, aber anscheinend nicht ausgewertet.

Wo könnte das Problem liegen?
MfG
Zero
zero
 
Posts: 6
Joined: 03. May 2004 14:05

Re: Webalizer funzt nicht (XAMPP 1.4.2.Windows)

Postby BartonFink » 03. May 2004 18:23

zero wrote:Wo könnte das Problem liegen?


Hast Du schon mal webalizer.bat gestartet?
BartonFink
 
Posts: 8
Joined: 17. April 2004 09:03

Postby Kristian Marcroft » 03. May 2004 18:55

Hi,

er muss eignetlich nur:

http://localhost/xampp/webalizer.php aufrufen.. dann wird die webalizer.bat durch php aufgerufen...

So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Postby zero » 03. May 2004 20:29

Guten Abend...

Ja, ich habe die webalizer.bat schon manuell gestartet und
habe auch die webalizer.php aufgerufen. Leider wird die Anzeige nicht
aktualisiert :-(
Es werden immer nur die Beispieldaten angezeigt.

Der Rechner läuft in einem Netzwerk und ich habe die etc/Hosts angepasst:
127.0.0.1 Intranet.

Kann das damit zu tun haben?
MfG
Zero
zero
 
Posts: 6
Joined: 03. May 2004 14:05

Postby zero » 09. May 2004 16:28

Ich habe mir das Problem mal genauer angesehen.
Wenn ich die webalizer.bat manuell starte, wird auch eine neue index.html aufgebaut (im Webalizer-Verzeichnis). Wenn ich diese mit dem Browser aufrufe,
enthält diese auch alle aktuellen Daten.

Wenn ich aber die Xampp-Startseite aufrufe und dann unter Tools auf Webalizer
klicke, bekomme ich keine aktuelle Statistik angezeigt - sondern immer
nur die von 02. Juni.

Sind da einige Scripte oder Dateien nicht "richtig" eingestellt?
Kann mir jemand eine Lösung oder einen Tipp geben?
MfG
Zero
zero
 
Posts: 6
Joined: 03. May 2004 14:05

Postby zero » 10. May 2004 08:02

Hat denn keiner eine Idee?
Sollte ich lieber eine ältere Version von Xampp nehmen?
Diese ist die erste, bei der die Geschichte mit dem Webalizer
nicht richtig funzt.
MfG
Zero
zero
 
Posts: 6
Joined: 03. May 2004 14:05

Postby zero » 10. May 2004 08:29

Es sieht so aus, als würde der shell_exec Aufruf der webalizer.php
nicht funzen.
Save_mode = off, aber es läuft nicht.
Ideen?
MfG
Zero
zero
 
Posts: 6
Joined: 03. May 2004 14:05

Postby Wiedmann » 10. May 2004 11:43

Ersetze in der Datei:
C:\xampp\htdocs\xampp\webalizer.php

die Zeile mit dem "shell_exec" durch folgende Zwei:
Code: Select all
$progpath = realpath('../../webalizer/');
exec($progpath.'/webalizer.exe -c '.$progpath.'/webalizer.conf');


Nach Aufrufen von dem Link wirst du aber den Frame trotzdem nochmal neu laden müssen, da der Browser diesen erst einmal aus dem Cache holt.

Kann dir aber auch bei Interesse eine ganz andere Alternative für den Aufruf vom Webalizer zukommen lassen.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby zero » 10. May 2004 14:13

Wiedmann wrote:Ersetze in der Datei:
C:\xampp\htdocs\xampp\webalizer.php

die Zeile mit dem "shell_exec" durch folgende Zwei:
Code: Select all
$progpath = realpath('../../webalizer/');
exec($progpath.'/webalizer.exe -c '.$progpath.'/webalizer.conf');


Nach Aufrufen von dem Link wirst du aber den Frame trotzdem nochmal neu laden müssen, da der Browser diesen erst einmal aus dem Cache holt.

Kann dir aber auch bei Interesse eine ganz andere Alternative für den Aufruf vom Webalizer zukommen lassen.


Super! Vielen Dank, jetzt funktioniert alles.
Deine Alternative würde mich aber trotzdem interessieren - soll
ich Dir eine persönliche Nachricht zukommen lassen? (Will nicht aufdringlich sein)
MfG
Zero
zero
 
Posts: 6
Joined: 03. May 2004 14:05

Postby Wiedmann » 10. May 2004 15:34

Kannst du gerne machen. (Dann weiß ich wenigstens mal ob das wo anders auch tut ;) )

Schick einfach ne PM mit deiner EMail.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 10 guests