Apache als Service auf Windows NT 4.0 SP6

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Apache als Service auf Windows NT 4.0 SP6

Postby Unikat2k4 » 25. April 2004 19:52

Hi,

also ich habe mir heute das neuste XAMPP Paket runtergeladen und direkt installiert. Alles hat auch wunderbar geklappt bis auf folgende Sachen, beftreffend Apache und MySQL als Service laufen zu lassen:

1) In der mysql_installservice.bat steht eine Kopieroption, die nicht mit Windows NT 4.0 kompatibel zu sein scheint. /-y funktioniert jedenfalls nicht und somit wird die my.ini nicht ins Windows Verzeichnis kopiert, was dazu führt das MySQL nicht richtig gestartet werden kann. Nachdem ich die Option gelöscht hatte, funktionierte die .bat-Datei ohne Probleme.

2) Jetzt kommen wir zu einem Problem, was ich noch nicht lösen konnte und und weswegen ich den Thread hier mal gestartet habe. Den Apache möchte ich auch als Service laufen lassen, was mit der apache_installservice.bat ja auch kein Problem sein sollte. Es kommt zu keiner Fehlermeldung nach dem Ausführen dieser Datei, sondern erst nach dem Neustart.

Kurz nach dem Einloggen kommt der Hinweis, das ein Service nicht gestartet werden konnte. In der Ereignisanzeige ist zu lesen, das der Service Control Manager einen Fehler 7024 mit der Bemerkung "Der Apache2 terminierte mit Dienstfehler 1. " gemeldet hat . Auch nach langem suchen konnte ich keinen Grund dafür finden. Kann mir jemand diesbezüglich helfen?

PS: Habe XAMPP auch testweise mal auf Windows XP Pro SP1 installiert, wo es zu keinem der erwähnten Probleme gekommen ist. Ich weiß auch, das Windows NT 4.0 alt ist, aber daran kanns doch echt nicht liegen, oder?
Unikat2k4
 
Posts: 6
Joined: 25. April 2004 11:44

Postby Apache-User » 25. April 2004 20:10

schon mal geschaut ob port 80 durch etwas blockiert ist und apache deswegen nicht starten kann??
mfg
D.A.U.™
User avatar
Apache-User
 
Posts: 594
Joined: 30. December 2002 16:50
Location: anonym

Postby Unikat2k4 » 25. April 2004 20:19

jep....direkt nachdem der service installiert ist, läuft der apache auch...nur nach dem Neustart leider nicht mehr.....
Unikat2k4
 
Posts: 6
Joined: 25. April 2004 11:44

Postby Wiedmann » 25. April 2004 20:39

Kurz nach dem Einloggen kommt der Hinweis, das ein Service nicht gestartet werden konnte. In der Ereignisanzeige ist zu lesen, das der Service Control Manager einen Fehler 7024 mit der Bemerkung "Der Apache2 terminierte mit Dienstfehler 1. " gemeldet hat . Auch nach langem suchen konnte ich keinen Grund dafür finden. Kann mir jemand diesbezüglich helfen?

Da hast du wohl nur ins Ergeignisprotokoll --> System geschaut.
Was steht denn im Ergeignisprotokoll --> Anwendung?

Kannst den Apache auch mal über die Batch (am besten aus der Eingabeaufforderung starten) als Konsolenanwendung starten. Was zeigt er da an?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Unikat2k4 » 25. April 2004 20:50

hi,

also in Ergeignisprotokoll --> Anwendung taucht gar keine fehlermeldung auf...nur in Ergeignisprotokoll --> System

Über den Batch läßt sich Apache ohne Probleme starten und funktioniert einwandfrei...naja wäre aber schöner, wenn er auch als service laufen würde :)
Unikat2k4
 
Posts: 6
Joined: 25. April 2004 11:44

Postby Wiedmann » 25. April 2004 21:19

Hm. im error.log steht bestimmt auch nichts.... Komisch das er als Konsolenanwendung läuft.

Mal folgender Test:
1.) Service über Batchdatei deinstallieren
2.) Regedit starten. Alle Schlüssel die noch mit "Apache" anfangen im Zweig "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\" löschen.
3.) Rechner neu starten
4.) Ins Verzeichnis "C:\xampp\apache\bin" gehen und eingeben:
"Apache.exe -k install"
5.) eingeben: "net start Apache2" --> läuft?
6.) Rechner neu starten --> läuft Apache nach Neustart immer noch?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Unikat2k4 » 25. April 2004 21:30

zu 5) ja

zu 6) nein

aber ich habe im error log folgende fehlermeldung gefunden:

[Sun Apr 25 22:27:42 2004] [error] Init: Failed to generate temporary 512 bit RSA private key
Unikat2k4
 
Posts: 6
Joined: 25. April 2004 11:44

Postby Wiedmann » 25. April 2004 21:59

Hm. also liegts am mod_ssl.

in der ssl.conf: Steht "SSLMutex" auf "default"?

Wenn du SSL nicht brauchst, deaktivier mal das Modul:
#LoadModule ssl_module modules/mod_ssl.so

Hm. Ich denke mal er will wo zugreifen, wo er als SYSTEM keine Berechtigung hat, sondern nur der Benutzer der das eingerichtet hat.
(Die Standard-Verzeichnisberechtigungen unterscheiden sich zwischen NT4 und W2K/XP etwas)

Versuch: XAMPP - Verzeichnis mit rechts anklicken --> Berechtigungen --> Jeder=Vollzugriff --> Vererben an Unterverzeichnisse.

Du könntest jetzt auch noch den Apache-Dienst als bestimmter Benutzer einrichten.

Oder mit z.B. "NTFILMON" schauen worauf er da zugreifen will.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Unikat2k4 » 26. April 2004 19:52

hi

also in meiner ssl.conf steht leider keine Option namens SSLMutex!! Muss das da drin stehen? Habe SSLMutex=default mal hinzugefügt

Also ich brauche SSL auch momentan nicht...daher habe ich es mal deaktiviert

Da ich als Administrator eingloggt war....hatte ich jederzeit Vollzugriff...habe trotzdem mal die Bereichtungen auf die Unterverzeichnisse angewendet...

leider hat das das Problem nicht gelöst.....

der genannte Fehler steht nicht mehr im error log....

erstmal danke für deine hilfe...werde mal schauen, ob die nächste XAMPP Version das Problem löst...
Unikat2k4
 
Posts: 6
Joined: 25. April 2004 11:44

Postby Unikat2k4 » 30. April 2004 17:21

hab mal den original apache_2.0.49-win32-x86-no_ssl nebenbei installiert....komischerweise startet der als service ohne probleme...
Unikat2k4
 
Posts: 6
Joined: 25. April 2004 11:44

Postby Kerbie » 03. May 2004 21:31

LAso ich benutze auch Win NT 4.0 Sp6 Ich habe das selbe problem wenn ich Apache als service laufen lasse das er mal direkt bei start anspringt oder ich ihn manuel nachladen darf bei dienste obwohl dort selber steht das er automatisch gestartet werden soll. Naja keine ahnugn warum aber da ich den rechner sowiso selten neustarte ist ganz in ordnung

Gruß

Kerbie
User avatar
Kerbie
 
Posts: 1
Joined: 03. May 2004 21:18
Location: Oberhausen

SSL entfernen

Postby abx » 30. November 2004 23:09

Also bei mir hat es jetzt geklappt, indem ich das Laden der ssl.conf in der httpd.conf auskommentiert habe. Ich brauch eh kein ssl und das automatische Starten als Dienst war mir wichtig. Schade, dass dieses Problem auch mit der aktuellen Version noch existiert, der Thread ist ja schon etwas älter.
abx
 
Posts: 1
Joined: 30. November 2004 22:56

Postby Kristian Marcroft » 01. December 2004 09:57

Hi,

leider kann ich diese Fehler überhaupt nicht nachvollziehen.
XAMPP läuft hier bei uns im Intranet auf einem WinNT 4.0 SP6a Server
Ohne mucken. Mittlerweile ca. 2500 HTML/PHP Seiten laufen darüber....

Durch einfaches auskommentieren der SSL.conf soll es funzen?
Ich vermute das ihr den IIS noch aktiv habt. Denn die SSL.conf lässt den apache an Port 443 binden.

Was sagt denn Apache wenn ssl.conf includet ist und du Apache über ein cmd startest? (start_apache.bat)

So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 8 guests