Apache startet nicht mit Netwerklaufwerk

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Apache startet nicht mit Netwerklaufwerk

Postby nepas » 11. April 2013 20:16

Unter Windows 7 wurde XAMPP installiert, Firefox zeigt mit "localhost" die erwarteten Seiten.

Da die Skripte auf einem anderen PC (XP) liegen, habe ich das entsprechende Verzeichnis vollständig freigegeben und mittels mittels "Netzlaufwerk verbinden" dem Laufwerksbuchstaben Z zugeordnet. Auf dem Windows 7 Rechner sehe ich im Explorer unter Laufwerk Z die Skripte, die sich auf dem XP-Rechner befinden. Beide Rechner haben die gleiche Bezeichnung der Arbeitsgruppe.

Auf dem Windows 7 Rechner habe ich dann in der Datei httpd.conf die Einstellungen bzgl. DocumentRoot auf "Z:" eingestellt. Falls ich jetzt als Administrator das Control-Panel aufrufe und den Button "Apache Starten" anklicke, bekomme ich folgende Fehlermeldung:

Fehler: Apache wurde unerwartet beendet.
Ursache könnte ein geblockter Port, fehlende Abhängigkeiten,
fehlende Berechtigungen, ein Absturz oder ein Abbruch einer anderen Methode sein.
Überprüfe die Datei "/xampp/apache/logs/error.log"
und die Windows Ereignisanzeige für weitere Hinweise

Installation und Programmstart wurden jeweils als Administrator gestartet.

Was mache ich falsch, bzw. wie müsste es richtig gehen?

Viele Grüße

Willi
nepas
 
Posts: 3
Joined: 11. April 2013 19:07
XAMPP Version: 5.6.3
Operating System: Windows 7

Re: Apache startet nicht mit Netwerklaufwerk

Postby Altrea » 12. April 2013 03:56

Netzlaufwerke sind Benutzerbezogen. Führst du ein Programm als Administrator aus, ändert sich der Benutzerkontext. Die Prozesse haben also keine Ahnung davon, was bei irgendeinem lokalen Benutzer Laufwerk Z ist.
Du kannst aber UNC-Pfade verwenden, um Dateien von Netzlaufwerke anfragen und ausliefern zu können.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6490
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: Apache startet nicht mit Netwerklaufwerk

Postby nepas » 12. April 2013 19:06

Guten Tag,

zunächst einmal danke für die Antwort und den Denkanstoss.

Leider habe ich noch keinen Erfolg, sondern bekomme die gleichen Fehlermeldungen; in der httpd.conf lauten die betreffenden Zeilen

DocumentRoot "\\pcwilli\web-app"
bzw.
<Directory "\\pcwilli\web-app">

Servername und Freigabenamen habe ich überprüft; mit dir \\pcwilli\web-app bekomme ich unter cmd die erwarteten Dateien angezeigt.

Wo liegt mein Denkfehler?

Viele Grüße

Willi
nepas
 
Posts: 3
Joined: 11. April 2013 19:07
XAMPP Version: 5.6.3
Operating System: Windows 7

Re: Apache startet nicht mit Netwerklaufwerk

Postby Altrea » 12. April 2013 19:34

Hallo Willi,

nepas wrote:Wo liegt mein Denkfehler?

Nur ein fehlender wissensbaustein. Versuchs einmal mit forward slashes statt backward slashes. Auch obwohl du dich auf einem Windows Betriebssystem befindet akzeptiert der Apache diese Slashes in der Regel unproblematischer.

Mit freundlichen Grüßen,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6490
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: Apache startet nicht mit Netwerklaufwerk

Postby nepas » 13. April 2013 18:42

Guten Abend,

vielen Dank für diesen Wissensblock.

Unter dem Control-Panel kann ich jetzt des Apache-Server starten. Allerdings erhalte ich unter "localhost" - sowohl Firefox als auch Internet Explorer - den Fehler

403 -
Der Zugriff auf das angeforderte Verzeichnis ist nicht möglich. Entweder ist kein Index-Dokument vorhanden oder das Verzeichnis ist zugriffsgeschützt.


Verschiedentlich wird empfohlen, die Sicherheitseinstellung in der Konfigurationsdatei "httpd-xampp.conf", was jedoch äußerst riskant ist.

Gibt es einen einfacheren Weg, wie ich weiterkommen könnte?

Viele Grüße

Willi
nepas
 
Posts: 3
Joined: 11. April 2013 19:07
XAMPP Version: 5.6.3
Operating System: Windows 7

Re: Apache startet nicht mit Netwerklaufwerk

Postby Altrea » 13. April 2013 19:15

Du hast ein Verzeichnis für Anfragen, aber scheinbar keine expliziten Zugriffsregeln im Apache definiert.
In der httpd.conf existiert bereits ein entsprechender <Directory> Block mit Zugriffsregeln für den vorigen DocumentRoot Eintrag. Diesen könntest du einfach umlegen.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6490
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 17 guests