index.php im htdocs wird nicht angezeigt

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

index.php im htdocs wird nicht angezeigt

Postby stephanF » 22. April 2004 11:09

Hallo zusammen und einen schönen Tag wünsche ich,

die ist mein erster Beitrag und den Schreibe ich aus lauter Verzweiflung.
Folgendes Problem:

Installation von XAMMP 1.4.2 auf WinXP Pro. Funktioniert hier einwandfrei. Wenn ich innerhalb unseres Intranets mit den Clients meinen Server aufrufe mit http://MeinRechnerName erscheint auch die Startseite von XAMMP. Auch funktioniert eine Ebene tiefer die index.php aus dem Verzeichnis xammp. Soweit sogot.
Alle meine Webprojekte liegen in einem Ordner "www" dieser befindet sich im Verzeichnis htdocs.
Wenn ich nun über die Clients (auch WinXP) "http://MeinRechnerName/www" eingebe, erschein eine "index of" seite.Das ist OK, weil keine index.htm oder php vohanden ist.
JETZT KOMMT DER FEHLER:
Wechsele ich jetzt in ein Verzeichns mit einer index.HTM, funktioniert alles. Wechsele ich aber in ein Verzeichnis mit einer index.PHP kann die Seite nicht angezeigt weden.

in meiner httpd.conf steht aber alles drin:
DirectoryIndex index.html index.htm index.php index.php4 index.php3 index.cgi index.pl index.html.var index.phtml.

Bitte, bitte, brauche dringend Hilfe, damit unsere Firma wieder af unsere DB zugreifen kann.

Wie gesagt, das Problem betrifft "nur" die Clients. Auf dem Server mit der XAMMP-Installation läuft alles einwandfrei.

Danke Euch schon mal im Voraus

mit freundlichen Grüßen aus Thüringen

Stephan
stephanF
 
Posts: 5
Joined: 22. April 2004 10:42

Postby Rolidor » 22. April 2004 13:38

Benutze selbst kein XP. Möglicherweise hat das aber (wie bei Linux/Unix) was mit der Rechtevergabe für den entsprechenden Ordner zu tun. Die müssten 'ausführbar' beinhalten!?
Rolidor
 
Posts: 406
Joined: 20. April 2004 10:17
Location: Dreieich - Hessen

Postby stephanF » 22. April 2004 13:59

Leider ist das nicht der Fehler. Mit den Rechten hat das nx zu tun. Trotzdem Danke für die Info

schöne Grüße aus Thüringen
Stephan
stephanF
 
Posts: 5
Joined: 22. April 2004 10:42

Postby Wiedmann » 22. April 2004 14:11

Was steht denn im "error.log"?

(wenn du die "index.htm" umbenennst in "index.php" funktioniert es also nicht mehr?)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby stephanF » 22. April 2004 15:26

Richtig, alle index.htm geht, und index.php funktionert nicht
stephanF
 
Posts: 5
Joined: 22. April 2004 10:42

Postby Heini_net » 22. April 2004 15:59

kanns vielleicht sein das in der httpd.conf paar einträge auskommentiert werden müssen z.b das die php.exe aufgerufen werden muss usw ?

Mfg. Heini
User avatar
Heini_net
 
Posts: 520
Joined: 25. July 2003 15:43
Location: hier

Postby stephanF » 22. April 2004 17:59

Dann würde es doch auf dem Server mit der Installation doch auch nicht gehen, oder...???

php Dateien in weiteren unterverzeichnissen gehen auch nicht ist mir eben aufgefallen.
stephanF
 
Posts: 5
Joined: 22. April 2004 10:42

Postby Rolidor » 22. April 2004 19:43

Drei Kleinigkeiten fallen mir da evt. noch ein.
1. Du hast in deinem 1sten Posting die Endung php groß geschrieben. Habe sogar auf meiner Winwurst98-Kiste zeitweise Schwierigkeiten, wenn die Groß/Kleinschreibung nicht mit dem Dateinamen übereinstimmt. Ist im Explorer auch nicht gleich zu sehen, da der standardmäßig nur den ersten Buchstaben groß anzeigt, auch wenn der Dateiname tatsächlich mehrere Großbuchstaben enthält. Groß geschriebene Dateiendungen ignoriert Apache bei mir geflissentlich.
2. Wenn du 'index.html' und 'index.php' im Verzeichnis liegen hast, wird die Datei bevorzugt, welche zuerst unter 'DirectoryIndex' in der httpd.conf eingetragen ist.
3. Versuch doch einfach mal für die betroffenen Verzeichnisse ensprechende Optionen festzulegen:
Code: Select all

<Directory "c:/woauchimmer/xampp/htdocs/www">

    Options Indexes FollowSymLinks MultiViews Includes ExecCGI
    AddType text/html .shtml
    AddHandler server-parsed .shtml
    AddHandler cgi-script .cgi .pl
    AllowOverride All
    Order allow,deny
    Allow from all

</Directory>

Hier als Beispiel mal das volle Programm, wie für das eigentliche DocumentRoot-Label.

Gruß
Rolidor
Rolidor
 
Posts: 406
Joined: 20. April 2004 10:17
Location: Dreieich - Hessen

Postby stephanF » 23. April 2004 04:59

das mit der Großschreibung der Endungen im ersten Posting ist nur hier passiert. Aus all meinen Maschienen ist selbstverständlich jede Endung Klein. Auf das andere werde ich erst nachher zurückkommen können, wenn ich wieder auf Arbeit bin.

gruß stephan
stephanF
 
Posts: 5
Joined: 22. April 2004 10:42


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 4 guests