Netzwerkzugriff auf Xampp/Apache 1.81

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Netzwerkzugriff auf Xampp/Apache 1.81

Postby Schmaetz » 25. March 2013 14:24

Hallo alle zusammen,

ich habe folgendes Problem:
Habe die neuste Version von Xampp (1.81) auf einem Windows Server 2008 rc2 Standard installiert und eine Webseite eingerichtet.
Wenn ich über den Server drauf zugreife lässt sich die Seite anzeigen. Allerdings nur über 127.0.0.1 bei Localhost kommt nur die Standard Seite des Apachen das alles funktioniert.

Meine Hauptproblematik liegt allerdings darin, dass wenn ich an einem anderen PC im Netzwerk(Domain organisiert) über die Ip-Adresse 192.168.1.2 auf den Server zugreife ändert sich die Adresszeile in http://127.0.0.1/index.php/Hauptseite und es kommt die Fehlermeldung Seite kann nicht angezeigt werden.
Ein normaler Zugriff auf die Daten des Server sowie ping anfrage auf die ip: 192.168.1.2 funktionieren einwandfrei.

Ich habe dies mit Chome und Firefox versucht, Hilfestellungen aus anderen Beiträgen haben mir leider nicht helfen können.
Hat alles nicht funktioniert. Achja bei der Firewall sind die Ports freigegeben, habe aber zur Sicherheit das ganze auch mit ausgeschalteter Firewall ohne ein anderes Resultat versucht.

Hoffe ihr könnt mir helfen.

Viele Grüße
Schmaetz
Schmaetz
 
Posts: 3
Joined: 25. March 2013 14:13
XAMPP Version: 5.6.3
Operating System: Windows Server 2008 RC2

Re: Netzwerkzugriff auf Xampp/Apache 1.81

Postby Schmaetz » 27. March 2013 15:38

Nochmals hallo zusammen.

Ich hab jetzt folgendes herausgefunden.
Wie oben geschrieben ändert der Browser ja die Adressleiste von der IP 192.168.1.2 auf http://127.0.0.1/index.php/Hauptseite

wenn ich jetzt allerdings in den Browser 192.168.1.2/index.php/Hauptseite eingebe erscheint die Seite. Allerdings beim öffnen weiterer Unterseiten der Homepage ändert der Browser das wieder auf 127.0.0.1... und es geht wieder nicht. Man muss also alles immer selber ändern. Kennt jemand nun einen Weg dass der Browser nicht auf 127.0.0.1 ändert.

Die Seite sieht auch ziemlich grausam auf den Netzwerk-Clienten aus, nehme an, dass liegt daran dass wegen dem Adresse austauschen nicht alle Elemente geladen werden können.

Viele Grüße
Schmaetz
Schmaetz
 
Posts: 3
Joined: 25. March 2013 14:13
XAMPP Version: 5.6.3
Operating System: Windows Server 2008 RC2

Re: Netzwerkzugriff auf Xampp/Apache 1.81

Postby Altrea » 27. March 2013 15:49

Hallo Schmatz,

deiner Schilderung nach kann es sich nur um ein Konfigurationsproblem der Anwendung handeln. Von alleine ändert Apache die URL nicht und führt auch keinen Redirect durch.

Ansatzpunkte wären also die Basis URL deiner Anwendung oder irgendwelche Redirect Anweisungen in .htaccess Dateien.

Mit freundlichen Grüßen,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6603
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

ERLEDIGT

Postby Schmaetz » 27. March 2013 15:49

Ok das Thema hat sich erledigt, hatte im Homepage Script den Fehler.

Sorry

viele Grüße
Matthias
Schmaetz
 
Posts: 3
Joined: 25. March 2013 14:13
XAMPP Version: 5.6.3
Operating System: Windows Server 2008 RC2


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 14 guests