Mod_Proxy

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Mod_Proxy

Postby Brainscanner » 20. April 2004 01:24

Hi, ich möchte meinen Apache als Proxy zu meinem System nutzen können. Zum Beispiel gebe ich .../Mail ein und werde auf das Webinterface meines Emailservers weitergeleitet wird, der unter dem Port 32000 läuft. Bei einem Freund, der Apache unter Linux betreibt, läuft das auch, aber wenn ich die nötige Zeile einfüge, läßt sich das Apache nicht starten. Windows bringt mir eine einfache Fehlermeldung.
Hier ist die Zeile, die ich benutzen wollte:
ProxyPass /Mail/ http://127.0.0.1:32000/mail

Der Rest des Konfigurationsabschnittes ist identisch mit dem von meinem Kumpel. Die Pfadangabe stimmt selbstverständlich. Weiß jemand Rat?
Brainscanner
 
Posts: 45
Joined: 07. March 2004 23:42
Location: Baden-Württemberg

Postby Wiedmann » 20. April 2004 01:46

Windows bringt mir eine einfache Fehlermeldung.

Verräts du uns auch welche?
Ich denke aber mal, dass du die Module "mod_proxy" und "mod_proxy_http" nicht aktiviert hast.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Brainscanner » 20. April 2004 09:45

Hm, ja Du hast Recht. Da hab ich noch was übersehen. Also es gibt folgende Proxymodule:
LoadModule proxy_module modules/mod_proxy.so
LoadModule proxy_connect_module modules/mod_proxy_connect.so
LoadModule proxy_http_module modules/mod_proxy_http.so
#LoadModule proxy_ftp_module modules/mod_proxy_ftp.so

Und weiter unten ist die Konfiguration so eingestellt:
<IfModule mod_proxy.so>
ProxyRequests On
ProxyPass /Emule/ http://127.0.0.1:4711/
ProxyPass /Mail/ https://127.0.0.1:32001/mail
#
#<Proxy *>
# Order deny,allow
# Deny from all
# Allow from .your-domain.com
#</Proxy>

#
# Enable/disable the handling of HTTP/1.1 "Via:" headers.
# ("Full" adds the server version; "Block" removes all outgoing Via: headers)
# Set to one of: Off | On | Full | Block
#
#ProxyVia On

#
# To enable the cache as well, edit and uncomment the following lines:
# (no cacheing without CacheRoot)
#
#CacheRoot "C:/Programme/xampp/apache/proxy"
#CacheSize 5
#CacheGcInterval 4
#CacheMaxExpire 24
#CacheLastModifiedFactor 0.1
#CacheDefaultExpire 1
#NoCache a-domain.com another-domain.edu joes.garage-sale.com

</IfModule>
# End of proxy directives.

# WEBDAV WEBDAV WEBDAV WEBDAV
# IF MOD_DAV!!!
# First load Modules (mod_dav.so + mod_dav_fs.so) ... then http://127.0.0.1:81
#
# Functions not with Frontpage but with DREAMWEAVER
<IfModule mod_dav.c>
Include conf/moddav.conf
</IfModule>

Leider funktioniert es nicht. Ich bekomme bei beiden URLs eine 404er Fehlermeldung. Wenn ich die eigentlichen Adressen dieser Dienste manuell eingebe, funktioniert es. Findest Du nen Fehler?
Brainscanner
 
Posts: 45
Joined: 07. March 2004 23:42
Location: Baden-Württemberg


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 9 guests