[gelöst] Server braucht lange um zu antworten (Portproblem?)

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

[gelöst] Server braucht lange um zu antworten (Portproblem?)

Postby corax777 » 28. February 2013 08:26

Hallo,
ich bin kein Administrationsprofi, das gleich vorweg. Also habt ein wenig Geduld mit mir ;)
Also, ich habe mir wie immer meinen kleinen lokalen Webserver aufgesetzt und eigentlich funktioniert auch alles. NUR: Jede Seite braucht höllisch lange um zu laden.
Nun warf ich einen kleinen Blick ins XAMPP Control Panel und da fiel mir folgendes auf:
Während der Browser vesucht eine Seite von meinem Webserver zu laden ändert sich ständig die Angabe unter "Apache Port(s). Es scheint so, als würde er alle möglichen Portnummern ausprobieren, um am Ende doch die 80 zu nutzen und dann lädt die Seite auch.

Ich habe in der httpd.conf NICHTS bezüglich ports geändert. Ist also im Originalzustand, bis auf die Angaben zum document root.

Sowas ist mir bisher noch nie untergekommen. Hat wer eine Idee was hier falsch läuft? Danke im Voraus.
corax777
 
Posts: 2
Joined: 28. February 2013 08:13
XAMPP Version: 5.6.3
Operating System: Windows 7 / Ubuntu

Re: Server braucht lange um zu antworten (Portproblem?)

Postby Altrea » 28. February 2013 12:17

Hallo corax777,

corax777 wrote:Sowas ist mir bisher noch nie untergekommen. Hat wer eine Idee was hier falsch läuft? Danke im Voraus.

Nichts. Das Wechseln der Ports sollte dich nicht verunsichern. Das liegt schlicht daran, dass die Routine des control panels welche den Apache Prozess überwacht nicht zwischen kommenden und gehenden Anfragen unterscheiden kann.
Dein PC sendet eine Anfrage von einem zufälligen 5-stelligen Port an den Apache Port, und dann taucht dieser Port im control panel auf.

Die Geschwindigkeit wurde schon mehrfach hier im Forum behandelt. Grund dafür ist unter anderem die IPv6 Problematik:
viewtopic.php?f=16&t=51152&p=202656&hilit=bind#p197001

Ein anderer Grund ist die Grundkonfiguration von XAMPP (vor Allem in Sachen MySQL), die auch auf langsame Rechner ausgelegt ist.

mit freundlichen Grüßen,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6671
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: Server braucht lange um zu antworten (Portproblem?)

Postby corax777 » 11. March 2013 07:10

Wurde gelöst. Hatte als Host-Parameter für den mysqli Konstruktur null angegeben und angenommen, das würde als localhost interpretiert. Wird es nicht. Habe jetzt als Host 127.0.0.1 angegeben und alles flutscht.
corax777
 
Posts: 2
Joined: 28. February 2013 08:13
XAMPP Version: 5.6.3
Operating System: Windows 7 / Ubuntu

Re: [gelöst] Server braucht lange um zu antworten (Portprobl

Postby Altrea » 11. March 2013 07:34

Vielen Dank für die Antwort.
Freut mich, dass sich das klären ließ :D
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6671
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64


Return to XAMPP für Windows

Who is online

Users browsing this forum: oldboy16 and 6 guests