Problem beim Stoppen von Apache

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Problem beim Stoppen von Apache

Postby The_Unknown » 11. February 2013 09:36

Hallo,

wenn ich den Apache auf Grund neuer virtueller Hosts (vhosts) neustarten will ("Stoppen" und wieder "Starten"), bekomme ich eine Access-Violation:
09:09:03 [main] Initialisere Control Panel
09:09:03 [main] Windows Version: Windows 7 Professional SP1 64-bit
09:09:03 [main] XAMPP Version: 1.8.1
09:09:03 [main] Control Panel Version: 3.1.0 3.1.0 [ Compiled: September 20th 2012 ]
09:09:03 [main] Dein Benutzerprofil besitzt keine Administratorenrechte! Das reicht aus für die meisten
09:09:03 [main] Anwendungsfunktionen, aber wann immer du etwas mit Windows-Diensten tun möchtest,
09:09:03 [main] wird eine Sicherheitsabfrage erscheinen oder etwas wird garnicht erst funktionieren!
09:09:03 [main] Also denke daran diese Anwendung mit Administratorrechten zu starten!
09:09:03 [main] XAMPP Installationsverzeichnis: "c:\xampp\"
09:09:03 [main] Voraussetzungen werden geprüft
09:09:08 [main] Alle Voraussetzungen sind erfüllt
09:09:08 [main] Initialisiere Module
09:09:08 [Apache] Apache Windows Dienst mit falschem Pfad gefunden
09:09:08 [Apache] Ändere die XAMPP Apache Einstellungen oder
09:09:08 [Apache] Entferne/Deaktiviere den anderen Windows Dienst vorher
09:09:08 [Apache] Pfad gefunden: ERROR: Not Able To Open Service Manager
09:09:08 [Apache] Erwarteter Pfad: "c:\xampp\apache\bin\httpd.exe" -k runservice
09:09:08 [Apache] Problem festgestellt!
09:09:08 [Apache] Port 80 in Benutzung von "httpd.exe"!
09:09:08 [Apache] Apache wird NICHT starten, wenn die konfigurierten Ports belegt sind!
09:09:08 [Apache] Die blockende Applikation muss deinstalliert/deaktiviert/rekonfiguriert werden
09:09:08 [Apache] oder konfiguriere Apache auf einen anderen Port zu lauschen
09:09:08 [Apache] Problem festgestellt!
09:09:08 [Apache] Port 443 in Benutzung von "httpd.exe"!
09:09:08 [Apache] Apache wird NICHT starten, wenn die konfigurierten Ports belegt sind!
09:09:08 [Apache] Die blockende Applikation muss deinstalliert/deaktiviert/rekonfiguriert werden
09:09:08 [Apache] oder konfiguriere Apache auf einen anderen Port zu lauschen
09:09:08 [main] Das FileZilla Modul ist deaktiviert
09:09:08 [main] Das Mercury Modul ist deaktiviert
09:09:08 [main] Das Tomcat Modul ist deaktiviert
09:09:08 [main] Starte Check-Timer
09:09:08 [main] Control Panel bereit
09:11:05 [mysql] Versuche MySQL zu starten...
09:11:07 [mysql] Statusänderung erkannt: gestartet
10:32:24 [Apache] Versuche Apache Windows Dienst zu stoppen...
10:32:28 [EXCEPTION] System Error. Code: 5.
Zugriff verweigert
10:32:28 [EXCEPTION] Access violation at address 005ABEFE in module 'xampp-control.exe'. Read of address 00000042
10:32:28 [EXCEPTION] Access violation at address 005ABEFE in module 'xampp-control.exe'. Read of address 00000042
10:32:32 [main] Deinitialisiere Module
10:32:32 [main] Deinitialisiere Control Panel


Obwohl im Log auch steht, dass der Port belegt sei, funktioniert Apache wunderbar. Für Neukonfigurationen muss ich nur leider immer den Rechner neustarten :( Habt ihr da einen Tipp für mich?

Danke im Voraus.

Ciao The_Unknown
The_Unknown
 
Posts: 1
Joined: 11. February 2013 09:24
Operating System: Windows 7 x64

Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 5 guests