MySQL startet nicht

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

MySQL startet nicht

Postby eddi » 13. April 2004 00:41

Hallo,

mag sein, dass es irgendwo schon eine Lösung gibt, aber die Suche im Forum hat nichts ergeben.
Minixampp liegt bei mir in C:\Programme\Wampp und läuft auf Win XP Pro. Wenn ich MySQL starte, wird die Eingabeaufforderung direkt wieder geschlossen und wenn ich versuche MySQL als Dienst laufen zu lassen bekomme ich die Meldung "Fehler 1067: Der Prozess wurde unerwartet beendet." Die Datei C:\my.cnf ist vorhanden, daran sollte es nicht liegen.
Ich würde MySQL gerne benutzen um Mods für phpBB erst einmal auf meinem eigenen Rechner zu testen bevor ich sie hochlade, deshalb brauche ich eine Lösung für mein Problem. Ich hoffe ihr könnt mir helfen.
eddi
 
Posts: 3
Joined: 13. April 2004 00:28

Postby DJ DHG » 13. April 2004 23:26

Moin Moin

wie sieht die my.cnf aus?
kannst du die mal posten?

mfg DJ DHG
User avatar
DJ DHG
AF Moderator
 
Posts: 2455
Joined: 27. December 2002 13:50
Location: Kiel

Postby eddi » 14. April 2004 13:45

Klar, die kann ich posten ... hier:

--start copy&paste--
# The MySQL client
[client]
#password = your_password
port = 3306
socket =C:/Programme/Wampp/mysql/mysql.sock

# Here follows entries for some specific programs

# The MySQL server
[mysqld]
port = 3306
socket = C:/Programme/Wampp/mysql/mysql.sock
skip-locking
set-variable = key_buffer=16M
set-variable = max_allowed_packet=1M
set-variable = table_cache=64
set-variable = sort_buffer=512K
set-variable = net_buffer_length=8K
set-variable = myisam_sort_buffer_size=8M
log-bin
server-id = 1

basedir=C:/Programme/Wampp/mysql
tmpdir=C:/Programme/Wampp/tmp
datadir=C:/Programme/Wampp/mysql/data

#bind-address=192.168.1.1
#log-update = /path-to-dedicated-directory/hostname

# Uncomment the following if you are using BDB tables
#set-variable = bdb_cache_size=4M
#set-variable = bdb_max_lock=10000

skip-innodb
# Uncomment the following if you are using InnoDB tables
#innodb_data_home_dir = C:/Programme/Wampp/mysql/
#innodb_data_file_path = ibdata1:10M:autoextend
#innodb_log_group_home_dir = C:/Programme/Wampp/mysql/
#innodb_log_arch_dir = C:/Programme/Wampp/mysql/
# You can set .._buffer_pool_size up to 50 - 80 %
# of RAM but beware of setting memory usage too high
#set-variable = innodb_buffer_pool_size=16M
#set-variable = innodb_additional_mem_pool_size=2M
# Set .._log_file_size to 25 % of buffer pool size
#set-variable = innodb_log_file_size=5M
#set-variable = innodb_log_buffer_size=8M
#innodb_flush_log_at_trx_commit=1
#set-variable = innodb_lock_wait_timeout=50

[mysqldump]
quick
set-variable = max_allowed_packet=16M

[mysql]
no-auto-rehash
# Remove the next comment character if you are not familiar with SQL
#safe-updates

[isamchk]
set-variable = key_buffer=20M
set-variable = sort_buffer=20M
set-variable = read_buffer=2M
set-variable = write_buffer=2M

[myisamchk]
set-variable = key_buffer=20M
set-variable = sort_buffer=20M
set-variable = read_buffer=2M
set-variable = write_buffer=2M

[mysqlhotcopy]
interactive-timeout

[WinMySQLadmin]
Server=C:/Programme/Wampp/mysql/bin/mysqld-nt.exe
--end copy&paste--

Eventuell könnte es daran liegen, dass ich die Datei "C:/Programme/Wampp/mysql/mysql.sock" nicht habe. Da bleibt dann nur die Frage wo ich die her kriege.
eddi
 
Posts: 3
Joined: 13. April 2004 00:28

Postby DJ DHG » 14. April 2004 14:42

hmm

hast du das xampp setup ausgeführt?

mach bitte eine cmd auf wechsel ins xampp verzecihniss und starte von dort mysql
und poste mal was angezeigt wird.

mfg DJ DHG
User avatar
DJ DHG
AF Moderator
 
Posts: 2455
Joined: 27. December 2002 13:50
Location: Kiel

Postby eddi » 14. April 2004 16:43

Ich hab das Setup schon ausgeführt, daran kann es wohl nicht liegen bzw. gelegen haben. Die mysql_start.bat benutzt ja auch nicht C:\my.cnf sondern die bin\my.cnf ... ich hab meine C:\my.cnf dahin kopiert und die Zeile "socket = C:/Programme/Wampp/mysql/mysql.sock" durch "socket = MySQL" wies ja auch in den anderen .cnf Beispielen steht ersetzt. Damit funktionierts, allerdings auch mit der C:/Programme... Variante. Kommt mir selbst alles etwas komisch vor, aber es läuft jetzt wenigstens.
Trotzdem Danke fürs Helfen.
eddi
 
Posts: 3
Joined: 13. April 2004 00:28

Postby kp1 » 24. April 2004 08:26

ICh habe genau das selbe Problem, mysql macht immer nach einer gewissen zeit Probleme (also Anfangs gings), aber einmal hab ich es ausversehn nicht über die shutdown datei beendet, jetzt geht es nicht mehr, kennt jemand ne Lösung
kp1
 
Posts: 3
Joined: 24. April 2004 08:22


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 15 guests