minixampp liegt auf E:\ , MySQL wird nicht gestartet W2K

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

minixampp liegt auf E:\ , MySQL wird nicht gestartet W2K

Postby Lukas Beck » 10. April 2004 23:55

Hallo,

minixampp liegt bei mir unter E:\, nun soll man aber my auf c:\ legen, dort liegt es auch, ich habe bereits den pfad in der my Datei manuell geändert, dennoch kann der Dienst unter Fehler: 1067 nicht gestartet werden, weiss nicht woran das hängt, zumindest geht alles, wenn ich es traditionell auf c: lege, was bei mir datentechnisch aber nicht mögilch ist. Wer hat hier ähnliche Erfahrungen gemacht oder kann Tipps geben?
Lukas Beck
 
Posts: 6
Joined: 10. April 2004 23:49

Postby Wiedmann » 11. April 2004 00:06

Du hast bestimm noch im Windows-Verzeichnis eine my.ini liegen?
Wenn ja, lösch die Datei "C:\my.cnf" und pass die Pfade in der "C:\WINDOWS\my.ini" an.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Lukas Beck » 11. April 2004 00:26

Vielen Dank für die schnelle Antwort,

ich habe im Win Ordner diese besagte Datei my.ini gehabt und den Pfad angepasst, leider zeigt er dennoch den gleichen Fehler an, die my ist gelöscht.

Hast Du noch eine Idee?

Gruss LUkas
Lukas Beck
 
Posts: 6
Joined: 10. April 2004 23:49

Postby Wiedmann » 11. April 2004 00:33

Hast du den MySQL-Dienst schonmal gelöscht ("mysql_uninstallservice.bat") und MySQL dann wieder neu als Dienst installiert ("mysql_installservice.bat")?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Lukas Beck » 11. April 2004 00:42

Hallo,

ja das habe ich getan, leider ohne erfolg, derzeit sieht das also wie folgt aus:

Auf E: liegt der ganze minixampp Ordner samt mysql und Co, von dort aus wurde der Dienst auch installiert, der verweist auf auf:

E:\minixampp\mysql\bin\mysqld-nt

die Datei liegt dort auch entsprechend. Die my ist gelöscht und die im Win Ordner entsprechend den Pfaden angepasst, weiterhin der oben genannte Fehler.

Gruss Lukas
Lukas Beck
 
Posts: 6
Joined: 10. April 2004 23:49

Postby Wiedmann » 11. April 2004 01:01

Mach mal eine Eingabeaufforderung auf, geh in den mysql\bin - Ordner und gib folgendes ein:
mysqld-nt.exe --console --standalone

Was gibt er dann aus?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Lukas Beck » 11. April 2004 10:26

Folgendes wird angezeigt:

040411 9:09:00 InnoDB:Started
mysqld-nt.exe: ready for connections
Version:'4.0.15-nt' socket: '' Port: 3306

[/img]
Lukas Beck
 
Posts: 6
Joined: 10. April 2004 23:49

Postby Wiedmann » 11. April 2004 15:37

Sieht ja schon mal ganz gut aus. Der SQL kann jedenfalls schonmal laufen :-)

Dann mal folgendes:
-geh in das Verzeichnis "E:\minixampp\mysql\bin" und gib ein:
"mysqld-nt --remove"
- jetzt lösche alle "my.cnf"- und "my.ini" - Dateien die du findest.
- ertselle folgende "my.ini" im Verzeichnis "%SYSTEMROOT%" (z.B: C:\WINDOWS"
Code: Select all
[mysqld]
basedir=E:\minixampp\mysql
datadir=E:\minixampp\mysql\data
port=3306
enable-named-pipe

[WinMySQLadmin]
Server=E:\minixampp\mysql\bin\mysqld-nt.exe
user=root
password=


(Das "enable-named-pipe" nur wenn du NT, W2K oder XP hast)
-geh in das Verzeichnis "E:\xampp\mysql\bin" und gib ein:
"mysqld-nt --install"
- gib ein:
"net start MySQL"

jetzt sollte er hoffentlich auch als Dienst laufen ;-)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Danke und noch etwas

Postby Lukas Beck » 11. April 2004 18:02

Ich habe es etwas umgemurkst - es funktioniert jetzt - vielen vielen Dank für deine schnelle Hilfe!

Eine Frage jedoch habe ich noch, die zwar nicht direkt ins MySQL Gebiet gehört, aber wenn ich schon mal einen Profi in Reichweite habe :D

Da ich ja jetzt einen anderen Ordner als htdocs gewählt habe, habe ich das kompfortable directory listing leider nicht mehr :-\

Leider habe ich in der Apache Konfigurationsdatei nichts entsprechendes entdecken können, was auf einen Befehl hinweist, wo ich das für den ordner einstellen kann.
Lukas Beck
 
Posts: 6
Joined: 10. April 2004 23:49

Postby Kristian Marcroft » 11. April 2004 18:13

Hi,

in der httpd.conf:

<Directory "C:/xampp/htdocs">
Options Indexes FollowSymLinks MultiViews Includes ExecCGI
AddType text/html .shtml
AddHandler server-parsed .shtml
AddHandler cgi-script .cgi
AllowOverride All
Order allow,deny
Allow from all
</Directory>


Du solltest den Pfad in <Directory "C:/xampp/htdocs"> anpassen, oder eine neue Directive erstellen die u.a. folgendes enthält:
"Options Indexes"

So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Postby Lukas Beck » 11. April 2004 18:57

Spitze - vielen Dank für die superschnelle und präzise Antwort.

Danke sehr

Gruss Lukas
Lukas Beck
 
Posts: 6
Joined: 10. April 2004 23:49


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 16 guests