Probleme mit Xampp 1.8.1 und Subversion 1.7.6

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Probleme mit Xampp 1.8.1 und Subversion 1.7.6

Postby HartlB » 20. November 2012 10:53

Hallo,
Ich wollte auf einem Windows 7 Rechner (64bit) mithilfe von Xampp 1.8.1, TortoiseSVN (64bit) und Subversion 1.7.6 die Möglichkeiten der Versionskontrolle bereitstellen und konnte dabei schon relativ leicht mit TortoiseSVN und Subversion im Verzeichnis "C:/xampp/webdav/svn" eine Projekt-Repository erstellen.

Auf diesem Rechner funktioniert Commiten und Updaten des Projekts einwandfrei, jedoch sollte nicht nur auf jenem Rechner das Projekt zur Verfügung stehn, sondern auch für andere Clients im Netzwerk, und dafür sollten die Dateien "mod_dav_svn.so" und "mod_authz_svn.so" ins Verzeichnis "C:/xampp/apache/modules" kopiert werden und die entsprechenden Einträge in der httpd.conf auskommentiert werden.


Code: Select all
...
142 LoadModule dav_module modules/mod_dav.so
143 LoadModule dav_svn_module modules/mod_dav_svn.so
144 LoadModule authz_svn_module modules/mod_authz_svn.so
145
...
513
514 <Location /svn>
515   DAV svn
516   SVNPath "C:/xampp/webdav/svn"
517   AuthType Basic
518   AuthName "Subversion repository"
519   AuthUserFile "C:/xampp/webdav/svn/conf/passwd"
520   Require valid-user
521 </Location>
...


Sind die beiden Module "dav_svn_module" und "authz_svn_module" eingetragen startet jedoch Apache nicht mehr und bringt beim Ausführen in der Konsole:

httpd.exe: Syntax error on line 143 of C:/xampp/apache/conf/httpd.conf: Cannot load module/mod_dav_svn.so into server: Die angegebene Prozedur wurde nicht gefunden.



Vielen Dank schon-mal im Voraus, ich hoffe jemand kann mir bei diesem Problemchen helfen :)
HartlB
 
Posts: 1
Joined: 19. November 2012 17:38
Operating System: Windows 7

Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 23 guests