[gelöst]mysql.sock mit XAMPP 1.8 verschwunden

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

[gelöst]mysql.sock mit XAMPP 1.8 verschwunden

Postby Bogunar » 11. September 2012 01:04

Ein Aloha in die Runde!

Ich gebe nicht gerne meinen Einstand mit einem Problem, aber bisher hatte ich keinen Grund großartig hier im Forum teilzunehmen.

Ziel: XAMPP 1.8 auf Windows 7
Grund: Einarbeitung in das Zend Framework

Ich hatte bis vor ein paar Tagen eine veraltete XAMPP-Version installiert. Die lief in puncto Apache und MySQL hervorragend. Über FileZilla Server und Co kann ich keine Aussage treffen, da ich die nicht benutzt habe. Leider ist mir entfallen, welche Version das war.
Ich habe das Zend Framework damit nicht zum laufen bekommen und dachte mir, dass es vielleicht Zeit ist mit der neuesten XAMPP-Version das auszuprobieren. Bei der Deinstallation wurden nicht alle Ordner und Dateien gelöscht, woraufhin ich manuell diese beseitigt habe. (evtl. war das ein Fehler von mir).

Die Installation von XAMPP 1.8 erfolgte ohne Probleme. Apache lässt sich einwandfrei starten. Auch MySQL kann über das ControlPanel gestartet werden. Im TaskManager tauchen der Apache und auch mysqld.exe auf. Beide Anwendungen laufen NICHT als Dienste. Sie waren auch noch nicht als Dienste aktiv.
Nach mehreren Tagen der Googlei habe ich festgestellt, dass es an dem Socket MySQL.sock liegt. MySQL erstellt einfach kein Socket. Dabei sind die Ordnerrechte auf Read, Write, Execute gesetzt. Auch für Unterordner, auch wenn dies nicht notwendig gewesen wäre.

Ich habe schon etliche Ratschläge aus dem Netz ausprobiert. Und es war wirklich viel Blödsinn dabei, wo mir schon vorab schwante, dass es nicht funktionieren kann. Deswegen wende ich mich nun an euch.

Hier noch der letzte Error-Log:
Code: Select all
120911  2:00:59 [Note] Plugin 'FEDERATED' is disabled.
120911  2:00:59 InnoDB: The InnoDB memory heap is disabled
120911  2:00:59 InnoDB: Mutexes and rw_locks use Windows interlocked functions
120911  2:00:59 InnoDB: Compressed tables use zlib 1.2.3
120911  2:00:59 InnoDB: Initializing buffer pool, size = 16.0M
120911  2:00:59 InnoDB: Completed initialization of buffer pool
120911  2:00:59 InnoDB: highest supported file format is Barracuda.
120911  2:00:59  InnoDB: Waiting for the background threads to start
120911  2:01:00 InnoDB: 1.1.8 started; log sequence number 1595675
120911  2:01:00 [Note] Recovering after a crash using mysql-bin
120911  2:01:00 [Note] Starting crash recovery...
120911  2:01:00 [Note] Crash recovery finished.
120911  2:01:00 [Note] Server hostname (bind-address): '127.0.0.1'; port: 3306
120911  2:01:00 [Note]   - '127.0.0.1' resolves to '127.0.0.1';
120911  2:01:00 [Note] Server socket created on IP: '127.0.0.1'.
120911  2:01:00 [Note] Event Scheduler: Loaded 0 events
120911  2:01:00 [Note] c:\xampp\mysql\bin\mysqld.exe: ready for connections.
Version: '5.5.25a-log'  socket: ''  port: 3306  MySQL Community Server (GPL)


Die my.ini:
Code: Select all
# Example MySQL config file for small systems.
#
# This is for a system with little memory (<= 64M) where MySQL is only used
# from time to time and it's important that the mysqld daemon
# doesn't use much resources.
#
# You can copy this file to
# C:/xampp/mysql/bin/my.cnf to set global options,
# mysql-data-dir/my.cnf to set server-specific options (in this
# installation this directory is C:/xampp/mysql/data) or
# ~/.my.cnf to set user-specific options.
#
# In this file, you can use all long options that a program supports.
# If you want to know which options a program supports, run the program
# with the "--help" option.

# The following options will be passed to all MySQL clients
[client]
#password       = ""
port            = 3306
socket          = "C:/xampp/mysql/mysql.sock"

# Here follows entries for some specific programs

# The MySQL server
[mysqld]
port= 3306
socket = "C:/xampp/mysql/mysql.sock"
basedir = "C:/xampp/mysql"
tmpdir = "C:/xampp/tmp"
datadir = "C:/xampp/mysql/data"
pid_file = "mysql.pid"
skip-external-locking
key_buffer = 16M
max_allowed_packet = 1M
table_cache = 64
sort_buffer_size = 512K
net_buffer_length = 8K
read_buffer_size = 256K
read_rnd_buffer_size = 512K
myisam_sort_buffer_size = 8M
log_error = "mysql_error.log"
 
bind-address="127.0.0.1"

# Where do all the plugins live
plugin_dir = "C:/xampp/mysql/data/lib/plugin/"

# Don't listen on a TCP/IP port at all. This can be a security enhancement,
# if all processes that need to connect to mysqld run on the same host.
# All interaction with mysqld must be made via Unix sockets or named pipes.
# Note that using this option without enabling named pipes on Windows
# (via the "enable-named-pipe" option) will render mysqld useless!
#

# commented in by lampp security
#skip-networking
#skip-federated

# Replication Master Server (default)
# binary logging is required for replication
# log-bin deactivated by default since XAMPP 1.4.11
log-bin=mysql-bin

# required unique id between 1 and 2^32 - 1
# defaults to 1 if master-host is not set
# but will not function as a master if omitted
server-id   = 1

# Replication Slave (comment out master section to use this)
#
# To configure this host as a replication slave, you can choose between
# two methods :
#
# 1) Use the CHANGE MASTER TO command (fully described in our manual) -
#    the syntax is:
#
#    CHANGE MASTER TO MASTER_HOST=<host>, MASTER_PORT=<port>,
#    MASTER_USER=<user>, MASTER_PASSWORD=<password> ;
#
#    where you replace <host>, <user>, <password> by quoted strings and
#    <port> by the master's port number (3306 by default).
#
#    Example:
#
#    CHANGE MASTER TO MASTER_HOST='125.564.12.1', MASTER_PORT=3306,
#    MASTER_USER='joe', MASTER_PASSWORD='secret';
#
# OR
#
# 2) Set the variables below. However, in case you choose this method, then
#    start replication for the first time (even unsuccessfully, for example
#    if you mistyped the password in master-password and the slave fails to
#    connect), the slave will create a master.info file, and any later
#    change in this file to the variables' values below will be ignored and
#    overridden by the content of the master.info file, unless you shutdown
#    the slave server, delete master.info and restart the slaver server.
#    For that reason, you may want to leave the lines below untouched
#    (commented) and instead use CHANGE MASTER TO (see above)
#
# required unique id between 2 and 2^32 - 1
# (and different from the master)
# defaults to 2 if master-host is set
# but will not function as a slave if omitted
#server-id       = 2
#
# The replication master for this slave - required
#master-host     =   <hostname>
#
# The username the slave will use for authentication when connecting
# to the master - required
#master-user     =   <username>
#
# The password the slave will authenticate with when connecting to
# the master - required
#master-password =   <password>
#
# The port the master is listening on.
# optional - defaults to 3306
#master-port     =  <port>
#
# binary logging - not required for slaves, but recommended
#log-bin=mysql-bin


# Point the following paths to different dedicated disks
#tmpdir = "C:/xampp/tmp"
#log-update = /path-to-dedicated-directory/hostname

# Uncomment the following if you are using BDB tables
#bdb_cache_size = 4M
#bdb_max_lock = 10000

# Comment the following if you are using InnoDB tables
#skip-innodb
innodb_data_home_dir = "C:/xampp/mysql/data"
innodb_data_file_path = ibdata1:10M:autoextend
innodb_log_group_home_dir = "C:/xampp/mysql/data"
#innodb_log_arch_dir = "C:/xampp/mysql/data"
## You can set .._buffer_pool_size up to 50 - 80 %
## of RAM but beware of setting memory usage too high
innodb_buffer_pool_size = 16M
innodb_additional_mem_pool_size = 2M
## Set .._log_file_size to 25 % of buffer pool size
innodb_log_file_size = 5M
innodb_log_buffer_size = 8M
innodb_flush_log_at_trx_commit = 1
innodb_lock_wait_timeout = 50

## UTF 8 Settings
#init-connect=\'SET NAMES utf8\'
#collation_server=utf8_unicode_ci
#character_set_server=utf8
#skip-character-set-client-handshake
#character_sets-dir="C:/xampp/mysql/share/charsets"

[mysqldump]
quick
max_allowed_packet = 16M

[mysql]
no-auto-rehash
# Remove the next comment character if you are not familiar with SQL
#safe-updates

[isamchk]
key_buffer = 20M
sort_buffer_size = 20M
read_buffer = 2M
write_buffer = 2M

[myisamchk]
key_buffer = 20M
sort_buffer_size = 20M
read_buffer = 2M
write_buffer = 2M

[mysqlhotcopy]
interactive-timeout



Betrachtet diesen Fall wie einen Autounfall in der Notaufnahme. Viel kann man nicht mehr kaputt machen. Bin also für jeden Hinweis dankbar!

Bogunar
Bogunar
 
Posts: 5
Joined: 11. September 2012 00:40
XAMPP Version: 5.6.3
Operating System: Win7

Re: mysql.sock mit XAMPP 1.8 verschwunden

Postby Altrea » 11. September 2012 05:07

Hallo Bogunar,

Erstmal ein Lob dafür, dass deine Fehlerschilderung sehr detailliert und hilfreich ist. Wären alle Schilderungen hier so ausführlich und klar, wäre Hilfestellung leisten deutlich angenehmer und erfreulicher.
Leider fehlt mir dennoch ein kleiner winziger Satz in deiner Schilderung, der aber von elemantarer Bedeutung ist:
Wie äußert sich dein Fehler? Woher weißt du, dass überhaupt einer vorliegt?

mit freundlichen Grüßen,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6471
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: mysql.sock mit XAMPP 1.8 verschwunden

Postby Bogunar » 11. September 2012 08:43

Hey!

Ich komme darauf, dass es ein Problem geben muss, weil PHPMyAdmin mit einen 2002-Fehler ausgibt beim Login. Beim XAMPP-Statuscheck unter localhost/xampp/ wird MySQL als deaktiviert angegeben.

Bogunar
Bogunar
 
Posts: 5
Joined: 11. September 2012 00:40
XAMPP Version: 5.6.3
Operating System: Win7

Re: mysql.sock mit XAMPP 1.8 verschwunden

Postby Bogunar » 11. September 2012 23:25

Möchte ja nur ungern fordern oder sonstwie dreist erscheinen. Aber ich hab das Gefühl dass mein Anliegen in den Tiefen des Forums verschwindet. :(
Bogunar
 
Posts: 5
Joined: 11. September 2012 00:40
XAMPP Version: 5.6.3
Operating System: Win7

Re: mysql.sock mit XAMPP 1.8 verschwunden

Postby Altrea » 12. September 2012 04:04

Bogunar wrote:Möchte ja nur ungern fordern oder sonstwie dreist erscheinen.

Nun, du erscheinst zumindest sehr ungeduldig.
Dies hier ist ein Support-Forum mit ausschließlich freiwilligen Helfern (so wie auch ich einer bin). Die User hier haben alle eigene Jobs, Familien, Hobbys und verbringen einen Teil ihrer Freizeit hier um Probleme anderer zu analysieren, die sie selbst nicht haben. Und wenn du dir die Beiträge der letzten Monate hier ansiehst, wirst du sogar feststellen, dass man die Helfer an weniger als einer Hand abzählen kann.

Bogunar wrote:Aber ich hab das Gefühl dass mein Anliegen in den Tiefen des Forums verschwindet. :(

Dein Beitrag war weniger als einen Tag alt und lediglich ein Beitrag hatte sich vor deinem geschoben.
Und jetzt überlege bitte nochmal, ob dein Gefühl gerechtfertigt ist.

Bogunar wrote:Ich komme darauf, dass es ein Problem geben muss, weil PHPMyAdmin mit einen 2002-Fehler ausgibt beim Login. Beim XAMPP-Statuscheck unter localhost/xampp/ wird MySQL als deaktiviert angegeben.

MySQL im XAMPP Paket wird auf Windows Systemen standardmäßig so konfiguriert, dass die Kommunikation über TCP/IP läuft. Sockets werden auf Windows Systemen garnicht unterstützt, lediglich named pipes. Daher ist es nicht verwunderlich, dass die Socket-Datei nicht existiert.

Der Fehler 2002 lässt sich in der Regel durch eine kleine Konfigurationsänderung beheben.
  • beende dein MySQL falls gestartet
  • Öffne deine \xampp\mysql\bin\my.ini
  • suche nach der Zeile #bind-address="127.0.0.1"
  • entfernen das # am Anfang dieser Zeile
  • Datei speichern
  • MySQL starten

Sollte dies nicht zum gewünschten Erfolg führen, ist zusätzlich noch eine kleine Anpassung an der Windows HOSTS Datei nötig
  • Öffne deinen bevorzugten Klartext Editor (mit erhöhren Administrator Rechten, falls deine Windows UAC aktiviert ist)
  • Benutze den Öffnen-Dialog deines Editor um die Datei C:\Windows\system32\drivers\etc\HOSTS zu öffnen (Bei Windows Notepad musst du den Dateityp auf Alle Dateien umstellen, um die Datei dort sehen zu können)
  • Setze den Eintrag 127.0.0.1 localhost, auch wenn da steht, dass dies bereits durch DNS selbst geregelt wird.
  • Datei speichern

mit freundlichen Grüßen,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6471
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: mysql.sock mit XAMPP 1.8 verschwunden

Postby Bogunar » 12. September 2012 11:36

Bogunar wrote:
Möchte ja nur ungern fordern oder sonstwie dreist erscheinen.

Nun, du erscheinst zumindest sehr ungeduldig.
Dies hier ist ein Support-Forum mit ausschließlich freiwilligen Helfern (so wie auch ich einer bin). Die User hier haben alle eigene Jobs, Familien, Hobbys und verbringen einen Teil ihrer Freizeit hier um Probleme anderer zu analysieren, die sie selbst nicht haben. Und wenn du dir die Beiträge der letzten Monate hier ansiehst, wirst du sogar feststellen, dass man die Helfer an weniger als einer Hand abzählen kann.

Bogunar wrote:
Aber ich hab das Gefühl dass mein Anliegen in den Tiefen des Forums verschwindet.

Dein Beitrag war weniger als einen Tag alt und lediglich ein Beitrag hatte sich vor deinem geschoben.
Und jetzt überlege bitte nochmal, ob dein Gefühl gerechtfertigt ist.


Berechtigt bleibt aber die Frage, ob ich jetzt schon eine Antwort hätte, wenn ich nicht nachgehakt hätte. Wie auch immer, ich bin ja dankbar für den freiwilligen Einsatz aller hier.

MySQL im XAMPP Paket wird auf Windows Systemen standardmäßig so konfiguriert, dass die Kommunikation über TCP/IP läuft. Sockets werden auf Windows Systemen garnicht unterstützt, lediglich named pipes. Daher ist es nicht verwunderlich, dass die Socket-Datei nicht existiert.

Der Fehler 2002 lässt sich in der Regel durch eine kleine Konfigurationsänderung beheben.
beende dein MySQL falls gestartet
Öffne deine \xampp\mysql\bin\my.ini
suche nach der Zeile #bind-address="127.0.0.1"
entfernen das # am Anfang dieser Zeile
Datei speichern
MySQL starten

Sollte dies nicht zum gewünschten Erfolg führen, ist zusätzlich noch eine kleine Anpassung an der Windows HOSTS Datei nötig
Öffne deinen bevorzugten Klartext Editor (mit erhöhren Administrator Rechten, falls deine Windows UAC aktiviert ist)
Benutze den Öffnen-Dialog deines Editor um die Datei C:\Windows\system32\drivers\etc\HOSTS zu öffnen (Bei Windows Notepad musst du den Dateityp auf Alle Dateien umstellen, um die Datei dort sehen zu können)
Setze den Eintrag 127.0.0.1 localhost, auch wenn da steht, dass dies bereits durch DNS selbst geregelt wird.
Datei speichern


Leider hat dies nicht zum Erfolg geführt. Über Netstat -a sehe ich zwar, dass MySQL horcht, aber PHPMyadmin und alle datenbankabhängigen Applikationen in htdocs keinen Zugang zu MySQL erhalten. Eine Überlegung von mir ist jetzt, in der php.ini was zu modifizieren. Jetzt ist nur die Frage: was?

Sorry nochmal für das Drängeln! Werde jetzt ganz geduldig sein. :)

Bogunar
Bogunar
 
Posts: 5
Joined: 11. September 2012 00:40
XAMPP Version: 5.6.3
Operating System: Win7

Re: mysql.sock mit XAMPP 1.8 verschwunden

Postby Altrea » 12. September 2012 17:27

Bogunar wrote:Berechtigt bleibt aber die Frage, ob ich jetzt schon eine Antwort hätte, wenn ich nicht nachgehakt hätte.

Berechtigt bleibt die Frage, ob ich mir beim nächsten Mal dann nicht extra viel Zeit lasse dir zu antworten ;)

Bogunar wrote:Leider hat dies nicht zum Erfolg geführt. Über Netstat -a sehe ich zwar, dass MySQL horcht, aber PHPMyadmin und alle datenbankabhängigen Applikationen in htdocs keinen Zugang zu MySQL erhalten.

Das ist schade, denn das hat bei allen anderen bisher zum Erfolg geführt.

Bogunar wrote:Eine Überlegung von mir ist jetzt, in der php.ini was zu modifizieren. Jetzt ist nur die Frage: was?

Was möchtest du dort denn ändern? PHP sehe ich da nicht als Problem.
Du könntest die phpmyadmin Konfiguration so abändern, dass explizit TCP/IP genutzt wird, indem du folgende Einträge in der config.inc.php hinzufügst:
Code: Select all
$cfg['Servers'][$i]['host']             = 'localhost';
$cfg['Servers'][$i]['connect_type']     = 'tcp';


mit freundlichen Grüßen,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6471
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: mysql.sock mit XAMPP 1.8 verschwunden

Postby Bogunar » 13. September 2012 14:19

Hey!

Das fehlende Protokoll in der Config war die Fehlerursache. *seufz* Jetzt klappt es 1A. Danke!

Du hast was gut bei mir! (das meine ich so wie ich es schreibe)

Bogunar
Bogunar
 
Posts: 5
Joined: 11. September 2012 00:40
XAMPP Version: 5.6.3
Operating System: Win7


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 7 guests