Woltlab Burning board 3.1. volcano

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Woltlab Burning board 3.1. volcano

Postby MiZi » 10. September 2012 15:50

Hallo,

ich habe unter xampp 1.7.7 die Forumssoftware Woltlab Burning board 3.1. volcano installiert.

Funktioniert soweit tadellos, im localen Netz sowieso.

Um auch von außen an mein Board zu kommen, habe ich einen Port im Router freigegeben und intern auf die IP des XAMPP-Rechners umgeleitet auch das funktioniert eigentlich gut.

Ich habe nur ein Problem:

wenn ich von extern über diese Port-Umleitung einen Beitrag absende, bekomme ich je nach Browser eine Fehlermeldung oder es passiert gar nichts mehr im aktiven Browser-Fenster.
Die Aktion wird korrekt abgeschlossen, der Beitrag ist gespeichert und ich kann jetzt manuell auch weitermachen wie gewünscht, sehe aber nicht das mein Beitrag gespeichert wurde, wenn ich den Thread nicht manuell noch einmal aufrufe.
Beim absenden wird im Normalfall der Thread neu aufgerufen und mit dem letzten Beitrag im Fenster angezeigt. Das passiert aber nur wenn ich in meinem lokalen Netzwerk mit dem Forum arbeite.

Ich habe jetzt festgestellt, das er aus irgendeinem Grund die Portnummer doppelt in die URL einbaut, und darum die Thread nicht mehr findet, hier ein Beispiel:

Nach dem Absender der Nachricht z.B. auf Seite:
http://123.123.123.123:1234/www.meinehom…D=1793#post1793
versucht der Browser anschließend diese Seite zu öffnen:
http://123.123.123.123:1234:1234/www.meinehomepage.de/Forum/index.php?page=Thread&postID=1793#post1793

Vielleicht kann mir hier jemand weiterhelfen, damit ich dieses ärgerliche Problem endlich gelöst bekomme, die Damen und Herren bei Woltlab schieben das Problem auf XAMPP.

Vielen Dank.
Grüße
MiZi
MiZi
 
Posts: 7
Joined: 13. November 2011 07:58
XAMPP Version: 1.8.3-1
Operating System: Vista 64

Re: Woltlab Burning board 3.1. volcano

Postby Altrea » 10. September 2012 16:10

Hallo MiZi,

Wir können hier leider keinerlei Support für Drittanbieterscripte bieten.
Da das Woltlab Burning Board ein kommerzielles Produkt ist, hast du bei denen auch einen Anspruch auf Support. Das Woltlab Burning Board hat eine aktive Community und ein sehr hilfsbereites Supportforum.
Ich sehe das Problem derzeit auch nicht bei XAMPP, sondern bei der Konfiguration des Boards selbst.

mit freundlichen Grüßen,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6682
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: Woltlab Burning board 3.1. volcano

Postby MiZi » 11. September 2012 05:56

Hallo,

danke, in etwa das gleiche bekomme ich dort auch zu hören.
Funktioniert, nur nicht unter xampp, nicht deren Problem.

Schade, sehr schade.

Grüße
MiZi
MiZi
 
Posts: 7
Joined: 13. November 2011 07:58
XAMPP Version: 1.8.3-1
Operating System: Vista 64

Re: Woltlab Burning board 3.1. volcano

Postby Altrea » 11. September 2012 06:53

MiZi wrote:danke, in etwa das gleiche bekomme ich dort auch zu hören.
Funktioniert, nur nicht unter xampp, nicht deren Problem.

Schade, sehr schade.

Sobald mir Woltlab eine ihrer Lizenzen zur Verfügung stellt, bin ich gerne bereit mich mit diesem Problem zu beschäftigen, vorher kann ich da rein garnichts für dich tun.
XAMPP ist ein freies Produkt und somit hat Woltlab da alle Möglichkeiten, ihr Produkt auf der Plattform zu testen, umgekehrt funktioniert das nunmal nicht.

Die XAMPP Komponenten selbst fügen nicht einfach irgendwo Ports an, außer sie werden dazu angewiesen, zum Beispiel redirects oder rewrite rules.
Solltest du solche Änderungen vorgenommen haben, solltest du das wissen.

Eine weitere Möglichkeit wäre, dass du deine Port-Umleitung nicht richtig konfiguriert ist.

mit freundlichen Grüßen,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6682
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: Woltlab Burning board 3.1. volcano

Postby MiZi » 12. September 2012 07:46

Sorry, das solltest Du nicht falsch verstehen, mir ist die Lage schon klar und auch wer eigentlich auf das Problem zu reagieren hätte.

Ich hatte nur gehofft das vielleicht hier jemand das Problem schon hatte und es gelöst hat.

Natürlich habe ich nichts umgestellt, sonst wüsste ich das in der Tat. Vielleicht mache ich es mir nur zu einfach mit der Portumleitung auf eine interne IP, vielleicht ist auch der Router das Problem, ich weiss nur nicht recht wo ich da ansetzen soll, da gibt es nicht viel zu verstellen.

Vielen Dank für die Tipps, ich werde dann mal weiter suchen.

Grüße
MiZi
MiZi
 
Posts: 7
Joined: 13. November 2011 07:58
XAMPP Version: 1.8.3-1
Operating System: Vista 64


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 9 guests