Mercury Server unter Xampp

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Mercury Server unter Xampp

Postby georg01 » 26. August 2012 20:39

Hallo Community,

ich hatte Englische Version von WinXP.
Dort habe ich mir unter XAMPP (Version 1.7.3) den Mercury Server nach die Anleitung konfiguriert.
Link:
http://system66.blogspot.de/2010/01/how-to-send-mail-from-localhost-with.html

Ich könnte Mails (aus den php- Scripten) mit Outlook auch empfangen!
NUN
Weil ich mein Deutsch auch erweitern / Verbessern möchte, habe mir jetzt eine DE Version -> thia – immer noch XP neu Installiert.
Dabei aber die neue XAMPP- Version 1.8.0 installiert.
Den Mercury Server nach der gleicher Anleitung (s.o.) konfiguriert, -> nun auf einmal – kann ich keine Mails empfangen!

Ich habe selbstverständlich viel schon gesucht, nun in der Web- Dschungel ist es sehr schwer.
Dass es an der WIN XP DE, bzw. neue XAMMP 1.8.0 Version liegt, kann ich mir kaum vorstellen.

Habe inzwischen auch aus Verzweiflung die php.ini geändert:
SMTP = localhost
Smtp_port = 25
Sendmail_from = postmaster@localhost


Bitte sehr um Rat / Hilfe.

LG
Georg
georg01
 
Posts: 6
Joined: 07. June 2012 22:23
XAMPP Version: 5.6.3
Operating System: xp pro

Re: Mercury Server unter Xampp

Postby georg01 » 28. August 2012 22:59

Hallo Community,

BITTE – Entschuldigung für mein double Posting!
Habe jedoch ne weitere Frage, und möchte deshalb dafür keinen neuen Thread offnen.


System WinXP /SP3
XAMPP 1.8.0

Damit ich auch Mails aus PHP- Scripten im Outlook (offline) empfangen kann, nutze ich (habe mir eingerichtet) den Mercury Server der im Xampp integriert ist.

Wenn ich im Mercury:
File->Send mail message …
An meine (im Outlook dafür eingerichtete Konto [root@localhost.com]) sende, kann ich die Mail auch empfangen!

Wen ich aus einem PHP- Script eine Mail an ->root@localhost.com sende, bekomme ich keine! Fehlermeldung. ( Message successfully sent!)

Nach reichlichen Recherchen im Web, wurde behauptet (Forum einträge … tuts … durch welche ich mich schon geklickt habe), dass unter WIN kein SMTP Server lauft.
Vermute ich nicht; (Xampp – Status)

PHP – Aktiviert
HTTPS (SSL) – Aktiviert
Common Gateway Interface (CGI) – Aktiviert
Server Side Includes (SSI) – Aktiviert
SMTP Server – Aktiviert


BITTE-n Fazit:
Mercury selbst sendet eine Mail (per File->Send mail message …) die auch im Outlook abrufbar ist. – Funzt 1A.
Ein PHP- Script (http://localhost/mailtest/mailform.php) sendet eine Mail an ->root@localhost.com was keine Fehlermeldung generiert, -> aber nicht im Outlook erscheint (eingekommen ist).

Hier meine Frage:
Wie kann ich den Mailversand verfolgen / debuggen?
Weil es keine Fehlermeldung gibt, und meine Administrator Kenntnisse noch schlechter wie mein Deutsch sind ….

Bitte um Rat -> Hilfe dabei.

LG.
Georg
georg01
 
Posts: 6
Joined: 07. June 2012 22:23
XAMPP Version: 5.6.3
Operating System: xp pro


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 11 guests