Apache startet nicht!

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Apache startet nicht!

Postby St0rmy » 19. August 2012 14:16

Ich habe ein Problem, mein Apache startet nicht auf dem Port 80 ...also habe ich den Port auf 8080 geändert da dieser frei ist und Apache startet immer noch nicht, also Port auf 8888 gesetzt da dieser auch frei ist und Apache starte wieder nicht.
Also habe ich mal die httpd.exe gestartet um zu gucken ob die einen Fehler ausgibt aber das consolenfenster schließt sich sofort wieder.

Kann mir einer Helfen?
St0rmy
 
Posts: 4
Joined: 19. August 2012 14:13
XAMPP Version: 5.5.19
Operating System: Windows 7

Re: Apache startet nicht!

Postby Altrea » 19. August 2012 14:25

Hallo St0rmy (für eine kurze Begrüßung sollte immer Zeit sein, vor Allem wenn man in einem Community Board um Hilfe bittet. Das ist eine Frage des Anstandes),

St0rmy wrote:Kann mir einer Helfen?

Bevor wir die Helfen können müssen wir erstmal wissen, was die Ursache dafür ist. Um dies herauszufinden hast du zwei Möglichkeiten:
  • Inhalt des \xampp\apache\logs\error.log analysieren
  • Eingabeaufforderung starten und \xampp\apache\bin\httpd.exe ausführen

mit freundlichen Grüßen,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6836
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: Windows 10 Pro x64

Re: Apache startet nicht!

Postby St0rmy » 19. August 2012 14:28

Tut mir leid..Hallo Community
in der error.log stehen nur einträge von gestern drin, weil da der Apache Server noch funktioniert hat, von heute sind keine Enträge vorhanden.

Hier ist der Inhalt der error.log
Code: Select all
[Sat Aug 18 15:19:12 2012] [notice] Digest: generating secret for digest authentication ...
[Sat Aug 18 15:19:12 2012] [notice] Digest: done
[Sat Aug 18 15:19:16 2012] [notice] Apache/2.2.21 (Win32) mod_ssl/2.2.21 OpenSSL/1.0.0e PHP/5.3.8 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Sat Aug 18 15:19:16 2012] [notice] Server built: Sep 10 2011 11:34:11
[Sat Aug 18 15:19:16 2012] [notice] Parent: Created child process 1864
[Sat Aug 18 15:19:20 2012] [notice] Digest: generating secret for digest authentication ...
[Sat Aug 18 15:19:20 2012] [notice] Digest: done
[Sat Aug 18 15:19:25 2012] [notice] Child 1864: Child process is running
[Sat Aug 18 15:19:25 2012] [notice] Child 1864: Acquired the start mutex.
[Sat Aug 18 15:19:25 2012] [notice] Child 1864: Starting 150 worker threads.
[Sat Aug 18 15:19:25 2012] [notice] Child 1864: Starting thread to listen on port 443.
[Sat Aug 18 15:19:25 2012] [notice] Child 1864: Starting thread to listen on port 443.
[Sat Aug 18 15:19:25 2012] [notice] Child 1864: Starting thread to listen on port 8888.
[Sat Aug 18 15:19:25 2012] [notice] Child 1864: Starting thread to listen on port 8888.
[Sat Aug 18 15:32:04 2012] [warn] pid file C:/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Sat Aug 18 15:32:04 2012] [notice] Digest: generating secret for digest authentication ...
[Sat Aug 18 15:32:04 2012] [notice] Digest: done
[Sat Aug 18 15:32:07 2012] [notice] Apache/2.2.21 (Win32) mod_ssl/2.2.21 OpenSSL/1.0.0e PHP/5.3.8 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Sat Aug 18 15:32:07 2012] [notice] Server built: Sep 10 2011 11:34:11
[Sat Aug 18 15:32:07 2012] [notice] Parent: Created child process 6464
[Sat Aug 18 15:32:12 2012] [notice] Digest: generating secret for digest authentication ...
[Sat Aug 18 15:32:12 2012] [notice] Digest: done
[Sat Aug 18 15:32:17 2012] [notice] Child 6464: Child process is running
[Sat Aug 18 15:32:17 2012] [notice] Child 6464: Acquired the start mutex.
[Sat Aug 18 15:32:17 2012] [notice] Child 6464: Starting 150 worker threads.
[Sat Aug 18 15:32:17 2012] [notice] Child 6464: Starting thread to listen on port 443.
[Sat Aug 18 15:32:17 2012] [notice] Child 6464: Starting thread to listen on port 8888.
[Sat Aug 18 15:32:17 2012] [notice] Child 6464: Starting thread to listen on port 443.
[Sat Aug 18 15:32:17 2012] [notice] Child 6464: Starting thread to listen on port 8888.
[Sat Aug 18 15:32:19 2012] [error] [client 5.153.97.213] File does not exist: C:/xampp/htdocs/favicon.ico
[Sat Aug 18 15:32:37 2012] [error] [client 5.73.56.192] File does not exist: C:/xampp/htdocs/favicon.ico
[Sat Aug 18 15:32:54 2012] [error] [client 5.73.56.192] File does not exist: C:/xampp/htdocs/favicon.ico
[Sat Aug 18 15:35:21 2012] [error] [client 5.73.56.192] File does not exist: C:/xampp/htdocs/favicon.ico
[Sat Aug 18 15:36:35 2012] [error] [client 5.73.56.192] File does not exist: C:/xampp/htdocs/favicon.ico
[Sat Aug 18 15:43:16 2012] [error] [client 5.73.56.192] File does not exist: C:/xampp/htdocs/favicon.ico
[Sat Aug 18 15:48:36 2012] [error] [client 5.73.56.192] File does not exist: C:/xampp/htdocs/favicon.ico
[Sat Aug 18 15:54:55 2012] [error] [client 5.73.56.192] File does not exist: C:/xampp/htdocs/favicon.ico
[Sat Aug 18 16:01:02 2012] [warn] pid file C:/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Sat Aug 18 16:01:02 2012] [notice] Digest: generating secret for digest authentication ...
[Sat Aug 18 16:01:02 2012] [notice] Digest: done
[Sat Aug 18 16:01:05 2012] [notice] Apache/2.2.21 (Win32) mod_ssl/2.2.21 OpenSSL/1.0.0e PHP/5.3.8 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Sat Aug 18 16:01:05 2012] [notice] Server built: Sep 10 2011 11:34:11
[Sat Aug 18 16:01:05 2012] [notice] Parent: Created child process 5904
[Sat Aug 18 16:01:08 2012] [notice] Digest: generating secret for digest authentication ...
[Sat Aug 18 16:01:08 2012] [notice] Digest: done
[Sat Aug 18 16:01:11 2012] [notice] Child 5904: Child process is running
[Sat Aug 18 16:01:11 2012] [notice] Child 5904: Acquired the start mutex.
[Sat Aug 18 16:01:11 2012] [notice] Child 5904: Starting 150 worker threads.
[Sat Aug 18 16:01:11 2012] [notice] Child 5904: Starting thread to listen on port 443.
[Sat Aug 18 16:01:11 2012] [notice] Child 5904: Starting thread to listen on port 8888.
[Sat Aug 18 16:01:11 2012] [notice] Child 5904: Starting thread to listen on port 443.
[Sat Aug 18 16:01:11 2012] [notice] Child 5904: Starting thread to listen on port 8888.
[Sat Aug 18 18:20:30 2012] [error] [client 5.73.56.192] File does not exist: C:/xampp/htdocs/favicon.ico
[Sat Aug 18 18:44:20 2012] [warn] pid file C:/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Sat Aug 18 18:44:20 2012] [notice] Digest: generating secret for digest authentication ...
[Sat Aug 18 18:44:20 2012] [notice] Digest: done
[Sat Aug 18 18:44:34 2012] [notice] Apache/2.2.21 (Win32) mod_ssl/2.2.21 OpenSSL/1.0.0e PHP/5.3.8 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Sat Aug 18 18:44:34 2012] [notice] Server built: Sep 10 2011 11:34:11
[Sat Aug 18 18:44:34 2012] [notice] Parent: Created child process 4904
[Sat Aug 18 18:44:37 2012] [notice] Digest: generating secret for digest authentication ...
[Sat Aug 18 18:44:37 2012] [notice] Digest: done
[Sat Aug 18 18:44:40 2012] [notice] Child 4904: Child process is running
[Sat Aug 18 18:44:40 2012] [notice] Child 4904: Acquired the start mutex.
[Sat Aug 18 18:44:40 2012] [notice] Child 4904: Starting 150 worker threads.
[Sat Aug 18 18:44:40 2012] [notice] Child 4904: Starting thread to listen on port 443.
[Sat Aug 18 18:44:40 2012] [notice] Child 4904: Starting thread to listen on port 8888.
[Sat Aug 18 18:44:40 2012] [notice] Child 4904: Starting thread to listen on port 443.
[Sat Aug 18 18:44:40 2012] [notice] Child 4904: Starting thread to listen on port 8888.


Danke schonmal im vorraus.
St0rmy
 
Posts: 4
Joined: 19. August 2012 14:13
XAMPP Version: 5.5.19
Operating System: Windows 7

Re: Apache startet nicht!

Postby Altrea » 19. August 2012 14:34

St0rmy wrote:in der error.log stehen nur einträge von gestern drin, weil da der Apache Server noch funktioniert hat, von heute sind keine Enträge vorhanden.

Dann bringt uns das nicht weiter, da hilft nur mein zweiter Vorschlag.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6836
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: Windows 10 Pro x64

Re: Apache startet nicht!

Postby St0rmy » 19. August 2012 14:37

Habe ich auch versucht, aber wie oben beschrieben, schließt sich das Fenster sofort ohne dass ich den Fehler oder was auch immer mir die console ausgibt, lesen kann.
St0rmy
 
Posts: 4
Joined: 19. August 2012 14:13
XAMPP Version: 5.5.19
Operating System: Windows 7

Re: Apache startet nicht!

Postby Altrea » 19. August 2012 14:46

Die Eingabeaufforderung schließt sich für gewöhnlich nicht, wenn du sie vorher von Hand gestartet hast.
Wenn du die httpd.exe natürlich nur mit Doppelklick startest, wird das Fenster am Ende einfach geschlossen.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6836
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: Windows 10 Pro x64

Re: Apache startet nicht!

Postby St0rmy » 19. August 2012 14:48

Die normale Console bleibt ja offen, aber für die httpd.exe öffnet sich ein neues Fenster, was sich sofort schleißt. Das einzige was ich erkennen konnte war: "Wohlmöglich...."

Edit: Das Problem habe ich bei 2 Computern.
St0rmy
 
Posts: 4
Joined: 19. August 2012 14:13
XAMPP Version: 5.5.19
Operating System: Windows 7

Re: Apache startet nicht!

Postby Altrea » 19. August 2012 14:54

St0rmy wrote:Die normale Console bleibt ja offen, aber für die httpd.exe öffnet sich ein neues Fenster, was sich sofort schleißt.

komisch, bei mir ist das anders, selbst wenn ich Apache als Windows Service registriert habe.

Dann kann ich dir leider nur den Ratschlag geben XAMPP komplett zu deinstallieren und ganz von Null zu beginnen.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6836
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: Windows 10 Pro x64


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 17 guests