Apache startet nicht mit vhosts

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Apache startet nicht mit vhosts

Postby PeterM2 » 05. August 2012 11:28

Ich verwende Version 1.7.7
Ich habe versucht vhosts einzurichten, jedoch startet dann Apache nicht mehr. In der error.log stehen nur Fehlermeldungen von gestern vom rumprobieren. Ich habe sie gelöscht und neu anlegen lassen. Dann starte ich Apache im XAMPP Control Panel v3.0.2 und Apache beendet sich sofort wieder ohne einen Eintrag im error.log zu hinterlassen.

host
Code: Select all
# localhost name resolution is handled within DNS itself.
#   127.0.0.1       localhost
#   ::1             localhost
127.0.0.1   landsurfing.localhost www.landsurfing.localhost
127.0.0.1   dummy-host.localhost www.dummy-host.localhost


httpd.conf
Code: Select all
Include "conf/extra/httpd-vhosts.conf"


httpd-vhosts.conf
Code: Select all
NameVirtualHost *:80

<VirtualHost *:80>
  DocumentRoot "D:/xampp/htdocs" # Pfad muss angepasst werden
  ServerName localhost
</VirtualHost>

<VirtualHost *:80>
    ServerAdmin webmaster@landsurfing.localhost
    DocumentRoot "D:/xampp/htdocs/landsurfing"
    ServerName landsurfing.localhost
    ServerAlias www.landsurfing.localhost
    <Directory "D:/xampp/htdocs/landsurfing">
       AllowOverride All
       Allow from All
    </Directory>
    ErrorLog "logs/landsurfing.localhost-error.log"
    CustomLog "logs/landsurfing.localhost-access.log" combined
</VirtualHost>


Der Ordner D:/xampp/htdocs/landsurfing existiert und enthält eine index.html

Wo liegt der Fehler?
PeterM2
 
Posts: 3
Joined: 01. March 2007 20:30

Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 21 guests