PHPMYAdmin

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

PHPMYAdmin

Postby hume » 24. July 2012 17:11

Hallo zusammen,

Xampp ist installiert, Apache läuft und MSQL, möchte von Xampp auf PHPMyAdmin zugreifen, aber es erscheint folgender Fehler:
"Fehler MySQL meldet: Dokumentation
Die Verbindung konnte aufgrund von ungültigen Einstellungen nicht hergestellt werden. "

Habe gelesen man muss etwas in der config.ini.php anpassen?

Hier mal die Config

Code: Select all
<?php
/*
 * This is needed for cookie based authentication to encrypt password in
 * cookie
 */
$cfg['blowfish_secret'] = 'xampp'; /* YOU SHOULD CHANGE THIS FOR A MORE SECURE COOKIE AUTH! */

/*
 * Servers configuration
 */
$i = 0;

/*
 * First server
 */
$i++;

/* Authentication type and info */
$cfg['Servers'][$i]['auth_type'] = ' localhost';
$cfg['Servers'][$i]['user'] = 'root';
$cfg['Servers'][$i]['password'] = '';
$cfg['Servers'][$i]['extension'] = 'mysql';
$cfg['Servers'][$i]['AllowNoPassword'] = true;
$cfg['Lang'] = '';

/* User for advanced features */
$cfg['Servers'][$i]['controluser'] = 'pma';
$cfg['Servers'][$i]['controlpass'] = '';

/* Advanced phpMyAdmin features */
$cfg['Servers'][$i]['pmadb'] = 'phpmyadmin';
$cfg['Servers'][$i]['bookmarktable'] = 'pma_bookmark';
$cfg['Servers'][$i]['relation'] = 'pma_relation';
$cfg['Servers'][$i]['table_info'] = 'pma_table_info';
$cfg['Servers'][$i]['table_coords'] = 'pma_table_coords';
$cfg['Servers'][$i]['pdf_pages'] = 'pma_pdf_pages';
$cfg['Servers'][$i]['column_info'] = 'pma_column_info';
$cfg['Servers'][$i]['history'] = 'pma_history';
$cfg['Servers'][$i]['designer_coords'] = 'pma_designer_coords';
$cfg['Servers'][$i]['tracking'] = 'pma_tracking';
$cfg['Servers'][$i]['userconfig'] = 'pma_userconfig';
$cfg['Servers'][$i]['recent'] = 'pma_recent';
$cfg['Servers'][$i]['table_uiprefs'] = 'pma_table_uiprefs';

/*
 * End of servers configuration
 */

?>
hume
 
Posts: 4
Joined: 23. May 2012 20:15
XAMPP Version: 1.7
Operating System: Windows 7

Re: PHPMYAdmin

Postby Altrea » 24. July 2012 17:45

Hallo Hume,

hume wrote:
Code: Select all
$cfg['Servers'][$i]['auth_type'] = ' localhost';

Das kann nicht funktionieren.
localhost ist kein gültiger Wert für eine Authentifizierungsmöglichkeit in phpMyAdmin.

mit freundlichen Grüßen,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6682
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: PHPMYAdmin

Postby hume » 24. July 2012 17:47

Auch bei config kein Ergebnis :(
hume
 
Posts: 4
Joined: 23. May 2012 20:15
XAMPP Version: 1.7
Operating System: Windows 7

Re: PHPMYAdmin

Postby Altrea » 24. July 2012 18:39

Wie wäre es mit
Code: Select all
$cfg['Servers'][$i]['auth_type'] = 'cookie';

und dann von Hand mit root und Passwort anmelden?

ggf. noch die Browser-Cookies löschen und Browser-Cache leeren.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6682
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 12 guests