Apache 1.8.0 startet nicht, bzw. nur kurz

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Apache 1.8.0 startet nicht, bzw. nur kurz

Postby RalleK » 23. July 2012 09:46

Hallo.


Ich habe vor ein paar Tagen die neue Xampp 1.8.0 installiert und seither startet Apache nicht mehr, weder über den Control Center noch über apache_start.bat.
Auch mit dem Control 3 Beta startet es nicht.
MySQL startet bei beiden ohne Probleme.

Nachdem ich das neue Programm installiert hatte funktionierte der Apache nicht mehr. Vorher war die Version 1.7.2 installiert und da war alles einwandfrei.
Auch nachdem ich dann die neue Version wieder gegen die 'Alte' ausgetauscht hatte, will er nicht mehr starten.
Es leuchtet zwar kurz die grün unterlegte Apache auf, stoppt jedoch dann sofort wieder. (Statusänderungen erkannt: gestartet, dann Statusänderungen erkannt: gestoppt)

Folgendes wird im Error-Log angezeigt:
[Mon Jul 23 10:20:19.640625 2012] [ssl:warn] [pid 472:tid 324] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Mon Jul 23 10:20:19.859375 2012] [mpm_winnt:notice] [pid 472:tid 324] AH00455: Apache/2.4.2 (Win32) OpenSSL/1.0.1c PHP/5.4.4 configured -- resuming normal operations
[Mon Jul 23 10:20:19.859375 2012] [mpm_winnt:notice] [pid 472:tid 324] AH00456: Server built: May 13 2012 14:10:15
[Mon Jul 23 10:20:19.859375 2012] [core:notice] [pid 472:tid 324] AH00094: Command line: 'C:\\Xampp\\apache\\bin\\httpd.exe -d C:/Xampp/apache'
[Mon Jul 23 10:20:19.859375 2012] [mpm_winnt:notice] [pid 472:tid 324] AH00418: Parent: Created child process 3448
[Mon Jul 23 10:20:20.796875 2012] [ssl:warn] [pid 3448:tid 1828] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Mon Jul 23 10:20:20.890625 2012] [mpm_winnt:crit] [pid 3448:tid 1828] (OS 10022)Ein ungültiges Argument wurde angegeben. : AH00405: Child: WSASocket failed to open the inherited socket
[Mon Jul 23 10:20:20.890625 2012] [mpm_winnt:crit] [pid 472:tid 324] AH00427: Parent: child process exited with status 3 -- Aborting.

Ich habe dann die Version zum 'selbst installieren' und die 'ZIP-Variante' (die man dann über 'apache_installservice.bat') einbindet ausprobiert - beides brachte nichts.
Außer der Fehlermeldung: Apache2.4 wird gestartet - Apache2.4 konnte nicht gestartet werden. Der Dienst hat keinen Fehler gemeldet. Sie erhalten weitere Hilfe, wenn sie NET HELPMSG 3534 eingeben (wenn ich das in die DOS-Box eingebe dann kommt auch nur: 'Der Dienst hat keinen Fehler gemeldet))

Ich habe schon viele Postings über das Problem (Apache startet nicht) durchgelesen, jedoch bezogen sich meisten auf Skype, bzw. die Belegung der Ports.

Mein Betriebssystem: Windows XP inkl. aller aktuellen Patches
Kein Skype installiert.
Installation unter: C:\Xampp\apache

Auch die empfohlene Winsock Reparatur (mit WinsockxpFix.exe) habe ich schon mehrfach drüber laufen lassen.
Ebenso das empfohlene 'Microsoft Visual C++ 2008 SP1 Redistributable Package (x86) Runtime' (Datei vcredist_x86.exe) wurde bereits nochmals installiert (wobei ich davon ausgehe dass es schon vorher drauf war, da Apache ja bis dahin funktioniert hat).

Es ist keine Firewall, außer die Windows eigene vorhanden und der Virenscanner ist von Avira.
Auch das Abschalten beider brachte keinen Erfolg.

Lt. Portcheck von XAMPP sind beide Ports (80 und 443) frei und werden von keinem Programm belegt. Auch das ändern der Ports in der 'httpd.conf' auf bsp. 8080 brachte nichts.

Ich weiss nun leider nicht mehr weiter, bzw. habe keine weiteren Möglichkeiten gefunden (auch auf der Seite: 'WICHTIG: XAMPP 1.8.0 & 1.7.7 Probleme und Lösungen') war leider nichts dabei, was mir weitergeholfen hat.

Vielleicht weiss jemand von euch Profis noch einen Rat, was ich sonst noch unternehmen kann.

Ich wäre über jeden weiteren Vorschlag dankbar, da ich schon seit Tagen dranhocke und das 'Ding' einfach nicht läuft.

Viele Grüße

Ralf


27. Juli 2012, 07:11
Weiss denn wirklich niemand einen Weg oder hat einen Rat was ich noch versuchen könnte????
RalleK
 
Posts: 1
Joined: 23. July 2012 09:06
XAMPP Version: 5.6.3
Operating System: Windows XP

Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 2 guests