[gelöst]Zend Guard Loader

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

[gelöst]Zend Guard Loader

Postby sto-kla » 15. July 2012 07:35

Hallo zusammen,
ich bin neu hier und hoffe, dass meine Frage verständlich rüberkommt.
Ich habe xampp 1.7.7 (PHP 5.3.8 ) auf Windows 7 64bit und möchte den Zend Loader zum laufen bekommen.
In der php.ini habe ich folgende Einträge ab Zeile 1927 erstellt:
zend_extension = "C:\...........\xampp\php\ioncube\ioncube_loader_win_5.3.dll"
zend_extension = "C:\...........\xampp\php\zend\ZendLoader.dll"
zend_loader.enable = On

Der ionCube läuft und wird auch mit PHPinfo angezeigt.
Beim Start des Apache kommt ein Fehler, dass php5.dll auf dem PC fehlt.

Wie kann ich den Loader zum laufen bekommen?

Danke im Voraus!
sto-kla
 
Posts: 2
Joined: 15. July 2012 07:24
XAMPP Version: 5.5.19
Operating System: Windows 7 64

Re: Zend Guard Loader

Postby Altrea » 15. July 2012 08:50

Hallo sto-kla,

Zend Loader erfordert seit PHP 5.3 die PHP non thread safe (nts) version. XAMPP wird aber mit der PHP thread safe (ts) version ausgeliefert.
Es gibt derzeit also keine Chance den Zend Loader mit XAMPP zum Laufen zu bewegen außer PHP komplett auszutauschen.

Möchtest du Zend Module verwenden, kann ich nur zum Zend Server (CE) raten.

mit freundlichen Grüßen,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6488
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: Zend Guard Loader

Postby sto-kla » 15. July 2012 08:56

Danke für die schnelle Antwort.
sto-kla
 
Posts: 2
Joined: 15. July 2012 07:24
XAMPP Version: 5.5.19
Operating System: Windows 7 64

Re: [gelöst]Zend Guard Loader

Postby raigi » 25. January 2014 17:25

Hallo Zusammen,

gibt es in der Zwischenzeit eine Lösung für das Problem? Kann der thread safe geändert werden?
Und PHP komplett austauschen heisst eine ältere Version - Oder?

Bin über jede Antwort froh.

Bis bald
raigi
 
Posts: 2
Joined: 25. January 2014 16:48
XAMPP Version: 1.8.3
Operating System: Win 7

Re: [gelöst]Zend Guard Loader

Postby Altrea » 25. January 2014 18:31

Hallo raigi

raigi wrote:gibt es in der Zwischenzeit eine Lösung für das Problem?

Nein.

raigi wrote:Kann der thread safe geändert werden?

Nein, das ist ein Compiler-Flag das steuert, wie sich das Kompilat verhält.
Man hat also nach dem Kompiliervorgang keine Möglichkeit mehr dies zu ändern.

raigi wrote:Und PHP komplett austauschen heisst eine ältere Version - Oder?

Eine ältere XAMPP Version verwenden ist der einzig unterstützte Weg.
Du kannst natürlich auch eine andere PHP Version über CGI oder FCGI einbinden, wie zum Beispiel hier letztens beschrieben:
viewtopic.php?f=4&t=67753&p=232615&hilit=htaccess#p232615

mit freundlichen Grüßen,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6488
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: [gelöst]Zend Guard Loader

Postby raigi » 30. January 2014 20:01

Hallo Altera,

Danke für die schnellen Antworten. Leider bin ich anscheinend bin ich für das einbinden der zweiten php Version zu doof.
Ich habe alles nach Anelitung erledigt, aber ohne Erfolg. Apache startet zwar ohne murren aber weiter keine Änderung.
Welche ältere Xampp Version wäre die richtige?

Vielen Dank
Rainer
raigi
 
Posts: 2
Joined: 25. January 2014 16:48
XAMPP Version: 1.8.3
Operating System: Win 7


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 14 guests