Port 80 - Problem!

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Port 80 - Problem!

Postby illumination » 21. June 2012 19:18

...Und keine Lösung in Sicht. Der Apache Service von XAMPP startet auf meinem Win7-Rechner nicht.
Zumindest beim ersten Anlauf taucht noch das Port 80 in Klammern hinter dem Startprozess auf.

Mit portcheck.org hatte ich gehofft heraus zu finden, ob und wieso das Port besetzt.
Allerdings kriegt man hier nur die Meldung, dass es eben belegt ist.

Skype hab ich jedenfalls nicht oder nicht mehr auf dem Rechner.
Mit anderen Diagnose-Tools und lebenserhaltenden Maßnahmen für Apache kenne ich mich nicht aus.
Und leider bin ich aus diversen anderen Beiträgen auch nicht schlauer geworden.

Unterstützung, Lösungsvorschläge wären fantastisch, denn ich brauche dringend XAMPP, um Magento zu testen,
und unter Wamp bereitet das einige Probleme.
illumination
 
Posts: 5
Joined: 21. June 2012 19:04
XAMPP Version: 5.6.3
Operating System: Windows 7

Re: Port 80 - Problem!

Postby WilliL » 21. June 2012 21:51

beim XAMPP Control Panel v3.0.11 ist "netstat" integriert, dass dir den Übeltäter anzeigt-
(xampp-control-3-beta.exe) im xampp verzeichnis
Willi
WilliL
 
Posts: 619
Joined: 08. January 2010 10:54
XAMPP Version: 5.5.19
Operating System: Win7Home Prem 64 SP1

Re: Port 80 - Problem!

Postby illumination » 23. July 2012 20:28

Sorry, für die späte Rückmeldung.
Netsat sagt das 80er Port werde von httpd.exe belegt...
Und was mache ich jetzt? oO
illumination
 
Posts: 5
Joined: 21. June 2012 19:04
XAMPP Version: 5.6.3
Operating System: Windows 7

Port 80 - Problem!

Postby echtkpvl » 23. July 2012 21:54

Nutzt du skype?
Skype baut eine p2p verbindung über port 80 auf.
Beende Skype (am besten über den taskmgr) starte xampp.
Und dann kanst du skype wieder starten.
Denn wen xampp gestartet ist(und damit port 80 zu ist) sucht skype sich einen andern port (kanst du in skye enstellungen > verbindungen einstellen).

Ich hoffe ich kann dir damit helfen.

LG
echtkpvl
 
Posts: 9
Joined: 23. July 2012 09:14
XAMPP Version: 5.6.3
Operating System: Windows 7

Port 80 - Problem!

Postby echtkpvl » 23. July 2012 21:55

Ups. Da hab ich zu schnell überflogen.
Sorry
echtkpvl
 
Posts: 9
Joined: 23. July 2012 09:14
XAMPP Version: 5.6.3
Operating System: Windows 7

Re: Port 80 - Problem!

Postby Altrea » 24. July 2012 05:24

Hallo illumination,

Ich zitiere mal, was du in deinem anderen Thread geschrieben hast, denn das enthält deutlich mehr Informationen als hier im Thread:
illumination wrote:Zuerst sprang aber der Apache-Server nicht an - wegen dem belegten Port 80. Dafür fand ich schon einmal keine Lösung, weil ich nicht herausbekam, welcher Dienst diesen Port verwendet.
Aber das Control Panel meldet immerhin noch, dass das genannte Port belegt ist. Das war bei Version 1.7.7 der Fall.

Nun habe ich es noch einmal mit Version 1.8.0 probiert und wieder startete Apache nicht. Der Server gibt nach einem Klick auf "Starten" keine Reaktion von sich und Über das Control Panel erhält man keine Fehlermeldung. Laut Netstat belegt httpd.exe Port 80. Damit kann ich jedoch nichts anfangen. Die Adresse lautet 0.0.0.0, die PID 1764. (Ich bin kein Programmierer, Webmaster usw.)

Wenn ich allerding im Anschluss einen Neustart des PCs mache und den Apache-Dienst aktiviert lasse, steht der Server mit dem Hochfahren zur Verfügung. Nach einem Stoppen kann man ihn jedoch nicht einfach wieder starten, sondern muss den Rechner neustarten, damit der Apache-Dienst beim Hochfahren wieder lädt. Dabei ist allerdings kein Autostart eingestellt.

Läuft Apache, kann ich unter "localhost.de" die Xampp Startseite besuchen


Nun ein Versuch der Fehlerbehebung:
  • Wenn du dein XAMPP control Panel startest, tust du dies auch mit erhöhten Administrationsrechten (Rechtsklick => als Administrator ausführen)? Falls nicht hat das CP keine Berechtigung irgendwelche Windows Dienste zu starten oder zu stoppen.
  • Ich würde die Dienste komplett entfernen, solange dein XAMPP nochnicht sauber läuft. Dienste können Fehler hervorrufen, die man ohne sie nicht gehabt hätte und lassen sich dann meist nur umständlich über über die Windows Ereignisanzeige analysieren
  • httpd.exe ist der Prozess den Apache immer verwendet. HTTP steht dabei für Hypertext Transfer Protocol, das Standardübertragungsprotokoll für Webseiten. Das D am Ende steht für Daemon, was soviel heißt wie Hintergrundprogramm, also das Programm, das mit dem HTTP irgendetwas tut. Es liegt aber nur in deinem Kenntnisstand, ob der httpd.exe Prozess der da läuft auch der ist der laufen sollte. Solltest du mehrere Apache installiert haben (egal ob es eine reine Apache Einzelkomponente oder ein Stack wie WampServer oder XAMPP ist), könnte es jeder davon sein. Das XAMPP Control Panel hat zudem keine einfache Möglichkeit zu erkennen, ob es der eigene Apache Prozess ist der da läuft. Daher meine Empfehlung: Deinstalliere alle anderen Apache Installationen oder Stacks, die einen Apache enthalten (auch doppelte XAMPP Installationen). Und auch hier: deinstalliere den Windows Service, denn dieser verweist immer nur auf einen bestimmten Pfad, und damit u.U. auf eine veraltete Apache installation
  • An Hand der PID kannst du im Windows Task Manager im Reiter Prozesse genau den Prozess ausfindig machen. Dazu müsstest du aber zu allererst die PID Spalte mit einblenden. Das bringt dir aber nur dann einen Mehrwert, wenn du den Prozess abschießen möchtest um den Port wieder freizubekommen.

mit freundlichen Grüßen,
Altrea

P.S.: Bitte versuche in Zukunft dich an die Regel "ein Thread pro Problem und User" zu halten und mische deine Probleme nicht in Threads mit ein, wo sie nichts zu suchen haben (besonders nicht, wenn es sich um das völlig falsche Forum handelt (Ein Apache Problem hat nichts im phpmyadmin thread zu suchen).
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6471
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: Port 80 - Problem!

Postby illumination » 24. July 2012 11:11

Hallo Altrea, im phpmyadmin-Thread habe ich diesen Beitrag eröffnet, weil es sich um eine Fehlermeldung innerhalb des phpmyadmin-Bereichs handelt und der XAMPP-Server ansich inzwischen läuft - wenn auch nur irgendwie - und es in Bezug auf das Port gar keine Meldung mehr gibt(?) Es sind jedoch keine weiteren Apache-Dienste installiert, zumindest weiß ich von keinem weiteren. Auch die vorangegangene XAMPP 1.7.7 Installation wurde zuvor restlos entfernt, der WampServer sowieso. Gibt es da noch typische Kandidaten außer vielleicht Skype? Die Dienste von XAMPP steuere ich eigentlich nur über die Häkchen-Aktivierung. (In der Hoffnung sie richtig verstanden zu haben.) :-/
illumination
 
Posts: 5
Joined: 21. June 2012 19:04
XAMPP Version: 5.6.3
Operating System: Windows 7

Re: Port 80 - Problem!

Postby Altrea » 24. July 2012 11:53

illumination wrote:Hallo Altrea, im phpmyadmin-Thread habe ich diesen Beitrag eröffnet, weil es sich um eine Fehlermeldung innerhalb des phpmyadmin-Bereichs handelt und der XAMPP-Server ansich inzwischen läuft

Es gibt keinen "XAMPP-Server".
XAMPP ist lediglich ein Stack aus bekannten Webserver Einzelkomponenten.
Wenn du also sagst, dass XAMPP an sich läuft, meinst du damit vermutlich Apache und/oder MySQL als Einzelkomponente.
Dennoch gehört auch phpMyAdmin zum XAMPP Paket und alles was mit dem XAMPP Paket zu tun hat (vorallem, wenn es sich im Funktionsstörungen handelt) sollte im jeweiligen XAMPP Forum beschrieben werden (in diesem Fall im XAMPP für Windows Forum).

illumination wrote:Es sind jedoch keine weiteren Apache-Dienste installiert, zumindest weiß ich von keinem weiteren.
[...]
Die Dienste von XAMPP steuere ich eigentlich nur über die Häkchen-Aktivierung. (In der Hoffnung sie richtig verstanden zu haben.) :-/

Wie ich schon empfohlen habe würde ich einfach jedliche Dienste von XAMPP Komponenten entfernen, also jedliche Apache, MySQL, etc Dienste.
Das bedeutet jedliche Häkchen links von den Einzelkomponenten im Control Panel entfernen.
Starten kannst du die Einzelkomponenten ja weiterhin über die Start-Buttons im XAMPP Control Panel.

illumination wrote:Gibt es da noch typische Kandidaten außer vielleicht Skype?

Sehr viele. Wir haben hier mal versucht eine kleine Liste zu machen: viewtopic.php?f=4&t=3807
Aber herumraten bringt garnichts. Ohne expliziten Hinweis im Apache error.log würde ich garnichts in der Richtung suchen.

mit freundlichen Grüßen,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6471
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: Port 80 - Problem!

Postby crontroller » 02. August 2012 17:40

wenn das problem immer noch dar ist gib doch anderen port an wenn port 80 nicht geht muss nur gültiger port sein und passen zum routerport windos port usw
viel spass
crontroller
 
Posts: 10
Joined: 01. August 2012 17:06
Location: NRW
XAMPP Version: 1.8.3-2
Operating System: Windos 7 32 bit


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 17 guests