Probleme mit alias und php Session

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Probleme mit alias und php Session

Postby hbergmann » 30. March 2012 09:31

Hallo,

ich habe erfolgreich xampp im Ordner 'C:\xampp\' entpackt und zum Laufen bekommen.
Ein größeres Projekt entwickele ich im Ordner 'D:\Projekt\Entwicklung'. Also habe ich folgenden Eintrag in ide http-conf eingebunden:

Code: Select all
<IfModule alias_module>

    Alias /Projekt "D:/Projekt/Entwicklung/"
    <Directory "D:/Projekt/Entwicklung/">
        Options Indexes Multiviews
        AllowOverride All
        Order allow,deny
        Allow from all
   </Directory>

</IfModule>


So weit so gut, über 'localhost/Projekt' kann ich im Browser auf den Ordner zugreifen. Error_Reporting habe ich übrigens in der php.ini so gesetzt:

Code: Select all
error_reporting = E_ALL | E_STRICT & ~E_DEPRECATED & ~E_NOTICE


Mein project arbeitet mit Sessions und jetzt erhalte ich folgende Fehlermeldung:

Code: Select all
<b>Warning</b>:  session_start() [<a href='function.session-start'>function.session-start</a>]: open(\xampp\tmp\sess_hdp0uis49dinnecns3b00d5dg2, O_RDWR) failed: No such file or directory (2) in <b>D:\Projekt\Entwicklung\includes\sys\initialize.inc.php</b> on line <b>


Ich habe das überprüft und finde die Session-Datei in 'xampp/tmp/' ohne Probleme.

Woran liegt das und wie muss ich vorgehen, um das Problem zu lösen?

Danke schon mal im Voraus!

Liebe Grüße

hbergmann
hbergmann
 
Posts: 4
Joined: 30. March 2012 09:17
XAMPP Version: 5.6.3
Operating System: Windows 7 64Bit

Re: Probleme mit alias und php Session

Postby hbergmann » 30. March 2012 14:12

Hallo,

habe jetzt erstmal mit der php-Anweisung session_save_path den Pfad zu 'C:\xampp\tmp\' manuell gesetzt, sodass es funktioniert. Mich würde dennoch interessieren, ob es grundsätzlich auch ohne diesen Workaround geht, indem Apache entsprechend richtig konfiguriert wird.

LG hbergmann
hbergmann
 
Posts: 4
Joined: 30. March 2012 09:17
XAMPP Version: 5.6.3
Operating System: Windows 7 64Bit

Re: Probleme mit alias und php Session

Postby WilliL » 30. March 2012 18:17

ich würde das über vhosts machen..

bitte auch die Kommentare lesen :wink:


Datei: C:/xampp177/apache/conf/extra/ httpd-vhosts.conf
Code: Select all
# Please see the documentation at
# <URL:http://httpd.apache.org/docs/2.2/vhosts/>
# for further details before you try to setup virtual hosts.
#
# You may use the command line option '-S' to verify your virtual host
# configuration.

# bei Problemen überprüfen:
# "DNS-Client" gestartet? (Windows Dienste)
#
# Use name-based virtual hosting.
#
# http://www.camma.ch/2010/04/17/xampp-mit-virtualhost/

NameVirtualHost 127.0.0.1:80

#
# c:\windows\system32\drivers\etc\HOSTS bei neuen VHOSTS anpassen
# ServerName UND ServerAlias

#
# The first VirtualHost section is used for all requests that do not
# match a ServerName or ServerAlias in any <VirtualHost> block.
#
# Daten aus httpd.conf, die diese Datei aufruft
#

# localhost
<VirtualHost 127.0.0.1:80>
    ServerAdmin postmaster@localhost
    DocumentRoot "C:/xampp177/htdocs"
    ServerName localhost
    ##ServerAlias www.dummy-host.localhost
    ErrorLog "logs/error-localhost.log"
    LogLevel warn
    CustomLog "logs/localhost-access.log" combined
    <Directory "C:/xampp177/htdocs">
        Options Indexes FollowSymLinks Includes ExecCGI
        Order allow,deny
        Allow from all
        AllowOverride All
        DirectoryIndex index.php index.shtml index.html index.htm
    </Directory>
</VirtualHost>

# no new_one - zum Testen
<VirtualHost 127.0.0.1:80>
    ServerAdmin webadmin@no.de
    DocumentRoot "D:/www/new_one"
    ServerName no
    ServerAlias new_one
    ##ServerAlias www.dummy-host.localhost
    ErrorLog "logs/error-new_one.log"
    LogLevel warn
    CustomLog "logs/new_one-access.log" combined
    <Directory "D:/www/new_one">
   Options Indexes FollowSymLinks Includes ExecCGI
        Order allow,deny
        Allow from all
        AllowOverride All
        DirectoryIndex index.php index.shtml index.html index.htm home.php
    </Directory>
</VirtualHost>


hier kannst du dann deine Projekseite (in diesem Beispiel" mit "no" oder "new_one" im browser aufrufen
statt 127.0.0.1 kannst du auch ein * einsetzen.

http://httpd.apache.org/docs/2.2/de/vhosts/ solltest du dir in jedem Fall durchlesen
Willi
WilliL
 
Posts: 628
Joined: 08. January 2010 10:54
XAMPP Version: 5.5.19
Operating System: Win7Home Prem 64 SP1

Re: Probleme mit alias und php Session

Postby hbergmann » 04. April 2012 09:01

Hallo,

danke für die Antwort, aber ich hatte schon immer Schwierigkeiten, vhosts auf einer Windows-Maschine vernünftig zum Laufen zu bekommen. Muss dazu sagen, dass ich mich zwar mit php und mysql-Programmierung auskenne, aber Server-Konfiguration war immer schon ne ziemliche Fummelei bei mir.

Habe jetzt also folgendes Problem, dass ich bei der Eingabe von 'no' oder 'new_one' im Browser immer auf Google-Ergebnisse zu 'no' oder 'new_one' geleitet werde. Irgendwie kapiert Windows nicht, dass es zuerst beim Apache-Server nachschauen soll. Bei der Eingabe von 'localhost' schaut es ja auch nicht bei Google nach, sondern öffnet gleich die xampp-Startseite.

Was habe ich übersehen?

LG

hbergmann
hbergmann
 
Posts: 4
Joined: 30. March 2012 09:17
XAMPP Version: 5.6.3
Operating System: Windows 7 64Bit

Re: Probleme mit alias und php Session

Postby hbergmann » 04. April 2012 09:33

So, habe jetzt die Datei 'Windows/System32/drivers/etc/hosts' so angepasst, dass 'no' und 'new_one' auch an 127.0.0.1 gebunden werden (warum das bei localhost funktionierte, obwohl das in dieser Datei auskommentiert war, ist mir weiterhin schleierhaft...).

Problematisch war es, dass ich die Datei nur als Administrator bearbeiten konnte, aber natürlich unter einem eingeschränkten Benutzerkonto entwickele. Habe ich dann aber auch lösen können.

Jetzt funktioniert's.

Danke für die Hilfe.

Gruß

hbergmann
hbergmann
 
Posts: 4
Joined: 30. March 2012 09:17
XAMPP Version: 5.6.3
Operating System: Windows 7 64Bit

Re: Probleme mit alias und php Session

Postby Altrea » 04. April 2012 12:59

hbergmann wrote:warum das bei localhost funktionierte, obwohl das in dieser Datei auskommentiert war, ist mir weiterhin schleierhaft...


Das steht doch als Kommentar in der Datei mit bei:
# localhost name resolution is handled within DNS itself.

Heißt soviel wie, dass localhost schon fest als Standardroute in der Namensauflösung einprogrammiert wurde (und zwar für IPv4 und IPv6, was bei Webservern gerne mal zu Problemen führt)

mit freundlichen Grüßen,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6946
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: Windows 10 Pro x64


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 9 guests