PHP wird nicht angezeigt

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

PHP wird nicht angezeigt

Postby Pocoyo » 29. March 2012 22:21

Hallo,

ich habe mich heute hier im Forum angemeldet, da ich bei meinem Fehler nicht mehr weiterkomme.

Ich habe folgenden Fehler: Ich habe html-Seiten und php-Seiten erstellt, die lokal auf einem Laptop sozusagen als Benutzeroberfläche laufen. Die html-Seiten laufen selbstverständlich problemlos, da sie ja keinen Server benötigen. Um Ordnerinhalte (Word-Dokumente, PDF-Dokumente, Bilder,...) übersichtlich darzustellen, werden sie mittels eines php-Scriptes gelesen und in einer Tabelle als Links ausgegeben. Auf meinem Entwicklungs-System mit xampp 1.7.4 auf Win 7 wird das php-Script richtig ausgeführt und die Seiten richtig ausgegeben. Nun habe ich das ganze Projekt auf den Laptop geladen. Dort läuft jetzt xampp 1.7.7 auf Win XP SP3, Apache ist als Dienst installiert.
Wenn man nun die php-Seiten aufruft, werden sie nicht angezeigt, sondern es kommt die Sicherheitsabfrage (Datei Öffnen - Speichern - Abbrechen) und der Browser (Internet Explorer 7) will die Datei speichern. Klickt man auf öffnen, kommt die Sicherheitsabfrage wieder.
Ich habe die Seiten auf einen Webserver geladen, von dort werden sie richtig gelesen und dargestellt.

Meine Lösungsansätze: Mit Hilfe des Control Panel und der Windows Services kontrolliert, ob Apache läuft - alles ok.
1. System aktualisiert auf XP Service Pack 3 und alle weiteren Updates
2. Internet Explorer 6 aktualisiert auf Internet Explorer 7
3. xampp 1.7.3 aktualisiert auf xampp 1.7.7 (Apache als Dienst de- und dann wieder installiert)
Trotzdem keine Anzeige der php-Seiten, auch der Aufruf von localhost/xampp wird nicht ausgeführt. Konfigurationsdateien wurden seit der Aktualisierung von xampp und meines Wissens davor nicht verändert.

Nu hat sich noch etwas weiteres ergeben: Wenn ich nun nach der xampp Aktualisierung aus dem Control Panel neben Apache auf Admin klicke, kommt die Meldung im Browser: Zugriff verweigert. Was ist das nun wieder?
Anscheinend ist wohl richtig was verbogen, ob in xampp oder im Windows, ich weiß nicht mehr weiter.
Vielleicht hat jemand eine Idee?
Mein nächster Versuch ist dann, dass Windows komplett neu aufzusetzen und auch xampp wieder komplett neu zu installieren. Daran ist dann das Problem, dass es sich um einen Laptop aus einer öffentlichen Verwaltung handelt, was das neu aufsetzen nicht gerade erleichtert, da es so weit aufwändiger ist.

Abschließend möchte ich mich für das Lesen bis zum Ende bedanken.
Gruß Martin
Pocoyo
 
Posts: 1
Joined: 29. March 2012 21:18
XAMPP Version: 5.6.3
Operating System: Windows XP SP3

Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 10 guests