Frage zu VirtuellemHost

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Frage zu VirtuellemHost

Postby HuBi.ch » 27. March 2004 14:05

Hi Leute,
ich hab mir in der conf - Datei vom Apache 2 virtuelle Hosts eingerichtet

xampp.localhost und
hubi.localhost

der Aufruf der beiden Sachen klappt, ich vermute jedoch nur weil ichs in die hosts - Datei eingetragen habe! egal ob ich xampp.localhost oder hubi.localhost öffne, es kommt immer die Stadardpage von Xampp!?

Hier mal die letzten Zeilen der conf - Datei

<VirtualHost *>
ServerAdmin webmaster@localhost.xampp
DocumentRoot E:/Internet/minixampp/htdocs/
ServerName localhost.xampp
ErrorLog logs/dummy-host.example.com-error_log
CustomLog logs/dummy-host.example.com-access_log common
</VirtualHost>

<VirtualHost *>
ServerAdmin webmaster@localhost.hubi
DocumentRoot E:/Internet/minixampp/htdocs/hubi/
ServerName localhost.hubi
ErrorLog logs/dummy-host.example.com-error_log
CustomLog logs/dummy-host.example.com-access_log common
</VirtualHost>

Kann mir wer von euch sagen was ich falsch mach eund was ich ändern muss/soll!? :)

thx für Hilfe!
HuBi.ch
 
Posts: 7
Joined: 26. March 2004 14:45

Postby Wiedmann » 27. March 2004 14:34

Naja,
beide Vhosts reagieren auf den selben Namen:
<VirtualHost *>
Beim "*" also auf alles. Da nimmer er halt den ersten passenden...

Siehe:
Syntax der Directive VirtualHost
Apache-Dokumentation zu virtuellen Hosts
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 12 guests