php_openssl.dll funktioniert seit XAMPP 1.7.4 nicht mehr

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

php_openssl.dll funktioniert seit XAMPP 1.7.4 nicht mehr

Postby DerAnalyst » 16. March 2012 21:50

Hallo,

seit XAMPP 1.7.4 muss in PHP die OpenSSL-Funktionalität mit der Extension php_openssl.dll aktiviert werden. Leider stürzt der Apache ab sobald eine OpenSSL Funktion aufgerufen wird. Wie kann dieses Problem behoben werden?

Gruß

Der_Analyst
DerAnalyst
 
Posts: 4
Joined: 12. April 2004 15:06
XAMPP Version: 5.6.3
Operating System: Windows

Re: php_openssl.dll funktioniert seit XAMPP 1.7.4 nicht mehr

Postby Altrea » 16. March 2012 22:28

Hallo Der_Analyst,

wirklich befriedigend lösen lässt sich das Problem vielleicht nicht. Grund dafür ist, dass Apache mit einer neueren OpenSSL Version kompiliert wurde als PHP. Läuft PHP nun als Apache Modul, so wird auch die SSL Funktionalität von Apache bereitgestellt. Da diese aber eine neuere Version bereit stellt als erwartet kommt es zum Crash.

Du könntest die libeay32.dll und ssleay32.dll aus dem php Ordner ins Apache\bin Ordner kopieren und so Apache sozusagen eine ältere OpenSSL Version unterjubeln. Dies allerdings kann zu Problemen von Apache mit SSL führen.

mit freundlichen Grüßen,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6764
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: php_openssl.dll funktioniert seit XAMPP 1.7.4 nicht mehr

Postby DerAnalyst » 17. March 2012 10:37

Hallo Altrea,

vielen Dank für die schnelle Antwort! Dein Workaround funktioniert :D. Ich habe diese Inkonsistenz als Feedback zur Version 1.8.0 Beta an Apachefriends gemeldet. Dann wird dieser Fehler sicherlich in naher Zukunft behoben sein ...

Grüße

DerAnalyst
DerAnalyst
 
Posts: 4
Joined: 12. April 2004 15:06
XAMPP Version: 5.6.3
Operating System: Windows

Re: php_openssl.dll funktioniert seit XAMPP 1.7.4 nicht mehr

Postby Altrea » 17. March 2012 11:42

DerAnalyst wrote:Ich habe diese Inkonsistenz als Feedback zur Version 1.8.0 Beta an Apachefriends gemeldet. Dann wird dieser Fehler sicherlich in naher Zukunft behoben sein ...

Kommt bei XAMPP 1.8.0 schon PHP 5.4 zum Einsatz wäre OpenSSL 1.0.0 die derzeit verwendet wird sogar die richtige Version.
Ansonsten kommt es ganz darauf an, welche Quellen von Apachelounge für Apache verwendet werden. Diese gibt es sowohl mit OpenSSL 1.0.0 als auch 0.9.8.

mit freundlichen Grüßen,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6764
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 10 guests