[gelöst]PHP include wird nicht geparst?!?

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

[gelöst]PHP include wird nicht geparst?!?

Postby Lucielectric » 09. March 2012 09:20

Liebes Apache-Friends-Team,

ich stehe vor einem Problem und finde keine Lösung.

Ich versuche grade für eine neue Website die Navigation per include-Befehl in die index.php einzubinden.

Wenn ich die index.php dann in Firefox öffne, wird die Navigation nicht angezeigt und im Quelltext wird der PHP-Befehl rosafarben dargestellt.

Habe verschiedene Variationen getestet.

Aktuell siehts so aus

navi.php

Code: Select all
<div id="navi">
              <ul id="navbar">
   <li><a href="#">Startseite</a></li>
   <li><a href="#">&Uuml;ber uns</a>
      <ul class="unternehmen">
      <li class="1"><a href="#">Chronik</a></li>
      <li><a href="#">Firmenpotrait</a></li>
      <li><a href="#">Jobangebote</a></li>
      <li><a href="#">Ausbildung</a></li>
      </ul>
   </li>
   <li><a href="#">Standorte</a>
      <ul class="Standorte">
      <li class="1"><a href="#">Alfter</a></li>
      <li><a href="#">Bonn</a></li>
      <li><a href="#">Blankenheim</a></li>
      <li><a href="#">Düsseldorf</a></li>
      </ul>
   </li>
              
        </div>


Die Stelle in der index.php wo das include steht
Code: Select all
....
<div id="slideshow">
                 <img src="images/headergrafiken/seite-01.jpg" alt="Seite 01" />
               <img src="images/headergrafiken/seite-02.jpg" alt="Seite 02" />
               <img src="images/headergrafiken/seite-03.jpg" alt="Seite 03" />
               <img src="images/headergrafiken/seite-04.jpg" alt="Seite 04" />
               <img src="images/headergrafiken/seite-05.jpg" alt="Seite 05" />
               <script type="text/javascript">

               $('#slideshow').jqFancyTransitions({ width: 660, height: 200, delay: 1000, effect: 'curtain', direction: 'top', stripDelay: 80, strips: 10, titleOpacity: 0.0, position: 'alternate'});

               </script>
              </div>
       
             </div>
             <?php include ('navi.php');?>
             

           <div id="content"></div>
.....
           


Ich weiß einfach nicht mehr weiter. Hab mir schon die Finger wund gesucht und alle möglichen Problemlösungen versucht, aber komme nicht zu einem befriedigenden Ergebnis.

Ich bin kein PHP-Programmierer, erstelle Websites eigentlich eher statisch mit HTML und CSS, den include-Befehl möchte ich nutzen, um einfacher Änderungen in der Navigation machen zu können.

Hat vielleicht jemand eine Idee?

Viele liebe Grüße

Lucielectric
Lucielectric
 
Posts: 2
Joined: 09. March 2012 09:12
Operating System: Windows Xp & Windows 7

Re: PHP include wird nicht geparst?!?

Postby Altrea » 09. March 2012 20:14

Hallo Lucielectric,

Was steht denn in der Adresszeile deines Browsers, sobald der von dir geschilderte Fehler auftritt?

mit freundlichen Grüßen,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8286
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: PHP include wird nicht geparst?!?

Postby Lucielectric » 10. March 2012 10:06

Hallo Altrea,

danke, das war der rettende Hinweis......und ich fühl mich grade wie der absolute DAU!

Natürlich hab ich vergessen, nach dem ich den include eingebaut habe, dass ich vom lokalen Verzeichnis auf den localhost wechsel muss.....Also der Pfad ging über den Rechner und nicht über den Server......Oh mann ich bin auch echt...... :oops: :oops:

Jetzt dürft Ihr alle was gemeines über Frauen und Technik sagen :)

Danke für den Hinweis - ich geh mich jetzt schämen!

LG

Lucielectric
Lucielectric
 
Posts: 2
Joined: 09. March 2012 09:12
Operating System: Windows Xp & Windows 7

Re: PHP include wird nicht geparst?!?

Postby Altrea » 10. March 2012 22:34

Hallo Lucielectric,

Zu deiner Ehrenrettung sei zu sagen, dass dies mindestens genauso oft auch Männern passiert :D Schämen brauchst du dich dafür nicht.
Ich freu mich, dass dein Problem gelöst werden konnte und wünsche dir weiterhin viel Spaß.

mit freundlichen Grüßen,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8286
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 19 guests