Virtual Host "Zugriff verweigert"

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Virtual Host "Zugriff verweigert"

Postby srx » 26. December 2011 01:46

Hallo,

ich nutze Xampp Version Version 1.7.7 auf einem PC mit Windows 7 Professional.

Xampp selbst läuft problemlos. Die Installation eines Virtual Host hingegen gestaltet sich schwierig.

Ich habe in der Datei /extra/httpd-vhosts.conf" folgenden Code eingefügt:

<VirtualHost *:81>
ServerAdmin postmaster@dummy-host2.localhost
DocumentRoot "C:/Projekte/somewebsite"
##ServerName dummy-host2.localhost
##ServerAlias www.dummy-host2.localhost
##ErrorLog "logs/dummy-host2.localhost-error.log"
##CustomLog "logs/dummy-host2.localhost-access.log" combined
</VirtualHost>


Außerdem gibt es in der httpd.conf den Eintrag

Listen 81


Somit kann ich zwar "localhost:81" aufrufen, erhalte aber dann die Fehlermeldung

Zugriff verweigert!

Der Zugriff auf das angeforderte Verzeichnis ist nicht möglich. Entweder ist kein Index-Dokument vorhanden oder das Verzeichnis ist zugriffsgeschützt.

Sofern Sie dies für eine Fehlfunktion des Servers halten, informieren Sie bitte den Webmaster hierüber.
Error 403
localhost
12/26/11 01:22:14
Apache/2.2.21 (Win32) mod_ssl/2.2.21 OpenSSL/1.0.0e PHP/5.3.8 mod_perl/2.0.4 Perl/v5.10.1


Der Versuch die Seite über 127.0.0.1:81 aufzurufen führt zum selben Ergebnis.

Kann mir jemand sagen, wo der Fehler liegt?
Im Verzeichnis "C:/Projekte/somewebsite" gibt es eine "index.html" Datei.

Viele Grüße, frohe Weihnachten und schon mal vielen Dank für Hinweis
-srx-
srx
 
Posts: 1
Joined: 26. December 2011 01:39
Operating System: Windows 7

Re: Virtual Host "Zugriff verweigert"

Postby Altrea » 26. December 2011 10:35

Hallo srx,

srx wrote:Im Verzeichnis "C:/Projekte/somewebsite" gibt es eine "index.html" Datei.

Du hast aber für dieses Verzeichnis sehr wahrscheinlich keine Zugriffsregeln definiert. Und da sich dieses Verzeichnis nicht innerhalb von htdocs befindet (für htdocs hätte eine Zugriffsregel gegriffen), greift nur die Standardregel, die jeden Zugriff abweist.

Lösung
Definiere innerhalb deines VHosts noch einen <Directory> Block (in diesem Fall würde ich dieselben Regeln übernehmen, die bereits für den htdocs Ordner definiert wurden):
Code: Select all
<VirtualHost *:81>
    ServerAdmin postmaster@dummy-host2.localhost
    DocumentRoot "C:/Projekte/somewebsite"
        <Directory "C:/Projekte/somewebsite">
            Options Indexes FollowSymLinks Includes ExecCGI
            AllowOverride All
            Order allow,deny
            Allow from all
        </Directory>
</VirtualHost>


mit freundlichen Grüßen,
Altrea

P.S.: Den <Directory> Block könntest du auch in die Standardkonfigurationsdatei schreiben statt innerhalb des Vhosts. Ich finde es innerhalb des VHosts übersichtlicher, ist aber Geschmackssache.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8286
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 5 guests