[gelöst]Deinstallation verhauen und nun geht nix mehr

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

[gelöst]Deinstallation verhauen und nun geht nix mehr

Postby Mentator » 09. December 2011 00:26

Hallo euch allen,

leider bin ich verdammt neu in der Thematik Xampp, aber ich hatte vor mir mal ne kleine Datenbank zusammen zu basteln und somit bin ich auf Xampp gestoßen.

Habe mittlerweile aber das Problem das ich es wohl kaputt gespielt habe, denn:

Ich habe die Installationsversion von Xampp auf meinen USB Stick gespeichert. Das funktionierte Super, als ich endlich rausfand das ich in 37 Dateien den Pfad so anpassen musste das der Laufwerksbuchstabe nicht beachtet wird, weil ich das ganze auf nem portablen USB haben wollte. Wie gesagt bis dahin alles schickie. Im Freudentaumel habe ich dann erstmal vorgefertigten MYSQL-Datenbanken versucht zu löschen, weil ich ja nur meine haben wollte, ohne auch nur daran zu denken, dass dort wohl einige nicht ganz ohne nutzen sind. Erschrocken habe ich das festgestellt aber keinen "Undo"Button gefunden ;). Also dachte ich mir, kein Ding kopierst du einfach mal die Datenbanken neu rein, aus der zip variante die ich mir dann runtergezogen habe. Aber doof wie ich war habe ich gleich den ganzen Ordner xampp vom usb stick gelöscht, zumindest soweit, das gegen ende knapp 300 Dateien nicht ohne weiteres zu löschen waren. Jetzt habe ich die Zipversion von Xampp versucht drüber zu installieren und zwar diesmal GENAU NACH ANWEISUNG auf der Xampp seite. Hat geklappt, aber Apache udn MySQL verweigern den Dienst. Filezilla und FTP laufen aber, zumindest laut control Panel.

Meine Vermutung nach stundenlanger forshcung ist, das ich durch die löschaktion der installationsversion die Dienste die Windows nun intus hat, zerschossen habe, aber selbst eine manuelle dienst deinstallation mittels der unsinstall von xamp scheint nicht zu helfen. die zipversion sagt per setup.bat das alles schickie ist, aber nach dem start des controlpanel geht nix mehr mit xampp.

Was soll ich tun, (ich denke mal alles runter, und dann nochmal neu und sauber drauf) aber wie bekomme ich die scheinbar fehlerhaften Dienste aus Windows wieder raus. einfaches Deaktivieren scheint ja nicht zu helfen.

Danke für eure Hilfe. Wenn frgaen sind fragt einfach^^

MfG eine neues Mitglied in eurer Runde
Mentator

PS: Ich weiß das ich hier mehr als fahrlässig rangegangen bin und ich verdiene jede beschimpfung seitens dokus lesen und anleitungen beachten..... ! Nur habe ich glaube ich meine lektion gelernt und werd es in zukunft beachten, nur helft mir Bitte hierbei.
Mentator
 
Posts: 2
Joined: 09. December 2011 00:05
Operating System: Windows 7 ultimate

Re: Deinstallation verhauen und nun geht nix mehr

Postby Altrea » 09. December 2011 01:35

Hallo Mentator

Mentator wrote:Habe mittlerweile aber das Problem das ich es wohl kaputt gespielt habe

Och, das passiert auch den besten mal :D

Mentator wrote:Ich habe die Installationsversion von Xampp auf meinen USB Stick gespeichert. Das funktionierte Super, als ich endlich rausfand das ich in 37 Dateien den Pfad so anpassen musste das der Laufwerksbuchstabe nicht beachtet wird, weil ich das ganze auf nem portablen USB haben wollte

Erster Tipp: Wenn du XAMPP auf mobilen Datenträgern "installieren" möchtest, nutze nicht die Installer-Version, sondern die zip-Version, denn die Installer Version führt nach dem entpacken automatisch die setup_xampp.bat Datei aus, welche wiederum die ganzen Pfade korrigiert.
Also: zip Version oder USB version hernehmen und die setup_xampp.bat Datei NICHT ausführen, das erspart das nachträgliche editieren der Pfade an x Stellen.

Mentator wrote:Im Freudentaumel habe ich dann erstmal vorgefertigten MYSQL-Datenbanken versucht zu löschen, weil ich ja nur meine haben wollte, ohne auch nur daran zu denken, dass dort wohl einige nicht ganz ohne nutzen sind.

Zweiter Tipp: Lösche, verschiebe, editiere nichts von dem du keine Ahnung hast, wofür es da ist :D
Ich habe in einem englischen Thread mal zusammengetragen, wofür die einzelnen Tabellen da sind:
viewtopic.php?f=16&t=48615&p=186792&hilit=cdcol#p186792

Mentator wrote:Hat geklappt, aber Apache udn MySQL verweigern den Dienst. Filezilla und FTP laufen aber, zumindest laut control Panel.

Meine Vermutung nach stundenlanger forshcung ist, das ich durch die löschaktion der installationsversion die Dienste die Windows nun intus hat, zerschossen habe

Dritter Tipp: Nutzt du Programme von mobilen Datenträgern, kannst du diese NICHT als Windows Dienst laufen lassen. Windows Dienste benötigen vollqualifizierte absolute Pfade mit Laufwerksbuchstaben, welche bei mobilen Medien nicht immer identisch sind.

Mentator wrote:die zipversion sagt per setup.bat das alles schickie ist, aber nach dem start des controlpanel geht nix mehr mit xampp.

Wie bereits erwähnt, ist die setup_xampp.bat Datei keine gute Idee, wenn du vom USB-Stick starten möchtest.

Mentator wrote:Was soll ich tun, (ich denke mal alles runter, und dann nochmal neu und sauber drauf) aber wie bekomme ich die scheinbar fehlerhaften Dienste aus Windows wieder raus. einfaches Deaktivieren scheint ja nicht zu helfen.

Erstmal musst du schauen, ob es überhaupt an irgendwelchen Diensten liegt. Also rufe dir die Windows Dienstübersicht auf und suche nach jedweden Apache2.2 oder MySQL Diensten. Solltest du welche finden und diese gestartet sein, dann stoppe dort die Dienste. Anschließend kannst du die Dateien \xampp\apache\apache_uninstallservice.bat und \xampp\mysql\mysql_uninstallservice.bat verwenden, um die Dienste komplett zu entfernen.
Beachte, dass Windows 7 eine neue Benutzerkontensteuerung besitzt. .bat Dateien die Systemänderungen ausführen sollen sollten also im Administrator Modus ausgeführt werden (Rechtsklick -> als Administrator ausführen)

Sollte das alles geklappt haben, nimm ein frisches XAMPP 1.7.7 in der zip-version, entpacke es auf den USB-Stick und führe das control panel (am besten direkt das Control Panel v3) aus, auch dieses wiederum im Administrator Modus.

Falls das doch nicht funktionieren sollte würde mir noch einfallen, dass du vielleicht das Microsoft Visual C++ 2008 SP1 Redistributable Package (x86) nicht installiert hast. Das ist Grundvoraussetzung für die aktuelle XAMPP Version.

mit freundlichen Grüßen,
Altrea

P.S.:
Mentator wrote:Ich weiß das ich hier mehr als fahrlässig rangegangen bin und ich verdiene jede beschimpfung seitens dokus lesen und anleitungen beachten..... !

Nene, Beschimpfung verdient keiner für soetwas, aber recht hast du natürlich schon :D
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8298
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Deinstallation verhauen und nun geht nix mehr

Postby Mentator » 09. December 2011 23:33

Aaaaalso, danke erstmal für die schnelle und ausführliche antwort^^.

So, das mit der installversion und dem usb stick klar, hab ich ja selbst mitbekommen^^, nungut.

Hab Visual C++ 2010 drauf mit allen aktuellen Updates und bin aus diesem Grund nicht darauf gekommen, das es die 2008 Sp1 sein muss. habs installiert, aber nix tut sich, glaube auch nicht das es daran lag, denn ich habe Xampp ja schonmal kurz zum laufen bekommen, vom Stick aus inklusive Dienste^^.

Aktuell sind die Dienste aus dem Autostart draußen und werden als Beendet unter allen Windows Diensten angezeigt, und auch im Taskmanager. Starte ich allerdings die Uninstall Dateien von Xampp für Apache und Mysql, so erhalte ich nur die Meldung das es aus ist aber er den Pfad nicht findet (ja habs als Admin ausgeführt, weil ich die Benutzerkontensteuerung komplett deaktiviert habe bei mir ).

Das Controlpanel zeigt mir aber wieder erwarten immer noch ein Häkchen in Apache MySQL und Filezilla an, es lässt sich aber nicht starten, leider.

Bitte also um weitere Hilfe ( hab heute leider kaum noch zeit, aber werd mich morgen mal mit dem DEINSTALLIEREN von Win7 Diensten befassen.


MfG Mentator

EDIT:

ok, hab das Problem gefunden und konnte es lösen. Unter diesem Link (http://hannes-schurig.de/23/03/2010/windows-dienste-loschen-registry-oder-der-sc-befehl/) findet man genau das was man dazu braucht.
Durch das einfach löschen der Install-version vom stick und das verschieben der Zip-Version, waren die Dienste einfach nicht mehr ansprechbar (auch nicht mit den uninstallern).
Hab die Dienste somit manuell entfernt und nochmal nen registryCleaner drüber gejagt. Damit war jetzt alles sauber, und ich konnte die Xampp-Zip version wieder ganz normal starten, auch vom Stick aus.
Wenn noch fragen oder Anregungen bestehen fragt mich einfach. Ich bin vorerst einmal froh, das jetzt alles wieder so läuft wie erwartet^^.

MfG Mentator

PS: braucht man bestimmte Berechtigungen, um Links ein zu fügen?
Mentator
 
Posts: 2
Joined: 09. December 2011 00:05
Operating System: Windows 7 ultimate

Re: Deinstallation verhauen und nun geht nix mehr

Postby Altrea » 10. December 2011 22:07

Mentator wrote:ok, hab das Problem gefunden und konnte es lösen. Unter diesem Link (http://hannes-schurig.de/23/03/2010/win ... sc-befehl/) findet man genau das was man dazu braucht.
Durch das einfach löschen der Install-version vom stick und das verschieben der Zip-Version, waren die Dienste einfach nicht mehr ansprechbar (auch nicht mit den uninstallern).
Hab die Dienste somit manuell entfernt und nochmal nen registryCleaner drüber gejagt. Damit war jetzt alles sauber, und ich konnte die Xampp-Zip version wieder ganz normal starten, auch vom Stick aus.

Vielen Dank für diese Informationen. Freut mich, dass nun alles funktioniert :D

Mentator wrote:PS: braucht man bestimmte Berechtigungen, um Links ein zu fügen?

Man benötigt eine Mindestanzahl an Beiträgen.

Ich markiere den Beitrag mal als gelöst 8)
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8298
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 4 guests