Apache lässt sich nicht starten

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Apache lässt sich nicht starten

Postby neox700 » 14. November 2011 16:40

Hallo!

Habe auf einem Windows Server 2003 XAMPP 1.7.7 installiert, nur leider lässt sich von der Installation der Apache nicht installieren ... auch die Apacheversion ohne SSL lässt sich nicht installieren, erst als ich die Version mit SSL installiert habe (Apache 2.2) lief der Apache.
Jetzt habe ich das Problem, dass mein Apache php nicht interpretieren kann, da ihm das installierte php vom XAMPP anscheinend völlig egal ist.
Am liebsten wäre es mir, wenn die Installation gefixt wird, aber ansonsten bin ich für Tipps und Ratschläge offen, was ich beim Apache machen muss, damit er php interpretieren kann bzw. ich dann auch phpmyadmin starten kann.

Vielen Dank für Eure Hilfe.

PS: Forensuche hat leider kein Ergebnis gebracht :(
neox700
 
Posts: 1
Joined: 14. November 2011 16:35
Operating System: Windows Server 2003

Re: Apache lässt sich nicht starten

Postby Altrea » 15. November 2011 05:55

Hallo neox700,

neox700 wrote:nur leider lässt sich von der Installation der Apache nicht installieren ...

Was bedeutet "installieren" in diesem Zusammenhang?

neox700 wrote:Jetzt habe ich das Problem, dass mein Apache php nicht interpretieren kann, da ihm das installierte php vom XAMPP anscheinend völlig egal ist.

Was ja auch vollkommen richtig ist. PHP ist relativ eigenständig von Apache (beim XAMPP Paket durch die Portabilität noch ein Stück weit mehr, da auf Registryschlüssel und Umgebungsvariablen verzichtet wird)

neox700 wrote:Am liebsten wäre es mir, wenn die Installation gefixt wird

Dazu müssten wir erstmal wissen, was deine Problemschilderung überhaupt bedeutet und dann auf Spurensuche gehen, wo das Problem gelöst werden kann.

Ich würde am ehesten mal aufs fehlende Microsoft Visual C++ 2008 SP1 Redistributable Package (x86) tippen, wenn du Apache nicht starten kannst. Oder auf einen temporären Portkonflikt (was auch erklären würde, weshalb du die Standardapacheinstallation ohne SSL nicht zum Laufen bekommen hast).
Andere Fehlerursachen können auch ein falsch gewähltes Installationsverzeichnis, dazwischenfunkende Sicherheitssoftware, fehlende Betriebssystemrechte sein.
Aber um eine Tendenz erkennen zu können, reicht deine Problemschilderung bei weitem nicht aus.

Also: Alles die ganzen Apache Versionen, die du seitdem installiert hast wieder runterschmeißen und von neuem beginnen.

mit freundlichen Grüßen,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8293
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 7 guests