mysql startet nicht

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

mysql startet nicht

Postby Markus1979 » 13. November 2011 19:13

Hallo zusammen,

ich nutze Xampp nun schon sehr lange, bisher immer problemlos...
vor ein paar tagen hab ich mir einen neuen rechner zusammengebaut mit windows 7 ultimate.

Nachdem ich mir gerade die neuste version (zip) runter geladen habe bekomme ich ich mysql einfach nicht zum starten.

vielleicht hab ihr ja eine idee woran das liegt.

Xampp liegt im Ordner "xampp" auf einer externen USB-Platte

Normalerweise startete es immer problemlos auch ohne die setup_xampp.bat aufzuführen...

die mysql-error sieht wie folgt aus

111113 18:19:34 [Note] Plugin 'FEDERATED' is disabled.
111113 18:19:34 InnoDB: The InnoDB memory heap is disabled
111113 18:19:34 InnoDB: Mutexes and rw_locks use Windows interlocked functions
111113 18:19:34 InnoDB: Compressed tables use zlib 1.2.3
111113 18:19:34 InnoDB: Initializing buffer pool, size = 16.0M
111113 18:19:34 InnoDB: Completed initialization of buffer pool
111113 18:19:34 InnoDB: highest supported file format is Barracuda.
111113 18:19:34 InnoDB: Operating system error number 87 in a file operation.
InnoDB: Some operating system error numbers are described at
InnoDB: http://dev.mysql.com/doc/refman/5.5/en/operating-system-error-codes.html
InnoDB: File name \xampp\mysql\data\ib_logfile0
InnoDB: File operation call: 'aio read'.
InnoDB: Cannot continue operation.


Vielen Dank schon mal und viele Grüße
Markus
Markus1979
 
Posts: 7
Joined: 13. November 2011 18:37
Operating System: win7 ultimate

Re: mysql startet nicht

Postby Markus1979 » 14. November 2011 09:08

Hallo zusammen,

da ich ausschließen wollte, dass es an meinem 64Bit Windows liegt habe ich Xampp heute nochmal im Büro auf WinXp getestet.
Bislang liefe es auch unter XP ohne Probleme, danach habe ich die neueste Version auch auf einem festen Laufwerk versucht
zu starten und hab die gleichen Probme wie beschrieben.

Viele Grüße
Markus
Markus1979
 
Posts: 7
Joined: 13. November 2011 18:37
Operating System: win7 ultimate

Re: mysql startet nicht

Postby Markus1979 » 14. November 2011 18:44

Hallo zusammen,

ich weiß zwar nicht wieso, aber Xampp funktioniert auf einem anderen USB Stick einwandfrei !
Nur auf meiner ext. USB-Festplatte nicht... ich nutze die Festplatte bestimmt schon seit 1,5 Jahren
mit Xampp und hatte nie probleme.

Hab ihr eine idee warum die Platte jetzt auf einmal spinnt?

Bevor die neue Version drauf kopiert wurde, wurde sie komplett formatiert.

Viele grüße
Markus
Markus1979
 
Posts: 7
Joined: 13. November 2011 18:37
Operating System: win7 ultimate

Re: mysql startet nicht

Postby Nobbie » 14. November 2011 21:38

Markus1979 wrote:Hab ihr eine idee warum die Platte jetzt auf einmal spinnt?

Bevor die neue Version drauf kopiert wurde, wurde sie komplett formatiert.


Genau das dürfte das Problem sein - die neue Formatierung erfolgte wahrscheinlich in NTFS (und vormals in FAT32), und NTFS unterstützt das Windows Rechtemanagement. Wenn die Platte (oder der Stick) mit FAT32 formatiert wird, kann jeder darauf schreiben und lesen. Aber bei NTFS wird im Dateisystem protokolliert, welcher User schreiben darf, lesen darf, ändern darf usw. - und genau das ist Dir zum Verhängnis geworden, offensichtlich darf Deine eigene UserId oder "System" (wenn Du Apache als Dienst startest) nicht beliebig zugreifen.

Formatiere die Festplatte einfach noch einmal neu mit FAT32 (wobei das unter Windows nur möglich ist, wenn die Platte < 32GB ist - ansonsten brauchst Du spezielle Tools, die das erledigen) und spiele Xampp erneut darauf, dann wird alles (wie gewohnt) funktionieren.
Nobbie
 
Posts: 8770
Joined: 09. March 2008 13:04

Re: mysql startet nicht

Postby Markus1979 » 15. November 2011 09:18

Hallo Nobbie,

Danke für deine Antwort.

Ich habe die Festplatte gestern mit Parted Magic neu in FAT32 formatiert.
Leider bleibt der Fehler gleich und Mysql startet nicht.

Ich habe die Platte mit Windows auf Fehler überprüft, die Fehleranalyse
ist auch nicht bis zu ende durchgelaufen. Auch das einspielen eines Backups
hat nicht funktioniert... "True Image" meinte dass nicht ausreichend Platz
auf der Platte wäre... Naja, dass Image hatte 200 MB die Platte 120 GB.

Also es scheint als hätte die Platte einen weg, trotzdem kann ich insgesamt
ganz normal mit arbeiten, wird einwandfrei erkannt, Dateien kopiere, verschieben
klappt einwandfrei...

Mir ist im nachhinein auch eingefallen dass die Platte vorher NTSF formatiert war,
da ich schon Dateien von ü 5GB drauf kopiert habe, soweit ich weiß kann FAT32 solle
Dateien nicht speichern.

Gibt es irgendein Tool mit dem man die Festpatte überprüfen und evtl reparieren kann.

Viele Grüße
Markus


PS: Was nutzt ihr als portables Speichermedium für Xampp?
Ich habe noch einen SanDisk Cruzer Contur 8GB, aber der ist mir irgendwie zu langsam
als Server... der Seitenaufbau / -reload dauert ewig.

Macht eine USB 3.0 Festplatte im Bezug auf Schnelligkeit sinn?
Markus1979
 
Posts: 7
Joined: 13. November 2011 18:37
Operating System: win7 ultimate


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 4 guests

cron