MySQL Service started Busy...

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

MySQL Service started Busy...

Postby Muamicus » 12. November 2011 18:57

Hallo, nutze XAMPP schon seit langer Zeit.

Jetzt, kann ich auf einmal unter localhost nichts mehr aufrufen... Er läd....

Klicke ich auf das Control Panel zeigt er mir an das Xampp nicht im "Running" Modus ist.
Klicke uch auf Start Bringt er mir folgende Meldung:

Busy...
MySQL Service started

Folgendes habe ich prpbiert:

- PC neugestartet
- In der Systemsteuerung geschaut ob es da vlt an irgendeinem Systemstart liegen lann - unnützes rausgenommen
→ neugestartet → auch nichts verdächtiges gefunden.

Leider alles ohne Erfolg.

Ich kann nicht einmal mehr localhost/xampp aufrufen

Hoffe einer hatte das gleiche Problem und könnte mir eventuell helfen.

Grüße und danke schon mal.
Muamicus
 
Posts: 12
Joined: 12. November 2011 18:46
Operating System: Windows 7

Re: MySQL Service started Busy...

Postby Altrea » 12. November 2011 19:45

Hallo Muamicus,

Deine verwendeten Begrifflichkeiten sind nicht klar gewählt. Das macht es nicht gerade einfach zu verstehen, was für ein Problem du eigentlich hast.

Muamicus wrote:Jetzt, kann ich auf einmal unter localhost nichts mehr aufrufen... Er läd....

Gut, also funktioniert entweder die Namensauflösung nicht richtig oder dein Apache bekommt den Request garnicht erst, oder dein Apache antwortet nicht richtig.

Um deinen Apache zu überprüfen bietet sich ein Blick in dein \xampp\apache\logs\error.log an. Dort werden Startversuche mitgeloggt.
Vielleicht blockiert irgendein Probramm einen der benötigten Ports.

Um die Namensauflösungssache auszuschließen, versuche es mal über die Loopback Adresse http://127.0.0.1/
Sollte dies funktionieren, ping localhost mal in der Eingabeaufforderung an um zu sehen zu welcher IP es aufgelöst wird
und wirf auchmal einen Blick in deine Windows HOSTS Datei, ob dort irgendetwas im Argen liegt.

Muamicus wrote:Klicke ich auf das Control Panel zeigt er mir an das Xampp nicht im "Running" Modus ist.

XAMPP ist nur eine Ansammlung an Einzelkomponenten. XAMPP hat also keinen "Running"-Modus.
Das einzige was von XAMPP gestartet sein muss ist das Control Panel. Und das ist es ja scheinbar.
Also sei bitte präziser, welcher der Komponenten nicht "Running" ist

Muamicus wrote:Klicke uch auf Start Bringt er mir folgende Meldung:

Busy...
MySQL Service started

Das ist MySQL, das hat aber mit deinem obrigen Problem nichts zu tun, denn der Apache müsste auch ohne MySQL antworten.
Es fällt auch auf, dass du XAMPP-Komponenten als Service registriert hast (das svc-Häkchen gesetzt hast).
Du könntest mal versuchen, das Häkchen wieder herauszunehmen und dann zu starten. Die Services brauchst du nur, wenn die XAMPP Komponenten beim Windows Start mitgestartet werden sollen. Dazu müssen sie aber erstmal wieder richtig funktionieren. Also raus damit.

Mehr kann man dazu erstmal nicht sagen. Und da nicht klar ist, ob du nun ein Problem mit Apache oder MySQL oder beidem oder überhaupt hast, versuch erstmal was ich geschrieben habe.

Glück Auf!
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8293
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: MySQL Service started Busy...

Postby Muamicus » 12. November 2011 19:57

Hallo Altrea,

Um deinen Apache zu überprüfen bietet sich ein Blick in dein \xampp\apache\logs\error.log an. Dort werden Startversuche mitgeloggt.
Vielleicht blockiert irgendein Probramm einen der benötigten Ports.


Dort steht folgendes:

[Sat Nov 12 18:41:55 2011] [notice] Digest: done
[Sat Nov 12 18:41:56 2011] [notice] Child 1792: Child process is running
[Sat Nov 12 18:41:56 2011] [notice] Child 1792: Acquired the start mutex.
[Sat Nov 12 18:41:56 2011] [notice] Child 1792: Starting 150 worker threads.
[Sat Nov 12 18:41:56 2011] [error] (OS 10038)Ein Vorgang bezog sich auf ein Objekt, das kein Socket ist. : winnt_accept: getsockname error on listening socket, is IPv6 available?
[Sat Nov 12 18:41:56 2011] [error] (OS 10038)Ein Vorgang bezog sich auf ein Objekt, das kein Socket ist. : winnt_accept: getsockname error on listening socket, is IPv6 available?
[Sat Nov 12 18:41:56 2011] [error] (OS 10038)Ein Vorgang bezog sich auf ein Objekt, das kein Socket ist. : winnt_accept: getsockname error on listening socket, is IPv6 available?
[Sat Nov 12 18:41:56 2011] [error] (OS 10038)Ein Vorgang bezog sich auf ein Objekt, das kein Socket ist. : winnt_accept: getsockname error on listening socket, is IPv6 available?


Keine Ahnung was damit gemeint ist?

Zu:

Um die Namensauflösungssache auszuschließen, versuche es mal über die Loopback Adresse http://127.0.0.1/
Sollte dies funktionieren, ping localhost mal in der Eingabeaufforderung an um zu sehen zu welcher IP es aufgelöst wird
und wirf auchmal einen Blick in deine Windows HOSTS Datei, ob dort irgendetwas im Argen liegt.


passiert folgendes:

nichts. Er läd bekommt aber scheinbar keine Antwort.

Das ist MySQL, das hat aber mit deinem obrigen Problem nichts zu tun, denn der Apache müsste auch ohne MySQL antworten.
Es fällt auch auf, dass du XAMPP-Komponenten als Service registriert hast (das svc-Häkchen gesetzt hast).
Du könntest mal versuchen, das Häkchen wieder herauszunehmen und dann zu starten. Die Services brauchst du nur, wenn die XAMPP Komponenten beim Windows Start mitgestartet werden sollen. Dazu müssen sie aber erstmal wieder richtig funktionieren. Also raus damit.


Nehme ich das Häkchen raus, klicke auf Start springt er ins "Running" bringt mir aber folgende Fehlermeldung als JS Fenster:

MySQL Server funktioniert nicht richtig. Online nach einem Problem suchen....

Hmmm

Vlt neuinstallieren?

Vielen Dank schon mal.
Muamicus
 
Posts: 12
Joined: 12. November 2011 18:46
Operating System: Windows 7

Re: MySQL Service started Busy...

Postby Muamicus » 12. November 2011 19:59

passiert folgendes:

nichts. Er läd bekommt aber scheinbar keine Antwort.



Man sieht das der Browser die Seite "laden" will. Das wars dann aber auch. Bringt auch keine Fehlermeldung. So als wenn er in einer Endlosschleife wäre...
Muamicus
 
Posts: 12
Joined: 12. November 2011 18:46
Operating System: Windows 7

Re: MySQL Service started Busy...

Postby Altrea » 12. November 2011 23:17

Eine Neuinstallation wäre einen Versuch wert, wenn MySQL sich schon garnichtmehr zum Starten bewegen lässt.
Achte dabei aber darauf, dass du XAMPP vorher vollständig entfernst (alle laufenden Prozesse beenden, zugehörige Windows services entfernen und dann erst die Dateien entfernen. Der uninstaller kann dies in der Regel alles selbst, aber manchmal funktioniert das auchnicht ganz zuverlässig.
Danach den PC neustarten und erst dann XAMPP neuinstallieren.

Vielleicht löst sich durch die Neuinstallation auch dein Apache Problem.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8293
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: MySQL Service started Busy...

Postby Muamicus » 14. November 2011 09:56

Hallo,

habe xampp jetzt deinstalliert. Konnte z.B. den xampp Ordner auf c auch nicht löschen ?

Jetzt habe ich mir xampp erneut installiert. Apache + MySQL stehen auf running.
Leider kann ich noch immer localhost nicht aufrufen :(
Muamicus
 
Posts: 12
Joined: 12. November 2011 18:46
Operating System: Windows 7

Re: MySQL Service started Busy...

Postby Altrea » 14. November 2011 10:56

Muamicus wrote:Konnte z.B. den xampp Ordner auf c auch nicht löschen ?

Dann war noch irgendeine Komponente im Zugriff.
Entweder ein laufender Prozess / Windows-Dienst, oder Windows selbst (Indezierung, oder ähnliches).

Muamicus wrote:Leider kann ich noch immer localhost nicht aufrufen :(

Kannst du auf http://127.0.0.1/xampp/ zugreifen?
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8293
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: MySQL Service started Busy...

Postby Muamicus » 14. November 2011 16:32

Kannst du auf http://127.0.0.1/xampp/ zugreifen?


Nein, leider das gleiche. Er läd und läd....

Habe mir auch ein aktuelles A-Virenprgramm zulegt - kann ja sein das es vlt an was eingefangenem liegt.
Leider auch ohne Erfolg.
Muamicus
 
Posts: 12
Joined: 12. November 2011 18:46
Operating System: Windows 7

Re: MySQL Service started Busy...

Postby Muamicus » 14. November 2011 16:33

In der erroer.php steht wieder:

[Mon Nov 14 10:27:38 2011] [notice] Child 1288: Child process is running
[Mon Nov 14 10:27:38 2011] [notice] Child 1288: Acquired the start mutex.
[Mon Nov 14 10:27:38 2011] [notice] Child 1288: Starting 150 worker threads.
[Mon Nov 14 10:27:38 2011] [error] (OS 10038)Ein Vorgang bezog sich auf ein Objekt, das kein Socket ist. : winnt_accept: getsockname error on listening socket, is IPv6 available?
[Mon Nov 14 10:27:38 2011] [error] (OS 10038)Ein Vorgang bezog sich auf ein Objekt, das kein Socket ist. : winnt_accept: getsockname error on listening socket, is IPv6 available?
[Mon Nov 14 10:27:38 2011] [error] (OS 10038)Ein Vorgang bezog sich auf ein Objekt, das kein Socket ist. : winnt_accept: getsockname error on listening socket, is IPv6 available?
[Mon Nov 14 10:27:38 2011] [error] (OS 10038)Ein Vorgang bezog sich auf ein Objekt, das kein Socket ist. : winnt_accept: getsockname error on listening socket, is IPv6 available?
Muamicus
 
Posts: 12
Joined: 12. November 2011 18:46
Operating System: Windows 7

Re: MySQL Service started Busy...

Postby Muamicus » 14. November 2011 17:04

Habe xampp jetzt noch einmal gelöscht.

Auch der installer sagt mir, dass er xampp auf c:\ nicht löschen kann.

Wo genau kann ich nach eventuell noch laufenden Diensten etc. schauen und sie ggbf löschen ?

Vielen Dank schon mal.
Muamicus
 
Posts: 12
Joined: 12. November 2011 18:46
Operating System: Windows 7

Re: MySQL Service started Busy...

Postby Altrea » 15. November 2011 06:03

Das klingt für mich alles sehr merkwürdig, vorallem deine fehlende Berechtigung Dateien auf C löschen zu können.
Da könnte auch die Windows Benutzerkontensteuerung oder eine Sicherheitssoftware mit im Boot sein.

Nach laufenden Prozessen schaust du am besten mal Windows Task-Manager (Reiter Prozesse) ob da irgendwo ein mysqld oder httpd Prozess zu finden ist, und unter Windows Dienste, ob da ein Apache 2.2 oder MySQL drin steht.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8293
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: MySQL Service started Busy...

Postby Muamicus » 18. November 2011 11:59

Unter Prozesse läuft vieles aber nicht eines der beiden.

Wo finde ich Windows Dienste ?

Wo kann ich einstellen das ich z.B. immer der Admin bin ?

Vielen Dank !
Muamicus
 
Posts: 12
Joined: 12. November 2011 18:46
Operating System: Windows 7


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 14 guests