1.7.7 lite - extension php_intl.dll läuft nicht...

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

1.7.7 lite - extension php_intl.dll läuft nicht...

Postby bekay » 08. November 2011 02:35

Ja, steht bereits alles im Betreff. In 1.7.3 konnte ich noch ohne Problem die php_intl.dll extension aktivieren. Jetzt allerdings steht sie nicht einmal deaktiviert (als in der Form ";extension=php_intl.dll") in der php.ini. Habe die Zeile mal hinzugefügt und Xampp neugestartet, aber das endete nur in einer Kaskade von Fehlermeldungen: Zuerst wurde mir mitgeteilt, dass icuuc46.dll nicht gefunden werden konnte, dann "unable to load dynamic library php_intl.dll" und ein Fehler in der Anwednung httpd.exe. Wie kann ich die Internationalization extension zum Laufen bringen...?
bekay
 
Posts: 1
Joined: 08. November 2011 02:25
Operating System: Win XP

Re: 1.7.7 lite - extension php_intl.dll läuft nicht...

Postby Altrea » 08. November 2011 03:02

Die Lite Version ist aufs wesendlichste reduziert, vielleicht ist deshalb auf den intl support verzichtet worden.
Ich habe aber auch gerade keine Lite Version installiert, um dies zu testen.

Bei der vollständigen XAMPP Installation kannst du php_intl in der php.ini hinzufügen.
Funktioniert zumindest bei meiner Windows XP Testmaschine problemlos.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8290
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: 1.7.7 lite - extension php_intl.dll läuft nicht...

Postby LonelyPixel » 12. November 2011 16:31

Nein, das geht auch nicht. Ich habe grade von 1.7.(irgendwas altes, das bislang ausgereicht hat) auf 1.7.7 aktualisiert. Da es ja keine Upgrades gibt, hab ich das alte xampp-Verzeichnis umbenannt und neu installiert. Jetzt versuche ich mal wieder, alle Änderungen in die neue Version zu übertragen, es macht aber wie gewohnt keinen Spaß.

Wenn ich die Zeile "extension=php_intl.dll" in php.ini einfüge, bekomme ich die Meldung "PHP Startup: Unable to load dynamic library 'C:\xampp\php\ext\php_intl.dll' - Das angegebene Modul wurde nicht gefunden." und danach stürzt Apache ab. Die Datei ist aber da! Was will der denn noch und kann es nur nicht sagen?
LonelyPixel
 
Posts: 23
Joined: 25. April 2010 16:34
Operating System: Windows XP

Re: 1.7.7 lite - extension php_intl.dll läuft nicht...

Postby Altrea » 12. November 2011 16:39

Hallo LonelyPixel,

Bitte ergänze in deinem Profil die Informationen zu deinem Betriebssystem und deiner eingesetzten XAMPP Version.
Das hilft uns sehr dir den Support zukommen lassen zu können, der zu deiner Entwicklungsumgebung passt.

Dann wäre es noch wichtig zu wissen, welche der ganzen XAMPP 1.7.7 Downloads du verwendet hast, damit man das mal nachstellen kann.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8290
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: 1.7.7 lite - extension php_intl.dll läuft nicht...

Postby LonelyPixel » 12. November 2011 20:59

Profil ist aktualisiert. Ich habe den ganz normalen Download genommen, keine Light-Version, einfach das Windows-XAMPP-Setup.
LonelyPixel
 
Posts: 23
Joined: 25. April 2010 16:34
Operating System: Windows XP

Re: 1.7.7 lite - extension php_intl.dll läuft nicht...

Postby Altrea » 12. November 2011 23:09

Die Installer Version? Versuchs mal mit der .zip Version. In manchen Fällen ist diese unauffälliger was Fehler betrifft.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8290
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: 1.7.7 lite - extension php_intl.dll läuft nicht...

Postby srslyUnique » 16. November 2011 13:14

Kopier alle icu* Dateien aus dem /xampp/php/ Verzeichnis nach /xampp/apache/bin/

Danach läuft es ohne Probleme.
srslyUnique
 
Posts: 1
Joined: 16. November 2011 13:13
Operating System: Windows 7 Professional 64bit


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 7 guests

cron